diff options
Diffstat (limited to 'recipes-networking/openvswitch/openvswitch-git')
3 files changed, 159 insertions, 4 deletions
diff --git a/recipes-networking/openvswitch/openvswitch-git/disable_m4_check.patch b/recipes-networking/openvswitch/openvswitch-git/disable_m4_check.patch index 5c86aacc..711a1487 100644 --- a/recipes-networking/openvswitch/openvswitch-git/disable_m4_check.patch +++ b/recipes-networking/openvswitch/openvswitch-git/disable_m4_check.patch | |||
@@ -13,10 +13,10 @@ diff --git a/Makefile.am b/Makefile.am | |||
13 | index ff7d70a..2fc1f13 100644 | 13 | index ff7d70a..2fc1f13 100644 |
14 | --- a/Makefile.am | 14 | --- a/Makefile.am |
15 | +++ b/Makefile.am | 15 | +++ b/Makefile.am |
16 | @@ -189,7 +189,7 @@ CLEAN_LOCAL += clean-pycov | 16 | @@ -187,7 +187,7 @@ CLEAN_LOCAL += clean-pycov |
17 | # Makefile in datapath/linux, needed to get the list of files to | 17 | |
18 | # distribute, requires GNU make extensions. | 18 | # If we're checked out from a Git repository, make sure that every |
19 | if GNU_MAKE | 19 | # file that is in Git is distributed. |
20 | -ALL_LOCAL += dist-hook-git | 20 | -ALL_LOCAL += dist-hook-git |
21 | +# ALL_LOCAL += dist-hook-git | 21 | +# ALL_LOCAL += dist-hook-git |
22 | dist-hook-git: distfiles | 22 | dist-hook-git: distfiles |
diff --git a/recipes-networking/openvswitch/openvswitch-git/openvswitch-add-ptest-7e614671cba3c4e338d1c5003b74a10047d7a8eb.patch b/recipes-networking/openvswitch/openvswitch-git/openvswitch-add-ptest-7e614671cba3c4e338d1c5003b74a10047d7a8eb.patch new file mode 100644 index 00000000..5b53f969 --- /dev/null +++ b/recipes-networking/openvswitch/openvswitch-git/openvswitch-add-ptest-7e614671cba3c4e338d1c5003b74a10047d7a8eb.patch | |||
@@ -0,0 +1,110 @@ | |||
1 | From fb68120ef8aed625b04b2fbd2cb78fc59a7b7432 Mon Sep 17 00:00:00 2001 | ||
2 | From: He Zhe <zhe.he@windriver.com> | ||
3 | Date: Wed, 30 Mar 2016 06:23:45 -0400 | ||
4 | Subject: [PATCH] openvswitch: Add test-install rule to support ptest execution | ||
5 | |||
6 | Signed-off-by: Radu Patriu <radu.patriu@enea.com> | ||
7 | |||
8 | Fix ptest for v2.5 | ||
9 | - Copy certain files from srcdir since it has been different from | ||
10 | build directory. | ||
11 | - Copy more necessary files for new added test cases. | ||
12 | - Modify config files for running on target. | ||
13 | |||
14 | Signed-off-by: He Zhe <zhe.he@windriver.com> | ||
15 | |||
16 | --- | ||
17 | Makefile.am | 1 + | ||
18 | test.mk | 72 +++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++ | ||
19 | 2 files changed, 73 insertions(+) | ||
20 | create mode 100644 test.mk | ||
21 | |||
22 | diff --git a/Makefile.am b/Makefile.am | ||
23 | index ea63acb..ff7d70a 100644 | ||
24 | --- a/Makefile.am | ||
25 | +++ b/Makefile.am | ||
26 | @@ -429,3 +429,4 @@ include windows/automake.mk | ||
27 | include ovn/automake.mk | ||
28 | include selinux/automake.mk | ||
29 | include build-aux/automake.mk | ||
30 | +include test.mk | ||
31 | diff --git a/test.mk b/test.mk | ||
32 | new file mode 100644 | ||
33 | index 0000000..b10a581 | ||
34 | --- /dev/null | ||
35 | +++ b/test.mk | ||
36 | @@ -0,0 +1,74 @@ | ||
37 | +TEST_DEST ?= ${prefix}/lib/openvswitch | ||
38 | +TEST_ROOT ?= ${prefix}/lib/openvswitch | ||
39 | +TEST_DEPEND = | ||
40 | + | ||
41 | +if HAVE_OPENSSL | ||
42 | +TEST_DEPEND += $(TESTPKI_FILES) | ||
43 | +endif | ||
44 | + | ||
45 | +test-install: $(TEST_DEPEND) | ||
46 | + @list='$(noinst_PROGRAMS) $(EXTRA_DIST) $(dist_check_SCRIPTS) $(TEST_DEPEND) tests/atlocal tests/atconfig' ;\ | ||
47 | + install -d $(TEST_DEST)/tests ;\ | ||
48 | + install $(srcdir)/vtep/ovs-vtep $(TEST_DEST)/tests ;\ | ||
49 | + install -d $(TEST_DEST)/python ;\ | ||
50 | + install -d $(TEST_DEST)/python/ovs ;\ | ||
51 | + install -d $(TEST_DEST)/python/ovs/db ;\ | ||
52 | + install -d $(TEST_DEST)/python/ovs/compat ;\ | ||
53 | + install -d $(TEST_DEST)/python/ovs/compat/sortedcontainers ;\ | ||
54 | + install -d $(TEST_DEST)/python/ovs/unixctl ;\ | ||
55 | + install -d $(TEST_DEST)/vswitchd ;\ | ||
56 | + install $(srcdir)/vswitchd/vswitch.ovsschema $(TEST_DEST)/vswitchd ;\ | ||
57 | + install vswitchd/ovs-vswitchd $(TEST_DEST)/vswitchd ;\ | ||
58 | + install -d $(TEST_DEST)/debian ;\ | ||
59 | + install $(srcdir)/debian/ovs-monitor-ipsec $(TEST_DEST)/debian ;\ | ||
60 | + install -d $(TEST_DEST)/build-aux ;\ | ||
61 | + install $(srcdir)/build-aux/check-structs $(TEST_DEST)/build-aux ;\ | ||
62 | + install -d $(TEST_DEST)/xenserver ;\ | ||
63 | + install $(srcdir)/xenserver/usr_share_openvswitch_scripts_ovs-xapi-sync $(TEST_DEST)/xenserver ;\ | ||
64 | + install $(srcdir)/xenserver/opt_xensource_libexec_interface-reconfigure $(TEST_DEST)/xenserver ;\ | ||
65 | + install $(srcdir)/xenserver/opt_xensource_libexec_InterfaceReconfigure.py $(TEST_DEST)/xenserver ;\ | ||
66 | + install $(srcdir)/xenserver/opt_xensource_libexec_InterfaceReconfigureBridge.py $(TEST_DEST)/xenserver ;\ | ||
67 | + install $(srcdir)/xenserver/opt_xensource_libexec_InterfaceReconfigureVswitch.py $(TEST_DEST)/xenserver ;\ | ||
68 | + install -d $(TEST_DEST)/vtep ;\ | ||
69 | + install $(srcdir)/vtep/vtep.ovsschema $(TEST_DEST)/vtep ;\ | ||
70 | + install -d $(TEST_DEST)/ovn ;\ | ||
71 | + install $(srcdir)/ovn/ovn-nb.ovsschema $(TEST_DEST)/ovn ;\ | ||
72 | + install $(srcdir)/ovn/ovn-sb.ovsschema $(TEST_DEST)/ovn ;\ | ||
73 | + install -d $(TEST_DEST)/utilities ;\ | ||
74 | + install $(srcdir)/utilities/ovs-pcap.in $(TEST_DEST)/utilities ;\ | ||
75 | + install $(srcdir)/utilities/ovs-pki.in $(TEST_DEST)/utilities ;\ | ||
76 | + for p in $$list ; do \ | ||
77 | + echo $$p ;\ | ||
78 | + p=$${p#../git/} ;\ | ||
79 | + pre=$${p#tests\/} ;\ | ||
80 | + if test $$pre != $$p ; then \ | ||
81 | + echo installing $$p to $(TEST_DEST)/tests/$$pre ;\ | ||
82 | + if test -f $$p ; then \ | ||
83 | + install $$p $(TEST_DEST)/tests/$$pre ;\ | ||
84 | + else \ | ||
85 | + install $(srcdir)/$$p $(TEST_DEST)/tests/$$pre ;\ | ||
86 | + fi ;\ | ||
87 | + continue ;\ | ||
88 | + fi ;\ | ||
89 | + pre=$${p#python\/ovs\/} ;\ | ||
90 | + if test $$pre != $$p ; then \ | ||
91 | + echo installing $$p to $(TEST_DEST)/python/ovs/$$pre ;\ | ||
92 | + if test -f $$p ; then \ | ||
93 | + install $$p $(TEST_DEST)/python/ovs/$$pre ;\ | ||
94 | + else \ | ||
95 | + install $(srcdir)/$$p $(TEST_DEST)/python/ovs/$$pre ;\ | ||
96 | + fi ;\ | ||
97 | + continue ;\ | ||
98 | + fi; \ | ||
99 | + done ;\ | ||
100 | + sed -i 's|abs_builddir=.*|abs_builddir='"'"'$(TEST_ROOT)/tests'"'"'|g' $(TEST_DEST)/tests/atconfig | ||
101 | + sed -i 's|abs_srcdir=.*|abs_srcdir='"'"'$(TEST_ROOT)/tests'"'"'|g' $(TEST_DEST)/tests/atconfig | ||
102 | + sed -i 's|abs_top_srcdir=.*|abs_top_srcdir='"'"'$(TEST_ROOT)'"'"'|g' $(TEST_DEST)/tests/atconfig | ||
103 | + sed -i 's|abs_top_builddir=.*|abs_top_builddir='"'"'$(TEST_ROOT)'"'"'|g' $(TEST_DEST)/tests/atconfig | ||
104 | + sed -i 's|at_srcdir=.*|at_srcdir='"'"'.'"'"'|g' $(TEST_DEST)/tests/atconfig | ||
105 | + sed -i 's|at_top_srcdir=.*|at_top_srcdir='"'"'..'"'"'|g' $(TEST_DEST)/tests/atconfig | ||
106 | + sed -i 's|at_top_build_prefix=.*|at_top_build_prefix='"'"'../'"'"'|g' $(TEST_DEST)/tests/atconfig | ||
107 | + sed -i 's|^\(.*config\.log.*\)|#\1|g' $(TEST_DEST)/tests/testsuite | ||
108 | + sed -i 's|$$srcdir|$$abs_srcdir|g' $(TEST_DEST)/tests/testsuite | ||
109 | + sed -i 's|ovs-appctl-bashcomp\.bash|/etc/bash_completion.d/ovs-appctl-bashcomp\.bash|g' $(TEST_DEST)/tests/testsuite | ||
110 | + sed -i 's|ovs-vsctl-bashcomp\.bash|/etc/bash_completion.d/ovs-vsctl-bashcomp\.bash|g' $(TEST_DEST)/tests/testsuite | ||
diff --git a/recipes-networking/openvswitch/openvswitch-git/systemd-update-tool-paths.patch b/recipes-networking/openvswitch/openvswitch-git/systemd-update-tool-paths.patch new file mode 100644 index 00000000..9a792e63 --- /dev/null +++ b/recipes-networking/openvswitch/openvswitch-git/systemd-update-tool-paths.patch | |||
@@ -0,0 +1,45 @@ | |||
1 | From f45c0a9d712113417e7b56c199f8576b470695ae Mon Sep 17 00:00:00 2001 | ||
2 | From: Mark Asselstine <mark.asselstine@windriver.com> | ||
3 | Date: Tue, 29 May 2018 18:57:46 +0000 | ||
4 | Subject: [PATCH] systemd: update tool paths | ||
5 | |||
6 | We are using the rhel files but we install our tools in a slightly | ||
7 | different path, update accordingly. | ||
8 | |||
9 | Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> | ||
10 | --- | ||
11 | rhel/usr_lib_systemd_system_ovs-vswitchd.service.in | 4 ++-- | ||
12 | rhel/usr_lib_systemd_system_ovsdb-server.service | 2 +- | ||
13 | 2 files changed, 3 insertions(+), 3 deletions(-) | ||
14 | |||
15 | diff --git a/rhel/usr_lib_systemd_system_ovs-vswitchd.service.in b/rhel/usr_lib_systemd_system_ovs-vswitchd.service.in | ||
16 | index 11b34c6..94c48f8 100644 | ||
17 | --- a/rhel/usr_lib_systemd_system_ovs-vswitchd.service.in | ||
18 | +++ b/rhel/usr_lib_systemd_system_ovs-vswitchd.service.in | ||
19 | @@ -15,8 +15,8 @@ EnvironmentFile=/etc/openvswitch/default.conf | ||
20 | EnvironmentFile=-/etc/sysconfig/openvswitch | ||
21 | EnvironmentFile=-/run/openvswitch/useropts | ||
22 | @begin_dpdk@ | ||
23 | -ExecStartPre=-/bin/sh -c '/usr/bin/chown :$${OVS_USER_ID##*:} /dev/hugepages' | ||
24 | -ExecStartPre=-/usr/bin/chmod 0775 /dev/hugepages | ||
25 | +ExecStartPre=-/bin/sh -c '/bin/chown :$${OVS_USER_ID##*:} /dev/hugepages' | ||
26 | +ExecStartPre=-/bin/chmod 0775 /dev/hugepages | ||
27 | @end_dpdk@ | ||
28 | ExecStart=/usr/share/openvswitch/scripts/ovs-ctl \ | ||
29 | --no-ovsdb-server --no-monitor --system-id=random \ | ||
30 | diff --git a/rhel/usr_lib_systemd_system_ovsdb-server.service b/rhel/usr_lib_systemd_system_ovsdb-server.service | ||
31 | index 0fa57a9..75c9e02 100644 | ||
32 | --- a/rhel/usr_lib_systemd_system_ovsdb-server.service | ||
33 | +++ b/rhel/usr_lib_systemd_system_ovsdb-server.service | ||
34 | @@ -10,7 +10,7 @@ Type=forking | ||
35 | Restart=on-failure | ||
36 | EnvironmentFile=/etc/openvswitch/default.conf | ||
37 | EnvironmentFile=-/etc/sysconfig/openvswitch | ||
38 | -ExecStartPre=/usr/bin/chown ${OVS_USER_ID} /var/run/openvswitch | ||
39 | +ExecStartPre=/bin/chown ${OVS_USER_ID} /var/run/openvswitch | ||
40 | ExecStartPre=/bin/sh -c 'rm -f /run/openvswitch/useropts; if [ "$${OVS_USER_ID/:*/}" != "root" ]; then /usr/bin/echo "OVSUSER=--ovs-user=${OVS_USER_ID}" > /run/openvswitch/useropts; fi' | ||
41 | EnvironmentFile=-/run/openvswitch/useropts | ||
42 | ExecStart=/usr/share/openvswitch/scripts/ovs-ctl \ | ||
43 | -- | ||
44 | 2.7.4 | ||
45 | |||