summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-xilinx-core/recipes-bsp/u-boot/u-boot-tools-xlnx_2022.1.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/meta-xilinx-core/recipes-bsp/u-boot/u-boot-tools-xlnx_2022.1.bb b/meta-xilinx-core/recipes-bsp/u-boot/u-boot-tools-xlnx_2022.1.bb
index eaf8d4ce..94369955 100644
--- a/meta-xilinx-core/recipes-bsp/u-boot/u-boot-tools-xlnx_2022.1.bb
+++ b/meta-xilinx-core/recipes-bsp/u-boot/u-boot-tools-xlnx_2022.1.bb
@@ -19,3 +19,20 @@ do_compile () {
19 oe_runmake -C ${S} cross_tools NO_SDL=1 O=${B} 19 oe_runmake -C ${S} cross_tools NO_SDL=1 O=${B}
20} 20}
21 21
22# mkeficapsule is not available in this version of u-boot
23PROVIDES:remove = "${MLPREFIX}u-boot-mkeficapsule"
24PROVIDES:class-native:remove = "u-boot-mkeficapsule-native"
25PACKAGES:remove = "${PN}-mkeficapsule"
26RDEPENDS:${PN}:remove = "${PN}-mkeficapsule"
27
28do_install:prepend() {
29 # Avoid do_install failure
30 mkdir -p tools
31 touch tools/mkeficapsule
32}
33
34do_install:append() {
35 # Avoid failure
36 rm -rf ${D}${bindir}/uboot-mkeficapsule
37 rm -rf ${D}${bindir}/mkeficapsule
38}