summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--docs/README.booting.versal.md28
-rw-r--r--docs/README.booting.zynqmp.md52
-rw-r--r--meta-microblaze/recipes-devtools/gdb/gdb-microblaze.inc1
-rw-r--r--meta-microblaze/recipes-devtools/gdb/gdb/0009-gdb-gdserver-Fix-ABI-settings-for-gdbserver.patch33
-rw-r--r--meta-xilinx-core/conf/machine/include/machine-xilinx-default.inc4
-rw-r--r--meta-xilinx-core/dynamic-layers/virtualization-layer/recipes-kernel/lopper/lopper_git.bbappend2
-rw-r--r--meta-xilinx-core/recipes-bsp/u-boot/u-boot-xlnx-2023.2.inc6
-rw-r--r--meta-xilinx-core/recipes-bsp/u-boot/u-boot-xlnx-2024.1.inc2
-rw-r--r--meta-xilinx-core/recipes-kernel/linux/linux-xlnx_2024.1.bb2
-rw-r--r--meta-xilinx-core/recipes-xrt/xrt/xrt.inc2
-rw-r--r--meta-xilinx-core/recipes-xrt/xrt/xrt/disable_aie_profiling.patch17
-rw-r--r--meta-xilinx-core/recipes-xrt/xrt/xrt_git.bb1
-rw-r--r--meta-xilinx-standalone-experimental/README.md13
-rw-r--r--meta-xilinx-standalone-experimental/conf/layer.conf3
-rw-r--r--meta-xilinx-standalone/classes/xlnx-embeddedsw.bbclass2
-rw-r--r--meta-xilinx-virtualization/README.md11
16 files changed, 129 insertions, 50 deletions
diff --git a/docs/README.booting.versal.md b/docs/README.booting.versal.md
index 4f673689..25738784 100644
--- a/docs/README.booting.versal.md
+++ b/docs/README.booting.versal.md
@@ -133,20 +133,27 @@ Below example uses base DDR address as 0x0 which matches in vivado address edito
133 133
134| Image Type | Base DDR Address | Image Offset | Load Address in DDR | 134| Image Type | Base DDR Address | Image Offset | Load Address in DDR |
135|--------------------|------------------|--------------|---------------------| 135|--------------------|------------------|--------------|---------------------|
136| Kernel | 0x0 | 0x200000 | 0x200000 | 136| Linux Kernel | 0x0 | 0x200000 | 0x200000 |
137| Device Tree | 0x0 | 0x1000 | 0x1000 | 137| Device Tree Blob | 0x0 | 0x1000 | 0x1000 |
138| Rootfs | 0x0 | 0x4000000 | 0x4000000 | 138| Rootfs | 0x0 | 0x4000000 | 0x4000000 |
139| U-boot boot script | 0x0 | 0x20000000 | 0x20000000 | 139| U-boot boot script | 0x0 | 0x20000000 | 0x20000000 |
140 140
1412. **Xen** 1412. **Xen**
142 142
143> **Note:** Xen, Rootfs and Device Tree image offset is calculated as shown below.
144> * `Xen Rootfs = Base DDR Address + Linux Kernel Image Offset(0xE00000) + Size of Linux Kernel Image`
145> * `Xen Kernel = Base DDR Address + Xen Rootfs Image Offset (Ex: 0x2600000) + Size of Xen Rootfs`
146> * `Device Tree Blob = Base DDR Address + Xen Kernel Image Offset (Ex: 0xBA00000) + Size of Device Tree Blob`
147
143| Image Type | Base DDR Address | Image Offset | Load Address in DDR | 148| Image Type | Base DDR Address | Image Offset | Load Address in DDR |
144|--------------------|------------------|--------------|---------------------| 149|--------------------|------------------|--------------|---------------------|
145| Kernel | 0x0 | 0xE00000 | 0xE00000 | 150| Linux Kernel | 0x0 | 0xE00000 | 0xE00000 |
146| Device Tree | 0x0 | 0xC000000 | 0xc000000 | 151| Xen Rootfs | 0x0 | 0x2600000 | 0x2600000 |
147| Rootfs | 0x0 | 0x02600000 | 0x02600000 | 152| Xen Kernel | 0x0 | 0xBA00000 | 0xBA00000 |
153| Device Tree Blob | 0x0 | 0xC000000 | 0xC000000 |
148| U-boot boot script | 0x0 | 0x20000000 | 0x20000000 | 154| U-boot boot script | 0x0 | 0x20000000 | 0x20000000 |
149 155
156
150> **Note:** 157> **Note:**
151> 1. `<target-image>` refers to core-image-minimal or petalinux-image-minimal 158> 1. `<target-image>` refers to core-image-minimal or petalinux-image-minimal
152> 2. For pxeboot boot create a symlink for `<target-image>-${MACHINE}-${DATETIME}.cpio.gz.u-boot` 159> 2. For pxeboot boot create a symlink for `<target-image>-${MACHINE}-${DATETIME}.cpio.gz.u-boot`
@@ -176,12 +183,14 @@ xsdb% stop
176 xsdb% dow -data ${DEPLOY_DIR_IMAGE}/core-image-minimal-${MACHINE}.cpio.gz.u-boot 0x4000000 183 xsdb% dow -data ${DEPLOY_DIR_IMAGE}/core-image-minimal-${MACHINE}.cpio.gz.u-boot 0x4000000
177 xsdb% dow -data ${DEPLOY_DIR_IMAGE}/boot.scr 0x20000000 184 xsdb% dow -data ${DEPLOY_DIR_IMAGE}/boot.scr 0x20000000
178 ``` 185 ```
186
179 * Xen XSDB 187 * Xen XSDB
180 ``` 188 ```
181 xsdb% targets -set -nocase -filter {name =~ "*A72*#0"} 189 xsdb% targets -set -nocase -filter {name =~ "*A72*#0"}
182 xsdb% dow -data ${DEPLOY_DIR_IMAGE}/Image 0xE00000 190 xsdb% dow -data ${DEPLOY_DIR_IMAGE}/Image 0xE00000
183 xsdb% dow -data ${DEPLOY_DIR_IMAGE}/system.dtb 0xc000000 191 xsdb% dow -data ${DEPLOY_DIR_IMAGE}/core-image-minimal-${MACHINE}.cpio.gz 0x2600000
184 xsdb% dow -data ${DEPLOY_DIR_IMAGE}/core-image-minimal-${MACHINE}.cpio.gz 0x02600000 192 xsdb% dow -data ${DEPLOY_DIR_IMAGE}/xen 0xBA00000
193 xsdb% dow -data ${DEPLOY_DIR_IMAGE}/system.dtb 0xC000000
185 xsdb% dow -data ${DEPLOY_DIR_IMAGE}/boot.scr 0x20000000 194 xsdb% dow -data ${DEPLOY_DIR_IMAGE}/boot.scr 0x20000000
186 ``` 195 ```
187 196
@@ -208,9 +217,10 @@ Versal> set ipaddr <board ip>
208 ``` 217 ```
209 U-Boot> tftpboot 0xE00000 Image 218 U-Boot> tftpboot 0xE00000 Image
210 U-Boot> setenv kernel_size 0x$filesize 219 U-Boot> setenv kernel_size 0x$filesize
211 U-Boot> tftpboot 0xc000000 system.dtb 220 U-Boot> tftpboot 0x2600000 core-image-minimal-${MACHINE}.cpio.gz
212 U-Boot> tftpboot 0x02600000 core-image-minimal-${MACHINE}.cpio.gz
213 U-Boot> setenv ramdisk_size 0x$filesize 221 U-Boot> setenv ramdisk_size 0x$filesize
222 U-Boot> tftpboot 0xBA00000 xen
223 U-Boot> tftpboot 0xC000000 system.dtb
214 U-Boot> tftpboot 0x20000000 boot.scr 224 U-Boot> tftpboot 0x20000000 boot.scr
215 ``` 225 ```
216 226
diff --git a/docs/README.booting.zynqmp.md b/docs/README.booting.zynqmp.md
index 3b73dbbb..44e6f2b7 100644
--- a/docs/README.booting.zynqmp.md
+++ b/docs/README.booting.zynqmp.md
@@ -132,7 +132,10 @@ xsdb% rst -processor -clear-registers
132xsdb% dow ${DEPLOY_DIR_IMAGE}/zynqmp_fsbl.elf 132xsdb% dow ${DEPLOY_DIR_IMAGE}/zynqmp_fsbl.elf
133xsdb% con 133xsdb% con
134``` 134```
1357. Now download TF-A, U-boot.elf and Device tree to APU and execute. 1357. Now download TF-A, U-boot.elf and Device tree blob to APU and execute.
136
137> **Note:** For Xen boot system.dtb load address will vary, see below table.
138
136``` 139```
137xsdb% stop 140xsdb% stop
138xsdb% dow ${DEPLOY_DIR_IMAGE}/bl31.elf 141xsdb% dow ${DEPLOY_DIR_IMAGE}/bl31.elf
@@ -159,18 +162,24 @@ Below example uses base DDR address as 0x0 which matches in vivado address edito
159 162
160| Image Type | Base DDR Address | Image Offset | Load Address in DDR | 163| Image Type | Base DDR Address | Image Offset | Load Address in DDR |
161|--------------------|------------------|--------------|---------------------| 164|--------------------|------------------|--------------|---------------------|
162| Kernel | 0x0 | 0x200000 | 0x200000 | 165| Linux Kernel | 0x0 | 0x200000 | 0x200000 |
163| Device Tree | 0x0 | 0x1000 | 0x1000 | 166| Device Tree Blob | 0x0 | 0x100000 | 0x100000 |
164| Rootfs | 0x0 | 0x04000000 | 0x4000000 | 167| Rootfs | 0x0 | 0x04000000 | 0x4000000 |
165| U-boot boot script | 0x0 | 0x20000000 | 0x20000000 | 168| U-boot boot script | 0x0 | 0x20000000 | 0x20000000 |
166 169
1672. **Xen** 1702. **Xen**
168 171
172> **Note:** Xen, Rootfs and Device Tree image offset is calculated as shown below.
173> * `Xen Rootfs = Base DDR Address + Linux Kernel Image Offset(0xE00000) + Size of Linux Kernel Image`
174> * `Xen Kernel = Base DDR Address + Xen Rootfs Image Offset (Ex: 0x2600000) + Size of Xen Rootfs`
175> * `Device Tree Blob = Base DDR Address + Xen Kernel Image Offset (Ex: 0xBA00000) + Size of Device Tree Blob`
176
169| Image Type | Base DDR Address | Image Offset | Load Address in DDR | 177| Image Type | Base DDR Address | Image Offset | Load Address in DDR |
170|--------------------|------------------|--------------|---------------------| 178|--------------------|------------------|--------------|---------------------|
171| Kernel | 0x0 | 0xE00000 | 0xE00000 | 179| Linux Kernel | 0x0 | 0xE00000 | 0xE00000 |
172| Device Tree | 0x0 | 0xC000000 | 0xc000000 | 180| Xen Rootfs | 0x0 | 0x2600000 | 0x2600000 |
173| Rootfs | 0x0 | 0x02600000 | 0x02600000 | 181| Xen Kernel | 0x0 | 0xBA00000 | 0xBA00000 |
182| Device Tree Blob | 0x0 | 0xC000000 | 0xC000000 |
174| U-boot boot script | 0x0 | 0x20000000 | 0x20000000 | 183| U-boot boot script | 0x0 | 0x20000000 | 0x20000000 |
175 184
176> **Note:** 185> **Note:**
@@ -202,12 +211,14 @@ xsdb% stop
202 xsdb% dow -data ${DEPLOY_DIR_IMAGE}/core-image-minimal-${MACHINE}.cpio.gz.u-boot 0x4000000 211 xsdb% dow -data ${DEPLOY_DIR_IMAGE}/core-image-minimal-${MACHINE}.cpio.gz.u-boot 0x4000000
203 xsdb% dow -data ${DEPLOY_DIR_IMAGE}/boot.scr 0x20000000 212 xsdb% dow -data ${DEPLOY_DIR_IMAGE}/boot.scr 0x20000000
204 ``` 213 ```
214
205 * Xen XSDB 215 * Xen XSDB
206 ``` 216 ```
207 xsdb% targets -set -nocase -filter {name =~ "*A53*#0"} 217 xsdb% targets -set -nocase -filter {name =~ "*A53*#0"}
208 xsdb% dow -data ${DEPLOY_DIR_IMAGE}/Image 0xE00000 218 xsdb% dow -data ${DEPLOY_DIR_IMAGE}/Image 0xE00000
209 xsdb% dow -data ${DEPLOY_DIR_IMAGE}/system.dtb 0xc000000 219 xsdb% dow -data ${DEPLOY_DIR_IMAGE}/core-image-minimal-${MACHINE}.cpio.gz 0x2600000
210 xsdb% dow -data ${DEPLOY_DIR_IMAGE}/core-image-minimal-${MACHINE}.cpio.gz 0x02600000 220 xsdb% dow -data ${DEPLOY_DIR_IMAGE}/xen 0xBA00000
221 xsdb% dow -data ${DEPLOY_DIR_IMAGE}/system.dtb 0xC000000
211 xsdb% dow -data ${DEPLOY_DIR_IMAGE}/boot.scr 0x20000000 222 xsdb% dow -data ${DEPLOY_DIR_IMAGE}/boot.scr 0x20000000
212 ``` 223 ```
213 224
@@ -221,13 +232,26 @@ ZynqMP> set serverip <host-server-ip-address>
221ZynqMP> set ipaddr <board-ip-address> 232ZynqMP> set ipaddr <board-ip-address>
222``` 233```
2233. Load the images to DDR address. 2343. Load the images to DDR address.
224```
225U-Boot> tftpboot 0x200000 Image
226U-Boot> tftpboot 0x100000 system.dtb
227U-Boot> tftpboot 0x4000000 core-image-minimal-${MACHINE}.cpio.gz.u-boot
228U-Boot> tftpboot 0x20000000 boot.scr
229 235
230``` 236 * Linux TFTP
237 ```
238 U-Boot> tftpboot 0x200000 Image
239 U-Boot> tftpboot 0x100000 system.dtb
240 U-Boot> tftpboot 0x4000000 core-image-minimal-${MACHINE}.cpio.gz.u-boot
241 U-Boot> tftpboot 0x20000000 boot.scr
242 ```
243
244 * Xen TFTP
245 ```
246 U-Boot> tftpboot 0xE00000 Image
247 U-Boot> setenv kernel_size 0x$filesize
248 U-Boot> tftpboot 0x2600000 core-image-minimal-${MACHINE}.cpio.gz
249 U-Boot> setenv ramdisk_size 0x$filesize
250 U-Boot> tftpboot 0xBA00000 xen
251 U-Boot> tftpboot 0xC000000 system.dtb
252 U-Boot> tftpboot 0x20000000 boot.scr
253 ```
254
231##### Booting Linux 255##### Booting Linux
232 256
233Once the images are loaded continue the execution. 257Once the images are loaded continue the execution.
diff --git a/meta-microblaze/recipes-devtools/gdb/gdb-microblaze.inc b/meta-microblaze/recipes-devtools/gdb/gdb-microblaze.inc
index 5eae0577..d3618229 100644
--- a/meta-microblaze/recipes-devtools/gdb/gdb-microblaze.inc
+++ b/meta-microblaze/recipes-devtools/gdb/gdb-microblaze.inc
@@ -13,4 +13,5 @@ SRC_URI:append:microblaze = " \
13 file://0006-Patch-MicroBlaze-these-changes-will-make-64-bit-vect.patch \ 13 file://0006-Patch-MicroBlaze-these-changes-will-make-64-bit-vect.patch \
14 file://0007-Patch-MicroBlaze-Added-m64-abi-for-64-bit-target-des.patch \ 14 file://0007-Patch-MicroBlaze-Added-m64-abi-for-64-bit-target-des.patch \
15 file://0008-Patch-MicroBlaze.patch \ 15 file://0008-Patch-MicroBlaze.patch \
16 file://0009-gdb-gdserver-Fix-ABI-settings-for-gdbserver.patch \
16 " 17 "
diff --git a/meta-microblaze/recipes-devtools/gdb/gdb/0009-gdb-gdserver-Fix-ABI-settings-for-gdbserver.patch b/meta-microblaze/recipes-devtools/gdb/gdb/0009-gdb-gdserver-Fix-ABI-settings-for-gdbserver.patch
new file mode 100644
index 00000000..93f67800
--- /dev/null
+++ b/meta-microblaze/recipes-devtools/gdb/gdb/0009-gdb-gdserver-Fix-ABI-settings-for-gdbserver.patch
@@ -0,0 +1,33 @@
1From 53b76bb548720367032a51a6d604c975b10bb30e Mon Sep 17 00:00:00 2001
2From: Aayush Misra <aayushm@amd.com>
3Date: Fri, 29 Mar 2024 14:59:16 +0530
4Subject: [PATCH] gdb/gdserver: Fix ABI settings for gdbserver
5
6---
7 gdb/microblaze-tdep.c | 7 ++++---
8 1 file changed, 4 insertions(+), 3 deletions(-)
9
10diff --git a/gdb/microblaze-tdep.c b/gdb/microblaze-tdep.c
11index 38ba38e8c7d..35cec286d8f 100644
12--- a/gdb/microblaze-tdep.c
13+++ b/gdb/microblaze-tdep.c
14@@ -1120,12 +1120,13 @@ void _initialize_microblaze_tdep ();
15 void
16 _initialize_microblaze_tdep ()
17 {
18+ //Setting abi to auto manually, should be able to modify in 'arch'_gdbarch_init function
19+ microblaze_abi_string = microblaze_abi_strings[0];
20+
21 register_gdbarch_init (bfd_arch_microblaze, microblaze_gdbarch_init);
22-// static struct cmd_list_element *setmicroblazecmdlist = NULL;
23-// static struct cmd_list_element *showmicroblazecmdlist = NULL;
24
25- /* Add root prefix command for all "set microblaze"/"show microblaze" commands. */
26
27+ /* Add root prefix command for all "set microblaze"/"show microblaze" commands. */
28 add_setshow_prefix_cmd ("microblaze", no_class,
29 _("Various microblaze specific commands."),
30 _("Various microblaze specific commands."),
31--
322.34.1
33
diff --git a/meta-xilinx-core/conf/machine/include/machine-xilinx-default.inc b/meta-xilinx-core/conf/machine/include/machine-xilinx-default.inc
index c732523c..1837da26 100644
--- a/meta-xilinx-core/conf/machine/include/machine-xilinx-default.inc
+++ b/meta-xilinx-core/conf/machine/include/machine-xilinx-default.inc
@@ -23,6 +23,10 @@ PREFERRED_PROVIDER_u-boot-tools ??= "u-boot-tools-xlnx"
23PREFERRED_PROVIDER_u-boot-tools-native ??= "u-boot-tools-xlnx-native" 23PREFERRED_PROVIDER_u-boot-tools-native ??= "u-boot-tools-xlnx-native"
24PREFERRED_PROVIDER_nativesdk-u-boot-tools ??= "nativesdk-u-boot-tools-xlnx" 24PREFERRED_PROVIDER_nativesdk-u-boot-tools ??= "nativesdk-u-boot-tools-xlnx"
25 25
26# Libmetal and OpenAMP Configuration
27PREFERRED_PROVIDER_libmetal ?= "libmetal-xlnx"
28PREFERRED_PROVIDER_open-amp ?= "open-amp-xlnx"
29
26do_image_wic[depends] += "${@' '.join('%s:do_deploy' % r for r in (d.getVar('WIC_DEPENDS') or "").split())}" 30do_image_wic[depends] += "${@' '.join('%s:do_deploy' % r for r in (d.getVar('WIC_DEPENDS') or "").split())}"
27 31
28UBOOT_SUFFIX ?= "bin" 32UBOOT_SUFFIX ?= "bin"
diff --git a/meta-xilinx-core/dynamic-layers/virtualization-layer/recipes-kernel/lopper/lopper_git.bbappend b/meta-xilinx-core/dynamic-layers/virtualization-layer/recipes-kernel/lopper/lopper_git.bbappend
index 62a3b0f2..6e31d1f0 100644
--- a/meta-xilinx-core/dynamic-layers/virtualization-layer/recipes-kernel/lopper/lopper_git.bbappend
+++ b/meta-xilinx-core/dynamic-layers/virtualization-layer/recipes-kernel/lopper/lopper_git.bbappend
@@ -1,5 +1,5 @@
1SRC_URI = "git://github.com/devicetree-org/lopper.git;branch=v0.2024.x;protocol=https" 1SRC_URI = "git://github.com/devicetree-org/lopper.git;branch=v0.2024.x;protocol=https"
2SRCREV = "a85a86eba10c7cd0f8aa4c99aa647ae8bdd72d70" 2SRCREV = "9e880fa8bad815f01ca8ec4a3e141e5386f012fd"
3 3
4FILESEXTRAPATHS:prepend := "${THISDIR}/lopper:" 4FILESEXTRAPATHS:prepend := "${THISDIR}/lopper:"
5 5
diff --git a/meta-xilinx-core/recipes-bsp/u-boot/u-boot-xlnx-2023.2.inc b/meta-xilinx-core/recipes-bsp/u-boot/u-boot-xlnx-2023.2.inc
index 0a813d69..33b302e9 100644
--- a/meta-xilinx-core/recipes-bsp/u-boot/u-boot-xlnx-2023.2.inc
+++ b/meta-xilinx-core/recipes-bsp/u-boot/u-boot-xlnx-2023.2.inc
@@ -15,3 +15,9 @@ HAS_PLATFORM_INIT ?= " \
15 " 15 "
16 16
17DEPENDS += "bc-native dtc-native python3-setuptools-native gnutls-native" 17DEPENDS += "bc-native dtc-native python3-setuptools-native gnutls-native"
18
19SRC_URI:append:microblaze = " file://microblaze-generic-top.h"
20
21do_configure:prepend:microblaze () {
22 install ${WORKDIR}/microblaze-generic-top.h ${S}/include/configs/
23}
diff --git a/meta-xilinx-core/recipes-bsp/u-boot/u-boot-xlnx-2024.1.inc b/meta-xilinx-core/recipes-bsp/u-boot/u-boot-xlnx-2024.1.inc
index 08e625c2..b919b230 100644
--- a/meta-xilinx-core/recipes-bsp/u-boot/u-boot-xlnx-2024.1.inc
+++ b/meta-xilinx-core/recipes-bsp/u-boot/u-boot-xlnx-2024.1.inc
@@ -2,7 +2,7 @@ UBOOT_VERSION = "v2024.01"
2 2
3UBRANCH = "xlnx_rebase_v2024.01" 3UBRANCH = "xlnx_rebase_v2024.01"
4 4
5SRCREV = "c0dbd5ec673441d8d8de4ac03a3b92c9512bfd6e" 5SRCREV = "12c2fe646e7e98ba98334c75e082cc10faf0413d"
6 6
7LICENSE = "GPL-2.0-or-later" 7LICENSE = "GPL-2.0-or-later"
8LIC_FILES_CHKSUM = "file://README;beginline=1;endline=4;md5=744e7e3bb0c94b4b9f6b3db3bf893897" 8LIC_FILES_CHKSUM = "file://README;beginline=1;endline=4;md5=744e7e3bb0c94b4b9f6b3db3bf893897"
diff --git a/meta-xilinx-core/recipes-kernel/linux/linux-xlnx_2024.1.bb b/meta-xilinx-core/recipes-kernel/linux/linux-xlnx_2024.1.bb
index 019e9de9..8f65469a 100644
--- a/meta-xilinx-core/recipes-kernel/linux/linux-xlnx_2024.1.bb
+++ b/meta-xilinx-core/recipes-kernel/linux/linux-xlnx_2024.1.bb
@@ -1,7 +1,7 @@
1LINUX_VERSION = "6.6.10" 1LINUX_VERSION = "6.6.10"
2YOCTO_META ?= "git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-6.6;destsuffix=yocto-kmeta" 2YOCTO_META ?= "git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-6.6;destsuffix=yocto-kmeta"
3KBRANCH="xlnx_rebase_v6.6_LTS" 3KBRANCH="xlnx_rebase_v6.6_LTS"
4SRCREV = "562194b7c36184701c8774d1a07da07deeae374b" 4SRCREV = "dcac89c7c78a556240e07ac3c6c568dd5be90ef3"
5SRCREV_meta = "5d0809d0d939c7738cb6e5391126c73fd0e4e865" 5SRCREV_meta = "5d0809d0d939c7738cb6e5391126c73fd0e4e865"
6 6
7KCONF_AUDIT_LEVEL="0" 7KCONF_AUDIT_LEVEL="0"
diff --git a/meta-xilinx-core/recipes-xrt/xrt/xrt.inc b/meta-xilinx-core/recipes-xrt/xrt/xrt.inc
index 89dc87cc..7c2e932c 100644
--- a/meta-xilinx-core/recipes-xrt/xrt/xrt.inc
+++ b/meta-xilinx-core/recipes-xrt/xrt/xrt.inc
@@ -3,7 +3,7 @@ BRANCHARG = "${@['nobranch=1', 'branch=${BRANCH}'][d.getVar('BRANCH', True) != '
3SRC_URI = "${REPO};${BRANCHARG};name=xrt" 3SRC_URI = "${REPO};${BRANCHARG};name=xrt"
4 4
5BRANCH= "master" 5BRANCH= "master"
6SRCREV_xrt = "8426f5733c01018acbd8d12745bc9e5ffc4535e6" 6SRCREV_xrt = "f23d53edd42fea0f0acd08c194b4750ed77127e2"
7PV = "202320.2.17.0" 7PV = "202320.2.17.0"
8 8
9SRC_URI += "git://github.com/Xilinx/dma_ip_drivers.git;branch=master;name=dma_ip_drivers;destsuffix=git/src/runtime_src/core/pcie/driver/linux/xocl/lib/libqdma;protocol=https" 9SRC_URI += "git://github.com/Xilinx/dma_ip_drivers.git;branch=master;name=dma_ip_drivers;destsuffix=git/src/runtime_src/core/pcie/driver/linux/xocl/lib/libqdma;protocol=https"
diff --git a/meta-xilinx-core/recipes-xrt/xrt/xrt/disable_aie_profiling.patch b/meta-xilinx-core/recipes-xrt/xrt/xrt/disable_aie_profiling.patch
deleted file mode 100644
index f2f63470..00000000
--- a/meta-xilinx-core/recipes-xrt/xrt/xrt/disable_aie_profiling.patch
+++ /dev/null
@@ -1,17 +0,0 @@
1diff --git a/src/runtime_src/xdp/profile/plugin/CMakeLists.txt b/src/runtime_src/xdp/profile/plugin/CMakeLists.txt
2index 8ef7a2f..9b8baac 100644
3--- a/src/runtime_src/xdp/profile/plugin/CMakeLists.txt
4+++ b/src/runtime_src/xdp/profile/plugin/CMakeLists.txt
5@@ -33,9 +33,9 @@ if (NOT WIN32)
6 # =========================================================
7 # The plugins to be built on Linux only
8 # =========================================================
9-add_subdirectory(aie_status)
10-add_subdirectory(aie_profile)
11-add_subdirectory(aie_trace)
12+#add_subdirectory(aie_status)
13+#add_subdirectory(aie_profile)
14+#add_subdirectory(aie_trace)
15 add_subdirectory(device_offload/hw_emu)
16 add_subdirectory(noc)
17 add_subdirectory(power)
diff --git a/meta-xilinx-core/recipes-xrt/xrt/xrt_git.bb b/meta-xilinx-core/recipes-xrt/xrt/xrt_git.bb
index 439c47ec..5a617a5c 100644
--- a/meta-xilinx-core/recipes-xrt/xrt/xrt_git.bb
+++ b/meta-xilinx-core/recipes-xrt/xrt/xrt_git.bb
@@ -4,7 +4,6 @@ DESCRIPTION = "Xilinx Runtime User Space Libraries and headers"
4require xrt.inc 4require xrt.inc
5 5
6SRC_URI += "file://xrt-cstdint.patch;striplevel=2" 6SRC_URI += "file://xrt-cstdint.patch;striplevel=2"
7SRC_URI += "file://disable_aie_profiling.patch;striplevel=2"
8 7
9LICENSE = "GPL-2.0-or-later & Apache-2.0 & MIT" 8LICENSE = "GPL-2.0-or-later & Apache-2.0 & MIT"
10LIC_FILES_CHKSUM = "file://../LICENSE;md5=de2c993ac479f02575bcbfb14ef9b485 \ 9LIC_FILES_CHKSUM = "file://../LICENSE;md5=de2c993ac479f02575bcbfb14ef9b485 \
diff --git a/meta-xilinx-standalone-experimental/README.md b/meta-xilinx-standalone-experimental/README.md
index 1c80dc8f..950e4e12 100644
--- a/meta-xilinx-standalone-experimental/README.md
+++ b/meta-xilinx-standalone-experimental/README.md
@@ -162,7 +162,14 @@ This layer depends on:
162 https://git.yoctoproject.org/meta-xilinx (official version) 162 https://git.yoctoproject.org/meta-xilinx (official version)
163 https://github.com/Xilinx/meta-xilinx (development and amd xilinx release) 163 https://github.com/Xilinx/meta-xilinx (development and amd xilinx release)
164 layers: meta-xilinx-core, meta-xilinx-bsp, meta-xilinx-standalone 164 layers: meta-xilinx-core, meta-xilinx-bsp, meta-xilinx-standalone
165 branch: langdale or amd xilinx release version (e.g. rel-v2023.1) 165 branch: langdale or amd xilinx release version (e.g. rel-v2024.1)
166 166
167 URI: https://git.yoctoproject.org/meta-virtualization 167 URI:
168 branch: langdale 168 https://git.yoctoproject.org/meta-virtualization (official version)
169 https://github.com/Xilinx/meta-virtualization (development and amd xilinx release)
170 branch: langdale or amd xilinx release version (e.g. rel-v2024.1)
171
172 URI:
173 https://github.com/OpenAMP/meta-openamp (official version)
174 https://github.com/Xilinx/meta-openamp (development and amd xilinx release)
175 branch: langdale or amd xilinx release version (e.g. rel-v2024.1)
diff --git a/meta-xilinx-standalone-experimental/conf/layer.conf b/meta-xilinx-standalone-experimental/conf/layer.conf
index 6cfd01c3..b4282ce0 100644
--- a/meta-xilinx-standalone-experimental/conf/layer.conf
+++ b/meta-xilinx-standalone-experimental/conf/layer.conf
@@ -19,7 +19,8 @@ LAYERDEPENDS_xilinx-standalone-exp = "core \
19 xilinx \ 19 xilinx \
20 xilinx-standalone \ 20 xilinx-standalone \
21 xilinx-microblaze \ 21 xilinx-microblaze \
22 virtualization-layer \ 22 virtualization-layer \
23 openamp-layer \
23 " 24 "
24 25
25LAYERSERIES_COMPAT_xilinx-standalone-exp = "scarthgap" 26LAYERSERIES_COMPAT_xilinx-standalone-exp = "scarthgap"
diff --git a/meta-xilinx-standalone/classes/xlnx-embeddedsw.bbclass b/meta-xilinx-standalone/classes/xlnx-embeddedsw.bbclass
index 089888fe..626ebe18 100644
--- a/meta-xilinx-standalone/classes/xlnx-embeddedsw.bbclass
+++ b/meta-xilinx-standalone/classes/xlnx-embeddedsw.bbclass
@@ -17,7 +17,7 @@ ESW_REV[2022.1] = "56d94a506fd9f80949f4cff08e13015928603f01"
17ESW_REV[2022.2] = "5330a64c8efd14f0eef09befdbb8d3d738c33ec2" 17ESW_REV[2022.2] = "5330a64c8efd14f0eef09befdbb8d3d738c33ec2"
18ESW_REV[2023.1] = "af784f742dad0ca6e69e05baf8de51152c396b9a" 18ESW_REV[2023.1] = "af784f742dad0ca6e69e05baf8de51152c396b9a"
19ESW_REV[2023.2] = "e847e1935dca630615e5f7dc694365a44b89699c" 19ESW_REV[2023.2] = "e847e1935dca630615e5f7dc694365a44b89699c"
20ESW_REV[2024.1] = "bd55a53c2e0bd9d27cd20a2660d14b0024aa8bb4" 20ESW_REV[2024.1] = "827c36863db8e94c1b46e1f40fbc636467913589"
21SRCREV ??= "${@d.getVarFlag('ESW_REV', d.getVar('ESW_VER')) or 'INVALID'}" 21SRCREV ??= "${@d.getVarFlag('ESW_REV', d.getVar('ESW_VER')) or 'INVALID'}"
22 22
23EMBEDDEDSW_BRANCHARG ?= "${@['nobranch=1', 'branch=${BRANCH}'][d.getVar('BRANCH') != '']}" 23EMBEDDEDSW_BRANCHARG ?= "${@['nobranch=1', 'branch=${BRANCH}'][d.getVar('BRANCH') != '']}"
diff --git a/meta-xilinx-virtualization/README.md b/meta-xilinx-virtualization/README.md
index ad6d4ada..5b66ea38 100644
--- a/meta-xilinx-virtualization/README.md
+++ b/meta-xilinx-virtualization/README.md
@@ -36,6 +36,17 @@ ENABLE_XEN_UBOOT_SCR = "1"
36ENABLE_XEN_DTSI = "1" 36ENABLE_XEN_DTSI = "1"
37ENABLE_XEN_QEMU_DTSI = "1" 37ENABLE_XEN_QEMU_DTSI = "1"
38 38
39# Default Xen Serial Console is serial0, if you are using serial1 then set as show below.
40XEN_SERIAL_CONSOLES = "serial1"
41
42# Variables for Xen JTAG or SD INITRD boot modes but this is not required for SD WIC image.
43IMAGE_FSTYPES += "cpio.gz"
44RAMDISK_IMAGE = "rootfs.cpio.gz"
45
46# Variables for Xen SD WIC image boot flow.
47IMAGE_FSTYPES += "wic"
48WKS_FILES = "xilinx-default-sd.wks"
49
39DISTRO_FEATURES:append = " multiarch security tpm virtualization vmsep xen" 50DISTRO_FEATURES:append = " multiarch security tpm virtualization vmsep xen"
40 51
41IMAGE_FEATURES += "ssh-server-openssh" 52IMAGE_FEATURES += "ssh-server-openssh"