diff options
-rw-r--r-- | meta-xilinx-core/recipes-bsp/initramdisk/initramdisk-xilinx.bb | 8 |
1 files changed, 4 insertions, 4 deletions
diff --git a/meta-xilinx-core/recipes-bsp/initramdisk/initramdisk-xilinx.bb b/meta-xilinx-core/recipes-bsp/initramdisk/initramdisk-xilinx.bb index 2114eafd..af786e7e 100644 --- a/meta-xilinx-core/recipes-bsp/initramdisk/initramdisk-xilinx.bb +++ b/meta-xilinx-core/recipes-bsp/initramdisk/initramdisk-xilinx.bb | |||
@@ -18,18 +18,18 @@ do_install[vardepsexclude] += "DEPLOY_DIR_IMAGE" | |||
18 | do_install[depends] += "${INITRAMFS_IMAGE}:do_image_complete" | 18 | do_install[depends] += "${INITRAMFS_IMAGE}:do_image_complete" |
19 | do_install[cleandirs] = "${D}" | 19 | do_install[cleandirs] = "${D}" |
20 | do_install() { | 20 | do_install() { |
21 | if [ -e ${DEPLOY_DIR_IMAGE}/${INITRAMFS_IMAGE}-${MACHINE}.rootfs.cpio.gz.u-boot ]; then | 21 | if [ -e ${DEPLOY_DIR_IMAGE}/${INITRAMFS_IMAGE}-${MACHINE}.cpio.gz.u-boot ]; then |
22 | install -d ${D}/boot/ | 22 | install -d ${D}/boot/ |
23 | install -m 0644 ${DEPLOY_DIR_IMAGE}/${INITRAMFS_IMAGE}-${MACHINE}.rootfs.cpio.gz.u-boot ${D}/boot/. | 23 | install -m 0644 ${DEPLOY_DIR_IMAGE}/${INITRAMFS_IMAGE}-${MACHINE}.cpio.gz.u-boot ${D}/boot/. |
24 | else | 24 | else |
25 | bbfatal "Unable to find expected initramfs: ${INITRAMFS_IMAGE}-${MACHINE}.rootfs.cpio.gz.u-boot" | 25 | bbfatal "Unable to find expected initramfs: ${INITRAMFS_IMAGE}-${MACHINE}.cpio.gz.u-boot" |
26 | fi | 26 | fi |
27 | } | 27 | } |
28 | 28 | ||
29 | PACKAGES = "${PACKAGE_BEFORE_PN} ${PN}" | 29 | PACKAGES = "${PACKAGE_BEFORE_PN} ${PN}" |
30 | 30 | ||
31 | RPROVIDES:${PN} = "initramdisk" | 31 | RPROVIDES:${PN} = "initramdisk" |
32 | FILES:${PN} = "/boot/${INITRAMFS_IMAGE}-${MACHINE}.rootfs.cpio.gz.u-boot" | 32 | FILES:${PN} = "/boot/${INITRAMFS_IMAGE}-${MACHINE}.cpio.gz.u-boot" |
33 | 33 | ||
34 | python() { | 34 | python() { |
35 | if not d.getVar('INITRAMFS_IMAGE'): | 35 | if not d.getVar('INITRAMFS_IMAGE'): |