diff options
Diffstat (limited to 'meta-dpdk')
13 files changed, 0 insertions, 412 deletions
diff --git a/meta-dpdk/COPYING.MIT b/meta-dpdk/COPYING.MIT deleted file mode 100644 index fb950dc6..00000000 --- a/meta-dpdk/COPYING.MIT +++ /dev/null | |||
@@ -1,17 +0,0 @@ | |||
1 | Permission is hereby granted, free of charge, to any person obtaining a copy | ||
2 | of this software and associated documentation files (the "Software"), to deal | ||
3 | in the Software without restriction, including without limitation the rights | ||
4 | to use, copy, modify, merge, publish, distribute, sublicense, and/or sell | ||
5 | copies of the Software, and to permit persons to whom the Software is | ||
6 | furnished to do so, subject to the following conditions: | ||
7 | |||
8 | The above copyright notice and this permission notice shall be included in | ||
9 | all copies or substantial portions of the Software. | ||
10 | |||
11 | THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR | ||
12 | IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, | ||
13 | FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE | ||
14 | AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER | ||
15 | LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, | ||
16 | OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN | ||
17 | THE SOFTWARE. | ||
diff --git a/meta-dpdk/LICENSE b/meta-dpdk/LICENSE deleted file mode 100644 index e57d3b90..00000000 --- a/meta-dpdk/LICENSE +++ /dev/null | |||
@@ -1,5 +0,0 @@ | |||
1 | All metadata files (including, but not limited to bb, bbappend, | ||
2 | bbclass, inc and conf files) are MIT licensed unless otherwise stated. | ||
3 | Source code included in tree for individual recipes is under the | ||
4 | LICENSE stated in the associated recipe (.bb file) unless otherwise | ||
5 | stated. | ||
diff --git a/meta-dpdk/README b/meta-dpdk/README deleted file mode 100644 index 1b256d02..00000000 --- a/meta-dpdk/README +++ /dev/null | |||
@@ -1,56 +0,0 @@ | |||
1 | meta-dpdk | ||
2 | ========= | ||
3 | |||
4 | This README file contains information on building the DPDK package. | ||
5 | |||
6 | This is a fork of meta-dpdk, git://git.yoctoproject.org/meta-dpdk | ||
7 | langdale branch as of commit bd1b4f10262f12dd66a91383757ccba4eeda0b08. | ||
8 | |||
9 | The software in this fork is specific to the AMD Embedded versal-net. | ||
10 | |||
11 | Dependencies | ||
12 | ============ | ||
13 | |||
14 | This layer depends on: | ||
15 | |||
16 | URI: git://git.openembedded.org/bitbake | ||
17 | branch: master | ||
18 | |||
19 | URI: git://git.openembedded.org/openembedded-core | ||
20 | layers: meta | ||
21 | branch: master | ||
22 | |||
23 | |||
24 | Guidelines for submitting patches | ||
25 | ==================================== | ||
26 | |||
27 | Please submit any patches against this fork of meta-dpdk to the meta-xilinx | ||
28 | mailing list (meta-xilinx@lists.yoctoproject.org). | ||
29 | |||
30 | Regardless of how you submit a patch or patchset, the patches should | ||
31 | at minimum follow the suggestions outlined in the 'Submitting a Change | ||
32 | to the Yocto Project' section in the Yocto Project Development Manual. | ||
33 | Specifically, they should: | ||
34 | |||
35 | - Include a 'Signed-off-by:' line. A commit can't legally be pulled | ||
36 | in without this. | ||
37 | |||
38 | - Provide a single-line, short summary of the change. This short | ||
39 | description should be prefixed by the BSP or recipe name, as | ||
40 | appropriate, followed by a colon. Capitalize the first character | ||
41 | of the summary (following the colon). | ||
42 | |||
43 | - For the body of the commit message, provide detailed information | ||
44 | that describes what you changed, why you made the change, and the | ||
45 | approach you used. | ||
46 | |||
47 | - If the change addresses a specific bug or issue that is associated | ||
48 | with a bug-tracking ID, include a reference to that ID in your | ||
49 | detailed description in the following format: [YOCTO #<bug-id>]. | ||
50 | |||
51 | - Pay attention to line length - please don't allow any particular | ||
52 | line in the commit message to stretch past 72 characters. | ||
53 | |||
54 | - For any non-trivial patch, provide information about how you | ||
55 | tested the patch, and for any non-trivial or non-obvious testing | ||
56 | setup, provide details of that setup. | ||
diff --git a/meta-dpdk/conf/layer.conf b/meta-dpdk/conf/layer.conf deleted file mode 100644 index 2b33f7a9..00000000 --- a/meta-dpdk/conf/layer.conf +++ /dev/null | |||
@@ -1,24 +0,0 @@ | |||
1 | # We have a conf and classes directory, add to BBPATH | ||
2 | BBPATH .= ":${LAYERDIR}" | ||
3 | |||
4 | # We have recipes-* directories, add to BBFILES | ||
5 | BBFILES += "${LAYERDIR}/recipes-*/*/*.bb \ | ||
6 | ${LAYERDIR}/recipes-*/*/*.bbappend" | ||
7 | |||
8 | BBFILE_COLLECTIONS += "dpdk" | ||
9 | BBFILE_PATTERN_dpdk := "^${LAYERDIR}/" | ||
10 | BBFILE_PRIORITY_dpdk = "5" | ||
11 | |||
12 | LAYERDEPENDS_dpdk = "core" | ||
13 | |||
14 | # This should only be incremented on significant changes that will | ||
15 | # cause compatibility issues with other layers | ||
16 | LAYERVERSION_dpdk = "1" | ||
17 | LAYERSERIES_COMPAT_dpdk = "kirkstone langdale" | ||
18 | |||
19 | BBFILES_DYNAMIC += " \ | ||
20 | clang-layer:${LAYERDIR}/dynamic-layers/clang-layer/*/*/*.bb \ | ||
21 | clang-layer:${LAYERDIR}/dynamic-layers/clang-layer/*/*/*.bbappend \ | ||
22 | petalinux:${LAYERDIR}/dynamic-layers/petalinux/recipes-*/*/*.bb \ | ||
23 | petalinux:${LAYERDIR}/dynamic-layers/petalinux/recipes-*/*/*.bbappend \ | ||
24 | " | ||
diff --git a/meta-dpdk/dynamic-layers/clang-layer/recipes-support/xdp-tools/xdp-tools/0001-configure-skip-toolchain-checks.patch b/meta-dpdk/dynamic-layers/clang-layer/recipes-support/xdp-tools/xdp-tools/0001-configure-skip-toolchain-checks.patch deleted file mode 100644 index 32a88b20..00000000 --- a/meta-dpdk/dynamic-layers/clang-layer/recipes-support/xdp-tools/xdp-tools/0001-configure-skip-toolchain-checks.patch +++ /dev/null | |||
@@ -1,46 +0,0 @@ | |||
1 | From 53f8a8dffa571de99b50f1a7b757cfd7d8c24d21 Mon Sep 17 00:00:00 2001 | ||
2 | From: Naveen Saini <naveen.kumar.saini@intel.com> | ||
3 | Date: Mon, 17 Oct 2022 15:44:16 +0800 | ||
4 | Subject: [PATCH 1/4] configure: skip toolchain checks | ||
5 | |||
6 | Current logic fetch full command line along with the tool. i.e | ||
7 | gcc -m64 -march=skylake -mtune=generic ... | ||
8 | |||
9 | Which throws ERROR: Cannot find tool -m64 | ||
10 | |||
11 | So need to re-write for loop, so it can work in cross-compilation | ||
12 | environment too. | ||
13 | |||
14 | Upstream-Status: Inappropriate | ||
15 | |||
16 | Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com> | ||
17 | --- | ||
18 | configure | 12 ++++++------ | ||
19 | 1 file changed, 6 insertions(+), 6 deletions(-) | ||
20 | |||
21 | diff --git a/configure b/configure | ||
22 | index 70fdfdf..48d1ea5 100755 | ||
23 | --- a/configure | ||
24 | +++ b/configure | ||
25 | @@ -38,12 +38,12 @@ check_toolchain() | ||
26 | : ${EMACS=emacs} | ||
27 | : ${ARCH_INCLUDES=} | ||
28 | |||
29 | - for TOOL in $PKG_CONFIG $CC $LD $OBJCOPY $CLANG $LLC $M4; do | ||
30 | - if [ ! $(command -v ${TOOL} 2>/dev/null) ]; then | ||
31 | - echo "*** ERROR: Cannot find tool ${TOOL}" ; | ||
32 | - exit 1; | ||
33 | - fi; | ||
34 | - done | ||
35 | + #for TOOL in $PKG_CONFIG $CC $LD $OBJCOPY $CLANG $LLC $M4; do | ||
36 | + # if [ ! $(command -v ${TOOL} 2>/dev/null) ]; then | ||
37 | + # echo "*** ERROR: Cannot find tool ${TOOL}" ; | ||
38 | + # exit 1; | ||
39 | + # fi; | ||
40 | + #done | ||
41 | |||
42 | clang_version=$($CLANG --version | grep -Po '(?<=clang version )[[:digit:]]+') | ||
43 | echo "Found clang binary '$CLANG' with version $clang_version (from '$($CLANG --version | head -n 1)')" | ||
44 | -- | ||
45 | 2.25.1 | ||
46 | |||
diff --git a/meta-dpdk/dynamic-layers/clang-layer/recipes-support/xdp-tools/xdp-tools/0002-Makefile-It-does-not-detect-libbpf-header-from-sysro.patch b/meta-dpdk/dynamic-layers/clang-layer/recipes-support/xdp-tools/xdp-tools/0002-Makefile-It-does-not-detect-libbpf-header-from-sysro.patch deleted file mode 100644 index 2e667836..00000000 --- a/meta-dpdk/dynamic-layers/clang-layer/recipes-support/xdp-tools/xdp-tools/0002-Makefile-It-does-not-detect-libbpf-header-from-sysro.patch +++ /dev/null | |||
@@ -1,44 +0,0 @@ | |||
1 | From 2840cf0b89497f545fae2eed7ece3f3c5fc558e3 Mon Sep 17 00:00:00 2001 | ||
2 | From: Naveen Saini <naveen.kumar.saini@intel.com> | ||
3 | Date: Mon, 17 Oct 2022 15:50:34 +0800 | ||
4 | Subject: [PATCH 2/4] Makefile: It does not detect libbpf header from sysroot | ||
5 | |||
6 | So adding sysroot headers path. | ||
7 | |||
8 | Upstream-Status: OE-Specific | ||
9 | |||
10 | Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com> | ||
11 | --- | ||
12 | lib/common.mk | 2 +- | ||
13 | lib/libxdp/Makefile | 2 +- | ||
14 | 2 files changed, 2 insertions(+), 2 deletions(-) | ||
15 | |||
16 | diff --git a/lib/common.mk b/lib/common.mk | ||
17 | index 56c0406..ab0bad8 100644 | ||
18 | --- a/lib/common.mk | ||
19 | +++ b/lib/common.mk | ||
20 | @@ -55,7 +55,7 @@ LIBXDP_SOURCES := $(wildcard $(LIBXDP_DIR)/*.[ch] $(LIBXDP_DIR)/*.in) | ||
21 | KERN_USER_H ?= $(wildcard common_kern_user.h) | ||
22 | |||
23 | CFLAGS += -I$(HEADER_DIR) -I$(LIB_DIR)/util $(ARCH_INCLUDES) | ||
24 | -BPF_CFLAGS += -I$(HEADER_DIR) $(ARCH_INCLUDES) | ||
25 | +BPF_CFLAGS += -I$(HEADER_DIR) $(ARCH_INCLUDES) -I${STAGING_INCDIR}/ | ||
26 | |||
27 | BPF_HEADERS := $(wildcard $(HEADER_DIR)/bpf/*.h) $(wildcard $(HEADER_DIR)/xdp/*.h) | ||
28 | |||
29 | diff --git a/lib/libxdp/Makefile b/lib/libxdp/Makefile | ||
30 | index 358b751..8f459d8 100644 | ||
31 | --- a/lib/libxdp/Makefile | ||
32 | +++ b/lib/libxdp/Makefile | ||
33 | @@ -30,7 +30,7 @@ PC_FILE := $(OBJDIR)/libxdp.pc | ||
34 | TEMPLATED_SOURCES := xdp-dispatcher.c | ||
35 | |||
36 | CFLAGS += -I$(HEADER_DIR) | ||
37 | -BPF_CFLAGS += -I$(HEADER_DIR) | ||
38 | +BPF_CFLAGS += -I$(HEADER_DIR) -I${STAGING_INCDIR}/ | ||
39 | |||
40 | |||
41 | ifndef BUILD_STATIC_ONLY | ||
42 | -- | ||
43 | 2.25.1 | ||
44 | |||
diff --git a/meta-dpdk/dynamic-layers/clang-layer/recipes-support/xdp-tools/xdp-tools/0003-Makefile-fix-KeyError-failure.patch b/meta-dpdk/dynamic-layers/clang-layer/recipes-support/xdp-tools/xdp-tools/0003-Makefile-fix-KeyError-failure.patch deleted file mode 100644 index 41c57f6e..00000000 --- a/meta-dpdk/dynamic-layers/clang-layer/recipes-support/xdp-tools/xdp-tools/0003-Makefile-fix-KeyError-failure.patch +++ /dev/null | |||
@@ -1,31 +0,0 @@ | |||
1 | From 157546fbc4f18751c52b3c8788879c05cf253331 Mon Sep 17 00:00:00 2001 | ||
2 | From: Naveen Saini <naveen.kumar.saini@intel.com> | ||
3 | Date: Mon, 17 Oct 2022 16:02:46 +0800 | ||
4 | Subject: [PATCH 3/4] Makefile: fix KeyError failure | ||
5 | |||
6 | Error: | ||
7 | Exception: KeyError: 'getpwuid(): uid not found: 11857215' | ||
8 | |||
9 | Upstream-Status: Inappropriate | ||
10 | |||
11 | Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com> | ||
12 | --- | ||
13 | lib/libxdp/Makefile | 2 +- | ||
14 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
15 | |||
16 | diff --git a/lib/libxdp/Makefile b/lib/libxdp/Makefile | ||
17 | index 8f459d8..9a340a3 100644 | ||
18 | --- a/lib/libxdp/Makefile | ||
19 | +++ b/lib/libxdp/Makefile | ||
20 | @@ -55,7 +55,7 @@ install: all | ||
21 | $(Q)install -d -m 0755 $(DESTDIR)$(BPF_OBJECT_DIR) | ||
22 | $(Q)install -m 0644 $(LIB_HEADERS) $(DESTDIR)$(HDRDIR)/ | ||
23 | $(Q)install -m 0644 $(PC_FILE) $(DESTDIR)$(LIBDIR)/pkgconfig/ | ||
24 | - $(Q)cp -fpR $(SHARED_LIBS) $(STATIC_LIBS) $(DESTDIR)$(LIBDIR) | ||
25 | + $(Q)cp -fpR --no-preserve=ownership $(SHARED_LIBS) $(STATIC_LIBS) $(DESTDIR)$(LIBDIR) | ||
26 | $(Q)install -m 0755 $(XDP_OBJS) $(DESTDIR)$(BPF_OBJECT_DIR) | ||
27 | $(if $(MAN_FILES),$(Q)install -m 0755 -d $(DESTDIR)$(MANDIR)/man3) | ||
28 | $(if $(MAN_FILES),$(Q)install -m 0644 $(MAN_FILES) $(DESTDIR)$(MANDIR)/man3) | ||
29 | -- | ||
30 | 2.25.1 | ||
31 | |||
diff --git a/meta-dpdk/dynamic-layers/clang-layer/recipes-support/xdp-tools/xdp-tools/0004-Makefile-fix-libxdp.pc-error.patch b/meta-dpdk/dynamic-layers/clang-layer/recipes-support/xdp-tools/xdp-tools/0004-Makefile-fix-libxdp.pc-error.patch deleted file mode 100644 index b1e15e52..00000000 --- a/meta-dpdk/dynamic-layers/clang-layer/recipes-support/xdp-tools/xdp-tools/0004-Makefile-fix-libxdp.pc-error.patch +++ /dev/null | |||
@@ -1,34 +0,0 @@ | |||
1 | From 46b3ff797135574aa0ee42f633a281d44f48da95 Mon Sep 17 00:00:00 2001 | ||
2 | From: Naveen Saini <naveen.kumar.saini@intel.com> | ||
3 | Date: Mon, 17 Oct 2022 16:05:15 +0800 | ||
4 | Subject: [PATCH 4/4] Makefile: fix libxdp.pc error | ||
5 | |||
6 | Error: | ||
7 | do_populate_sysroot: QA Issue: libxdp.pc failed sanity test (tmpdir) in | ||
8 | path ... xdp-tools/1.2.8-r0/sysroot-destdir/usr/lib/pkgconfig [pkgconfig] | ||
9 | |||
10 | Upstream-Status: Inappropriate | ||
11 | |||
12 | Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com> | ||
13 | --- | ||
14 | lib/libxdp/Makefile | 4 ++-- | ||
15 | 1 file changed, 2 insertions(+), 2 deletions(-) | ||
16 | |||
17 | diff --git a/lib/libxdp/Makefile b/lib/libxdp/Makefile | ||
18 | index 9a340a3..bc39177 100644 | ||
19 | --- a/lib/libxdp/Makefile | ||
20 | +++ b/lib/libxdp/Makefile | ||
21 | @@ -76,8 +76,8 @@ $(OBJDIR)/libxdp.so.$(LIBXDP_VERSION): $(SHARED_OBJS) | ||
22 | $^ $(LDFLAGS) $(LDLIBS) -o $@ | ||
23 | |||
24 | $(OBJDIR)/libxdp.pc: | ||
25 | - $(Q)sed -e "s|@PREFIX@|$(PREFIX)|" \ | ||
26 | - -e "s|@LIBDIR@|$(LIBDIR)|" \ | ||
27 | + $(Q)sed -e "s|@PREFIX@|$(prefix)|" \ | ||
28 | + -e "s|@LIBDIR@|$(libdir)|" \ | ||
29 | -e "s|@VERSION@|$(TOOLS_VERSION)|" \ | ||
30 | < libxdp.pc.template > $@ | ||
31 | |||
32 | -- | ||
33 | 2.25.1 | ||
34 | |||
diff --git a/meta-dpdk/dynamic-layers/clang-layer/recipes-support/xdp-tools/xdp-tools_1.2.8.bb b/meta-dpdk/dynamic-layers/clang-layer/recipes-support/xdp-tools/xdp-tools_1.2.8.bb deleted file mode 100644 index 7cd49a0b..00000000 --- a/meta-dpdk/dynamic-layers/clang-layer/recipes-support/xdp-tools/xdp-tools_1.2.8.bb +++ /dev/null | |||
@@ -1,37 +0,0 @@ | |||
1 | SUMMARY = "Utilities and example programs for use with XDP" | ||
2 | HOMEPAGE = "https://github.com/xdp-project/xdp-tools" | ||
3 | LICENSE = "GPL-2.0-or-later & LGPL-2.1-or-later & BSD-2-Clause" | ||
4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=9ee53f8d06bbdb4c11b1557ecc4f8cd5 \ | ||
5 | file://LICENSES/GPL-2.0;md5=994331978b428511800bfbd17eea3001 \ | ||
6 | file://LICENSES/LGPL-2.1;md5=b370887980db5dd40659b50909238dbd \ | ||
7 | file://LICENSES/BSD-2-Clause;md5=5d6306d1b08f8df623178dfd81880927" | ||
8 | |||
9 | DEPENDS += " libbpf clang-native zlib elfutils libpcap" | ||
10 | |||
11 | SRC_URI = "git://github.com/xdp-project/xdp-tools.git;branch=v1.2;protocol=https \ | ||
12 | file://0001-configure-skip-toolchain-checks.patch \ | ||
13 | file://0002-Makefile-It-does-not-detect-libbpf-header-from-sysro.patch \ | ||
14 | file://0003-Makefile-fix-KeyError-failure.patch \ | ||
15 | file://0004-Makefile-fix-libxdp.pc-error.patch \ | ||
16 | " | ||
17 | |||
18 | SRCREV = "d4ff1f9bcf8b03556b625ab6e16958598482e861" | ||
19 | |||
20 | S = "${WORKDIR}/git" | ||
21 | |||
22 | inherit pkgconfig | ||
23 | |||
24 | EXTRA_OEMAKE += "PREFIX=${D}${prefix} LIBDIR=${D}${libdir} BUILD_STATIC_ONLY=1 PRODUCTION=1" | ||
25 | |||
26 | CFLAGS += "-fPIC" | ||
27 | |||
28 | export STAGING_INCDIR | ||
29 | |||
30 | do_install () { | ||
31 | oe_runmake install | ||
32 | |||
33 | # Remove object files *.o | ||
34 | rm -rf ${D}/${libdir}/bpf | ||
35 | } | ||
36 | |||
37 | RDEPENDS:${PN} += "bash" | ||
diff --git a/meta-dpdk/dynamic-layers/petalinux/recipes-core/images/petalinux-image-everything.bbappend b/meta-dpdk/dynamic-layers/petalinux/recipes-core/images/petalinux-image-everything.bbappend deleted file mode 100644 index 732b1b45..00000000 --- a/meta-dpdk/dynamic-layers/petalinux/recipes-core/images/petalinux-image-everything.bbappend +++ /dev/null | |||
@@ -1,2 +0,0 @@ | |||
1 | COMMON_INSTALL:append:versal-net = " dpdk libmcdi" | ||
2 | |||
diff --git a/meta-dpdk/recipes-extended/dpdk/dpdk.inc b/meta-dpdk/recipes-extended/dpdk/dpdk.inc deleted file mode 100644 index 9ce9737e..00000000 --- a/meta-dpdk/recipes-extended/dpdk/dpdk.inc +++ /dev/null | |||
@@ -1,12 +0,0 @@ | |||
1 | DESCRIPTION = "Data Plane Development Kit" | ||
2 | HOMEPAGE = "http://dpdk.org" | ||
3 | |||
4 | LICENSE = "BSD-3-Clause & LGPL-2.1-only & GPL-2.0-only" | ||
5 | LIC_FILES_CHKSUM = "file://license/gpl-2.0.txt;md5=b234ee4d69f5fce4486a80fdaf4a4263 \ | ||
6 | file://license/lgpl-2.1.txt;md5=4b54a1fd55a448865a0b32d41598759d \ | ||
7 | file://license/bsd-3-clause.txt;md5=0f00d99239d922ffd13cabef83b33444" | ||
8 | |||
9 | SRC_URI = "git://dpdk.org/dpdk${STABLE};branch=${BRANCH} \ | ||
10 | " | ||
11 | |||
12 | CVE_PRODUCT = "data_plane_development_kit" | ||
diff --git a/meta-dpdk/recipes-extended/dpdk/dpdk_22.11.0.bb b/meta-dpdk/recipes-extended/dpdk/dpdk_22.11.0.bb deleted file mode 100644 index 2545d383..00000000 --- a/meta-dpdk/recipes-extended/dpdk/dpdk_22.11.0.bb +++ /dev/null | |||
@@ -1,71 +0,0 @@ | |||
1 | include dpdk.inc | ||
2 | |||
3 | SRC_URI = "git://github.com/Xilinx-CNS/cns-dpdk-next-sfc.git;branch=${BRANCH};protocol=https" | ||
4 | |||
5 | BRANCH = "cdx_22.11" | ||
6 | SRCREV = "59161e5e88faf7475a8db180efe6d6f5113631b4" | ||
7 | S = "${WORKDIR}/git" | ||
8 | |||
9 | # kernel module is provide by dpdk-module recipe, so disable here | ||
10 | EXTRA_OEMESON = " \ | ||
11 | -Denable_kmods=false \ | ||
12 | -Dexamples=cdma_demo,cdx_test \ | ||
13 | " | ||
14 | |||
15 | COMPATIBLE_MACHINE = "null" | ||
16 | COMPATIBLE_MACHINE:versal-net = "${MACHINE}" | ||
17 | COMPATIBLE_HOST:libc-musl:class-target = "null" | ||
18 | COMPATIBLE_HOST:linux-gnux32 = "null" | ||
19 | |||
20 | PACKAGECONFIG ??= " " | ||
21 | PACKAGECONFIG[afxdp] = ",,libbpf xdp-tools" | ||
22 | PACKAGECONFIG[libvirt] = ",,libvirt" | ||
23 | |||
24 | RDEPENDS:${PN} += "pciutils python3-core" | ||
25 | RDEPENDS:${PN}-examples += "bash" | ||
26 | DEPENDS = "numactl python3-pyelftools-native" | ||
27 | |||
28 | inherit meson pkgconfig | ||
29 | |||
30 | INSTALL_PATH = "${prefix}/share/dpdk" | ||
31 | |||
32 | do_write_config:append(){ | ||
33 | sed -i "/\[properties\]/a platform = \'cdx\'" ${WORKDIR}/meson.cross | ||
34 | } | ||
35 | |||
36 | do_install:append(){ | ||
37 | # remove source files | ||
38 | rm -rf ${D}/${INSTALL_PATH}/examples/* | ||
39 | |||
40 | # Install examples | ||
41 | install -m 0755 -d ${D}/${INSTALL_PATH}/examples/ | ||
42 | for dirname in ${B}/examples/dpdk-* | ||
43 | do | ||
44 | if [ ! -d ${dirname} ] && [ -x ${dirname} ]; then | ||
45 | install -m 0755 ${dirname} ${D}/${INSTALL_PATH}/examples/ | ||
46 | fi | ||
47 | done | ||
48 | |||
49 | } | ||
50 | |||
51 | PACKAGES =+ "${PN}-examples ${PN}-tools" | ||
52 | |||
53 | FILES:${PN} += " ${bindir}/dpdk-testpmd \ | ||
54 | ${bindir}/dpdk-proc-info \ | ||
55 | ${libdir}/*.so* \ | ||
56 | ${libdir}/dpdk/pmds-22.0/*.so* \ | ||
57 | " | ||
58 | FILES:${PN}-examples = " \ | ||
59 | ${INSTALL_PATH}/examples/* \ | ||
60 | " | ||
61 | |||
62 | FILES:${PN}-tools = " \ | ||
63 | ${bindir}/dpdk-pdump \ | ||
64 | ${bindir}/dpdk-test \ | ||
65 | ${bindir}/dpdk-test-* \ | ||
66 | ${bindir}/dpdk-*.py \ | ||
67 | " | ||
68 | |||
69 | CVE_PRODUCT = "data_plane_development_kit" | ||
70 | |||
71 | INSANE_SKIP:${PN} = "dev-so" | ||
diff --git a/meta-dpdk/recipes-extended/dpdk/libmcdi_0.1.0.bb b/meta-dpdk/recipes-extended/dpdk/libmcdi_0.1.0.bb deleted file mode 100644 index 0bc9a849..00000000 --- a/meta-dpdk/recipes-extended/dpdk/libmcdi_0.1.0.bb +++ /dev/null | |||
@@ -1,33 +0,0 @@ | |||
1 | DESCRIPTION = "Management Controller Driver Interface library" | ||
2 | |||
3 | LICENSE = "MIT" | ||
4 | LIC_FILES_CHKSUM = "file://COPYING.MIT;md5=838c366f69b72c5df05c96dff79b35f2" | ||
5 | |||
6 | SRC_URI = "git://github.com/Xilinx-CNS/mcdi-lib.git;branch=${BRANCH};protocol=https" | ||
7 | BRANCH = "master" | ||
8 | SRCREV = "db448189e5fcb38b4750faf6afe243d7998863bc" | ||
9 | |||
10 | S = "${WORKDIR}/git" | ||
11 | |||
12 | COMPATIBLE_MACHINE = "^$" | ||
13 | COMPATIBLE_MACHINE:versal-net = "${MACHINE}" | ||
14 | |||
15 | MCDI_PATH_EXAMPLES = "${datadir}/${BPN}/examples" | ||
16 | |||
17 | do_compile() { | ||
18 | oe_runmake all CC="${CC}" CROSS_COMPILE="${TARGET_PREFIX}" | ||
19 | } | ||
20 | |||
21 | do_install() { | ||
22 | oe_runmake install prefix="${prefix}" DESTDIR="${D}" | ||
23 | |||
24 | install -d ${D}/${MCDI_PATH_EXAMPLES} | ||
25 | install -m 0755 ${B}/example/mcdi_example_app ${D}/${MCDI_PATH_EXAMPLES} | ||
26 | install -m 0755 ${B}/init/init_app ${D}/${MCDI_PATH_EXAMPLES} | ||
27 | } | ||
28 | |||
29 | PACKAGES =+ "${PN}-examples" | ||
30 | |||
31 | FILES:${PN}-examples = " \ | ||
32 | ${MCDI_PATH_EXAMPLES}/* \ | ||
33 | " | ||