diff options
Diffstat (limited to 'meta-xilinx-multimedia/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/0004-opencv-resolve-missing-opencv-data-dir-in-yocto-buil.patch')
-rw-r--r-- | meta-xilinx-multimedia/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/0004-opencv-resolve-missing-opencv-data-dir-in-yocto-buil.patch | 33 |
1 files changed, 33 insertions, 0 deletions
diff --git a/meta-xilinx-multimedia/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/0004-opencv-resolve-missing-opencv-data-dir-in-yocto-buil.patch b/meta-xilinx-multimedia/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/0004-opencv-resolve-missing-opencv-data-dir-in-yocto-buil.patch new file mode 100644 index 00000000..50a3143e --- /dev/null +++ b/meta-xilinx-multimedia/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/0004-opencv-resolve-missing-opencv-data-dir-in-yocto-buil.patch | |||
@@ -0,0 +1,33 @@ | |||
1 | From e6eb7536fcfc2c75f7831f67b1f16f3f36ef2545 Mon Sep 17 00:00:00 2001 | ||
2 | From: Andrey Zhizhikin <andrey.z@gmail.com> | ||
3 | Date: Mon, 27 Jan 2020 10:22:35 +0000 | ||
4 | Subject: [PATCH] opencv: resolve missing opencv data dir in yocto build | ||
5 | |||
6 | When Yocto build is performed, opencv searches for data dir using simple | ||
7 | 'test' command, this fails because pkg-config provides an absolute | ||
8 | path on the target which needs to be prepended by PKG_CONFIG_SYSROOT_DIR | ||
9 | in order for the 'test' utility to pick up the absolute path. | ||
10 | |||
11 | Upstream-Status: Inappropriate [OE-specific] | ||
12 | |||
13 | Signed-off-by: Andrey Zhizhikin <andrey.z@gmail.com> | ||
14 | Signed-off-by: Jose Quaresma <quaresma.jose@gmail.com> | ||
15 | |||
16 | --- | ||
17 | ext/opencv/meson.build | 3 +++ | ||
18 | 1 file changed, 3 insertions(+) | ||
19 | |||
20 | diff --git a/ext/opencv/meson.build b/ext/opencv/meson.build | ||
21 | index 37e2015..326f737 100644 | ||
22 | --- a/ext/opencv/meson.build | ||
23 | +++ b/ext/opencv/meson.build | ||
24 | @@ -87,6 +87,9 @@ if opencv_found | ||
25 | opencv_prefix = opencv_dep.get_variable('prefix') | ||
26 | gstopencv_cargs += ['-DOPENCV_PREFIX="' + opencv_prefix + '"'] | ||
27 | |||
28 | + pkgconf_sysroot = run_command(python3, '-c', 'import os; print(os.environ.get("PKG_CONFIG_SYSROOT_DIR"))').stdout().strip() | ||
29 | + opencv_prefix = pkgconf_sysroot + opencv_prefix | ||
30 | + | ||
31 | # Check the data dir used by opencv for its xml data files | ||
32 | # Use prefix from pkg-config to be compatible with cross-compilation | ||
33 | r = run_command('test', '-d', opencv_prefix + '/share/opencv', check: false) | ||