diff options
Diffstat (limited to 'setup.py')
-rwxr-xr-x | setup.py | 12 |
1 files changed, 5 insertions, 7 deletions
@@ -1,5 +1,4 @@ | |||
1 | #!/usr/bin/env python | 1 | #!/usr/bin/env python3 |
2 | # -*- coding:utf-8 -*- | ||
3 | # Copyright 2019 The Android Open Source Project | 2 | # Copyright 2019 The Android Open Source Project |
4 | # | 3 | # |
5 | # Licensed under the Apache License, Version 2.0 (the 'License"); | 4 | # Licensed under the Apache License, Version 2.0 (the 'License"); |
@@ -16,8 +15,6 @@ | |||
16 | 15 | ||
17 | """Python packaging for repo.""" | 16 | """Python packaging for repo.""" |
18 | 17 | ||
19 | from __future__ import print_function | ||
20 | |||
21 | import os | 18 | import os |
22 | import setuptools | 19 | import setuptools |
23 | 20 | ||
@@ -35,7 +32,7 @@ with open(os.path.join(TOPDIR, 'README.md')) as fp: | |||
35 | # https://packaging.python.org/tutorials/packaging-projects/ | 32 | # https://packaging.python.org/tutorials/packaging-projects/ |
36 | setuptools.setup( | 33 | setuptools.setup( |
37 | name='repo', | 34 | name='repo', |
38 | version='1.13.8', | 35 | version='2', |
39 | maintainer='Various', | 36 | maintainer='Various', |
40 | maintainer_email='repo-discuss@googlegroups.com', | 37 | maintainer_email='repo-discuss@googlegroups.com', |
41 | description='Repo helps manage many Git repositories', | 38 | description='Repo helps manage many Git repositories', |
@@ -55,9 +52,10 @@ setuptools.setup( | |||
55 | 'Operating System :: MacOS :: MacOS X', | 52 | 'Operating System :: MacOS :: MacOS X', |
56 | 'Operating System :: Microsoft :: Windows :: Windows 10', | 53 | 'Operating System :: Microsoft :: Windows :: Windows 10', |
57 | 'Operating System :: POSIX :: Linux', | 54 | 'Operating System :: POSIX :: Linux', |
55 | 'Programming Language :: Python :: 3', | ||
56 | 'Programming Language :: Python :: 3 :: Only', | ||
58 | 'Topic :: Software Development :: Version Control :: Git', | 57 | 'Topic :: Software Development :: Version Control :: Git', |
59 | ], | 58 | ], |
60 | # We support Python 2.7 and Python 3.6+. | 59 | python_requires='>=3.6', |
61 | python_requires='>=2.7, ' + ', '.join('!=3.%i.*' % x for x in range(0, 6)), | ||
62 | packages=['subcmds'], | 60 | packages=['subcmds'], |
63 | ) | 61 | ) |