diff options
-rw-r--r-- | recipes-bsp/arm-trusted-firmware/arm-trusted-firmware.inc | 45 | ||||
-rw-r--r-- | recipes-bsp/arm-trusted-firmware/arm-trusted-firmware_git.bb | 3 |
2 files changed, 48 insertions, 0 deletions
diff --git a/recipes-bsp/arm-trusted-firmware/arm-trusted-firmware.inc b/recipes-bsp/arm-trusted-firmware/arm-trusted-firmware.inc new file mode 100644 index 0000000..43d412d --- /dev/null +++ b/recipes-bsp/arm-trusted-firmware/arm-trusted-firmware.inc | |||
@@ -0,0 +1,45 @@ | |||
1 | DESCRIPTION = "ARM Trusted Firmware" | ||
2 | |||
3 | LICENSE = "BSD" | ||
4 | LIC_FILES_CHKSUM = "file://docs/license.rst;md5=189505435dbcdcc8caa63c46fe93fa89" | ||
5 | |||
6 | PROVIDES += "arm-trusted-firmware" | ||
7 | |||
8 | DEPENDS += "u-boot-tools" | ||
9 | |||
10 | inherit deploy | ||
11 | |||
12 | PACKAGE_ARCH = "${MACHINE_ARCH}" | ||
13 | |||
14 | PROT ?= "https" | ||
15 | BRANCH ?= "socfpga_v2.3" | ||
16 | SRC_URI ?= "git://github.com/altera-opensource/arm-trusted-firmware.git;protocol=${PROT};branch=${BRANCH}" | ||
17 | |||
18 | S = "${WORKDIR}/git" | ||
19 | |||
20 | COMPATIBLE_MACHINE = "(agilex|stratix10)" | ||
21 | ATFPLAT = "${MACHINE}" | ||
22 | |||
23 | # Let the Makefile handle setting up the CFLAGS and LDFLAGS as it is a standalone application | ||
24 | EXTRA_OEMAKE = 'CROSS_COMPILE="${TARGET_PREFIX}" PLAT="${ATFPLAT}" DEPRECATED=1 HANDLE_EA_EL3_FIRST=1' | ||
25 | CFLAGS[unexport] = "1" | ||
26 | LDFLAGS[unexport] = "1" | ||
27 | AS[unexport] = "1" | ||
28 | LD[unexport] = "1" | ||
29 | PARALLEL_MAKE = "" | ||
30 | |||
31 | ALLOW_EMPTY_${PN} = "1" | ||
32 | |||
33 | do_configure[noexec] = "1" | ||
34 | |||
35 | do_compile() { | ||
36 | oe_runmake -C ${S} bl31 | ||
37 | } | ||
38 | |||
39 | do_deploy() { | ||
40 | install -d ${DEPLOYDIR} | ||
41 | install -m 0644 ${S}/build/${ATFPLAT}/release/bl31.bin ${DEPLOYDIR}/bl31.bin-${MACHINE}-${PV}-${PR} | ||
42 | ln -sf bl31.bin-${MACHINE}-${PV}-${PR} ${DEPLOYDIR}/bl31.bin | ||
43 | } | ||
44 | |||
45 | addtask deploy after do_compile | ||
diff --git a/recipes-bsp/arm-trusted-firmware/arm-trusted-firmware_git.bb b/recipes-bsp/arm-trusted-firmware/arm-trusted-firmware_git.bb new file mode 100644 index 0000000..509c8a4 --- /dev/null +++ b/recipes-bsp/arm-trusted-firmware/arm-trusted-firmware_git.bb | |||
@@ -0,0 +1,3 @@ | |||
1 | require arm-trusted-firmware.inc | ||
2 | |||
3 | SRCREV = "a124a308dc3125480ca9c746afb48007d9a7ffce" | ||