diff options
author | Samuli Piippo <samuli.piippo@qt.io> | 2018-04-27 12:02:27 +0300 |
---|---|---|
committer | Samuli Piippo <samuli.piippo@qt.io> | 2018-04-27 10:51:32 +0000 |
commit | d54122272b36404e176683988d6e4d6db635375c (patch) | |
tree | 681f7d8cb0ba23d57079176deae703d625024a2c | |
parent | 4be5ca22ed0596dc06e0cd598c103da825f50edd (diff) | |
download | meta-boot2qt-2.0.1_QtAS.tar.gz |
Add product name and Qt version to image confv2.0.1_QtAS
Flashing wizard now support product and qt settings items.
Use also correct product name for automotive images.
Task-number: AUTOSUITE-286
Change-Id: Iffba7c004b69d410d7b76434b1cccff6836ff23d
Reviewed-by: Mikko Gronoff <mikko.gronoff@qt.io>
-rw-r--r-- | classes/deploy-conf.bbclass | 8 | ||||
-rw-r--r-- | recipes-qt/images/b2qt-automotive-qt5-image.bb | 2 |
2 files changed, 7 insertions, 3 deletions
diff --git a/classes/deploy-conf.bbclass b/classes/deploy-conf.bbclass index 228b1e2..22c6ef7 100644 --- a/classes/deploy-conf.bbclass +++ b/classes/deploy-conf.bbclass | |||
@@ -29,15 +29,19 @@ | |||
29 | 29 | ||
30 | inherit image_types | 30 | inherit image_types |
31 | 31 | ||
32 | IMAGE_DEPENDS_conf = "qtbase-native" | ||
33 | |||
32 | DEPLOY_CONF_NAME ?= "${MACHINE}" | 34 | DEPLOY_CONF_NAME ?= "${MACHINE}" |
33 | DEPLOY_CONF_TYPE ?= "Boot2Qt" | 35 | DEPLOY_CONF_TYPE ?= "Boot2Qt" |
34 | 36 | ||
35 | IMAGE_CMD_conf() { | 37 | IMAGE_CMD_conf() { |
38 | QT_VERSION=$(qmake -query QT_VERSION) | ||
36 | cat > ${IMGDEPLOYDIR}/${IMAGE_NAME}.rootfs.conf <<EOF | 39 | cat > ${IMGDEPLOYDIR}/${IMAGE_NAME}.rootfs.conf <<EOF |
37 | [${DEPLOY_CONF_TYPE} | ${DEPLOY_CONF_NAME}] | 40 | [${DEPLOY_CONF_NAME}] |
38 | platform=${MACHINE} | 41 | platform=${MACHINE} |
42 | product=${DEPLOY_CONF_TYPE} | ||
43 | qt=Qt $QT_VERSION | ||
39 | os=linux | 44 | os=linux |
40 | board= | ||
41 | imagefile=${IMAGE_LINK_NAME}.img | 45 | imagefile=${IMAGE_LINK_NAME}.img |
42 | asroot=true | 46 | asroot=true |
43 | EOF | 47 | EOF |
diff --git a/recipes-qt/images/b2qt-automotive-qt5-image.bb b/recipes-qt/images/b2qt-automotive-qt5-image.bb index 67819d7..7c6c2de 100644 --- a/recipes-qt/images/b2qt-automotive-qt5-image.bb +++ b/recipes-qt/images/b2qt-automotive-qt5-image.bb | |||
@@ -32,7 +32,7 @@ LICENSE = "The-Qt-Company-DCLA-2.1" | |||
32 | LIC_FILES_CHKSUM = "file://${QT_LICENSE};md5=80e06902b5f0e94ad0a78ee4f7fcb74b" | 32 | LIC_FILES_CHKSUM = "file://${QT_LICENSE};md5=80e06902b5f0e94ad0a78ee4f7fcb74b" |
33 | PR = "r0" | 33 | PR = "r0" |
34 | 34 | ||
35 | DEPLOY_CONF_TYPE = "Automotive" | 35 | DEPLOY_CONF_TYPE = "Qt Automotive Suite 2.0.1" |
36 | 36 | ||
37 | IMAGE_FEATURES += "\ | 37 | IMAGE_FEATURES += "\ |
38 | package-management \ | 38 | package-management \ |