summaryrefslogtreecommitdiffstats
path: root/recipes/adbd/adbd.bb
diff options
context:
space:
mode:
authorKalle Viironen <kalle.viironen@digia.com>2014-04-15 15:13:33 +0300
committerKalle Viironen <kalle.viironen@digia.com>2014-04-15 15:13:40 +0300
commitbfb97bc3cc517c42647f5f8b1308bb7b1f4c76f1 (patch)
tree534bfaffc99f288f395297c625e284fea6e50401 /recipes/adbd/adbd.bb
parenta68e1ea9b2904f7c69330e534da877cf19376219 (diff)
parent03be9b83d45659d0d98fa1bf69853e0aa297ed32 (diff)
downloadmeta-boot2qt-QtEE_v2.1.0.tar.gz
Merge branch 'stable' into releaseQtEE_v2.1.0
* stable: wpa-supplicant: include headers and sources for external usage bootfs: need to use fakeroot for tar'ing sdk: include bluez4-dev package to sdk Create boot.tar.gz as part of the image build image: include CA certificates to image adbd: use network connection in imx53qsb sdk: libcap is required for QtWebEngine Include licenses to the image adbd: make switching between usb and ethernet easier use package groups for image content Create only tar.gz image type Change from dylan to dora brach in README mkcard: remove recipe for mkcard Change-Id: Id56ca219d05f2f833a4de3fc3ca057c5cf50a562
Diffstat (limited to 'recipes/adbd/adbd.bb')
-rw-r--r--recipes/adbd/adbd.bb6
1 files changed, 5 insertions, 1 deletions
diff --git a/recipes/adbd/adbd.bb b/recipes/adbd/adbd.bb
index 1feb7c3..9e3ed67 100644
--- a/recipes/adbd/adbd.bb
+++ b/recipes/adbd/adbd.bb
@@ -36,6 +36,7 @@ SRC_URI = "git://android.googlesource.com/platform/system/core;protocol=https \
36 file://adbd.patch;striplevel=2 \ 36 file://adbd.patch;striplevel=2 \
37 file://Makefile.adbd \ 37 file://Makefile.adbd \
38 file://adb-init \ 38 file://adb-init \
39 file://defaults \
39 " 40 "
40 41
41S = "${WORKDIR}/git/adb" 42S = "${WORKDIR}/git/adb"
@@ -44,7 +45,7 @@ FILES_${PN} += "${bindir}/adbd"
44 45
45do_configure() { 46do_configure() {
46 if [ -n "${ADB_PRODUCTID}" ]; then 47 if [ -n "${ADB_PRODUCTID}" ]; then
47 sed -i -e 's/PRODUCT=.*/PRODUCT=${ADB_PRODUCTID}/' ${WORKDIR}/adb-init 48 sed -i -e 's/PRODUCT=.*/PRODUCT=${ADB_PRODUCTID}/' ${WORKDIR}/defaults
48 fi 49 fi
49} 50}
50 51
@@ -58,6 +59,9 @@ do_install() {
58 59
59 install -m 0755 -d ${D}${sysconfdir}/init.d 60 install -m 0755 -d ${D}${sysconfdir}/init.d
60 install -m 0755 ${WORKDIR}/adb-init ${D}${sysconfdir}/init.d/ 61 install -m 0755 ${WORKDIR}/adb-init ${D}${sysconfdir}/init.d/
62
63 install -m 0755 -d ${D}${sysconfdir}/default
64 install -m 0755 ${WORKDIR}/defaults ${D}${sysconfdir}/default/adbd
61} 65}
62 66
63INITSCRIPT_NAME = "adb-init" 67INITSCRIPT_NAME = "adb-init"