diff options
author | Kalle Viironen <kalle.viironen@digia.com> | 2014-02-21 12:08:34 +0200 |
---|---|---|
committer | Kalle Viironen <kalle.viironen@digia.com> | 2014-02-21 12:08:39 +0200 |
commit | a68e1ea9b2904f7c69330e534da877cf19376219 (patch) | |
tree | b3b6b17eea9ae44206226cc7d47f42841883020f /recipes/busybox/busybox_1.21.1.bbappend | |
parent | 48f7d2b6ef3939417a1bf291a82fa36660b213e6 (diff) | |
parent | ee2541cf756ddada9bd008b148267e2836d42450 (diff) | |
download | meta-boot2qt-QtEE_v2.0.0.tar.gz |
Merge branch 'stable' into releaseQtEE_v2.0.0
* stable: (34 commits)
udev: disable udev-cache also for beagleboard
busybox: use ifplugd to enable hotplug networking
Move libgl workaround to libsdl
imx53: change to correct GPU driver package
emulator: don't build mesa with llvm anymore
Fix emulator hdd image building
emulator: alsa config to allow multiple source to play audio
hunspell: use multple checksums for hunspell srcs
Changes to init script
Add script to initialize yocto build env
Add missing copyright headers
Update copyright year to 2014
adb: use modprobe to load dependency modules
udev: disable udev-cache on beaglebone
Add support for BeagleBone Black
Recipe for hunspell
upgrade emulator components
gpu-viv-bin-mx6q: remove dependency to mesa
rpi: disable bbappend from meta-raspberrypi
Install all kernel modules
...
Change-Id: I7adca9894ee35092d546babb1926edbf06300feb
Diffstat (limited to 'recipes/busybox/busybox_1.21.1.bbappend')
-rw-r--r-- | recipes/busybox/busybox_1.21.1.bbappend | 46 |
1 files changed, 46 insertions, 0 deletions
diff --git a/recipes/busybox/busybox_1.21.1.bbappend b/recipes/busybox/busybox_1.21.1.bbappend new file mode 100644 index 0000000..fe5d5ea --- /dev/null +++ b/recipes/busybox/busybox_1.21.1.bbappend | |||
@@ -0,0 +1,46 @@ | |||
1 | ############################################################################# | ||
2 | ## | ||
3 | ## Copyright (C) 2014 Digia Plc and/or its subsidiary(-ies). | ||
4 | ## | ||
5 | ## This file is part of the Qt Enterprise Embedded Scripts of the Qt | ||
6 | ## framework. | ||
7 | ## | ||
8 | ## $QT_BEGIN_LICENSE$ | ||
9 | ## Commercial License Usage Only | ||
10 | ## Licensees holding valid commercial Qt license agreements with Digia | ||
11 | ## with an appropriate addendum covering the Qt Enterprise Embedded Scripts, | ||
12 | ## may use this file in accordance with the terms contained in said license | ||
13 | ## agreement. | ||
14 | ## | ||
15 | ## For further information use the contact form at | ||
16 | ## http://qt.digia.com/contact-us. | ||
17 | ## | ||
18 | ## | ||
19 | ## $QT_END_LICENSE$ | ||
20 | ## | ||
21 | ############################################################################# | ||
22 | |||
23 | FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" | ||
24 | SRC_URI += "\ | ||
25 | file://network.cfg \ | ||
26 | file://busybox-ifplugd.sh \ | ||
27 | file://ifplugd.action \ | ||
28 | " | ||
29 | |||
30 | PACKAGES =+ "${PN}-ifplugd" | ||
31 | FILES_${PN}-ifplugd = "\ | ||
32 | ${sysconfdir}/init.d/busybox-ifplugd.sh \ | ||
33 | ${sysconfdir}/etc/ifplugd/ifplugd.action \ | ||
34 | " | ||
35 | |||
36 | INITSCRIPT_PACKAGES += "${PN}-ifplugd" | ||
37 | INITSCRIPT_NAME_${PN}-ifplugd = "busybox-ifplugd.sh" | ||
38 | |||
39 | RRECOMMENDS_${PN} += "${PN}-ifplugd" | ||
40 | |||
41 | do_install_append () { | ||
42 | install -m 0755 ${WORKDIR}/busybox-ifplugd.sh ${D}${sysconfdir}/init.d/ | ||
43 | |||
44 | install -d ${D}${sysconfdir}/ifplugd | ||
45 | install -m 0755 ${WORKDIR}/ifplugd.action ${D}${sysconfdir}/ifplugd/ | ||
46 | } | ||