summaryrefslogtreecommitdiffstats
path: root/recipes/libgles/libgles-omap3_5.01.01.01.bbappend
diff options
context:
space:
mode:
authorKalle Viironen <kalle.viironen@digia.com>2014-07-04 09:28:14 +0300
committerKalle Viironen <kalle.viironen@digia.com>2014-07-04 09:28:19 +0300
commit82d54484a66e4912a03bb6605457fde62b9f9bcd (patch)
tree721a6cd030817d885822af49a8a6d0209e774cd4 /recipes/libgles/libgles-omap3_5.01.01.01.bbappend
parent24cb0946765e299d4553ab5fa2a37afcac1ea242 (diff)
parent9e1f91f349e0ca11cd8a13d180f9f9557daa3ef8 (diff)
downloadmeta-boot2qt-QtEE_v3.1.0.tar.gz
Merge branch 'stable' into releaseQtEE_v3.1.0
* stable: linux-boundary: revert 1G/3G memory split configure Use specific SHA1 from all of the meta repos beagleboard specific u-boot was removed from meta-ti Old libgles-omap3 packages were removed from meta-ti toradex: enable FunctionFS module needed for adb bbb: correct path for kernel configure fragment image: include i2c-tools in image adb: enabled network mode for toradex toradex: Add hardware acceleration for gstream adbd: add dependency to openssl for libcrypto Include toradex repository imx6: set preferred version for gpu drivers Include older Vivante drivers for Apalis iMX6 Include support for Toradox Apalis iMX6 BBB: enable USB serial kernel drivers No need for RPi in BBMASK Change-Id: Ic3192cd00a8b24972253c64f294de5d364111135
Diffstat (limited to 'recipes/libgles/libgles-omap3_5.01.01.01.bbappend')
-rw-r--r--recipes/libgles/libgles-omap3_5.01.01.01.bbappend42
1 files changed, 42 insertions, 0 deletions
diff --git a/recipes/libgles/libgles-omap3_5.01.01.01.bbappend b/recipes/libgles/libgles-omap3_5.01.01.01.bbappend
new file mode 100644
index 0000000..9a90577
--- /dev/null
+++ b/recipes/libgles/libgles-omap3_5.01.01.01.bbappend
@@ -0,0 +1,42 @@
1#############################################################################
2##
3## Copyright (C) 2014 Digia Plc and/or its subsidiary(-ies).
4##
5## This file is part of the Qt Enterprise Embedded Scripts of the Qt
6## framework.
7##
8## $QT_BEGIN_LICENSE$
9## Commercial License Usage Only
10## Licensees holding valid commercial Qt license agreements with Digia
11## with an appropriate addendum covering the Qt Enterprise Embedded Scripts,
12## may use this file in accordance with the terms contained in said license
13## agreement.
14##
15## For further information use the contact form at
16## http://qt.digia.com/contact-us.
17##
18##
19## $QT_END_LICENSE$
20##
21#############################################################################
22
23FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
24
25BINLOCATION_omap3 = "${S}/gfx_rel_es5.x"
26BINLOCATION_beaglebone = "${S}/gfx_rel_es8.x"
27
28LIBGLESWINDOWSYSTEM = "libpvrPVR2D_FLIPWSEGL.so.1"
29
30# Inhibit warnings about files being stripped.
31INHIBIT_PACKAGE_STRIP = "1"
32
33pkg_postinst_${PN}_append() {
34ESREV=$(echo ${BINLOCATION} | grep -Po '(\d+)(?!.*\d)' )
35echo ${ESREV} > $D${sysconfdir}/powervr-esrev
36}
37
38RRECOMMENDS_${PN} = "omap3-sgx-modules"
39RRECOMMENDS_${PN}-blitwsegl = ""
40RRECOMMENDS_${PN}-flipwsegl = ""
41RRECOMMENDS_${PN}-frontwsegl = ""
42RRECOMMENDS_${PN}-linuxfbwsegl = ""