diff options
Diffstat (limited to 'recipes/mkcard')
-rwxr-xr-x | recipes/mkcard/files/mkcard.sh | 16 | ||||
-rw-r--r-- | recipes/mkcard/mkcard_0.5.bb | 22 |
2 files changed, 22 insertions, 16 deletions
diff --git a/recipes/mkcard/files/mkcard.sh b/recipes/mkcard/files/mkcard.sh index 3e70dbc..e75a176 100755 --- a/recipes/mkcard/files/mkcard.sh +++ b/recipes/mkcard/files/mkcard.sh | |||
@@ -32,11 +32,6 @@ echo ,,,- | |||
32 | 32 | ||
33 | sleep 1 | 33 | sleep 1 |
34 | 34 | ||
35 | |||
36 | if [ -x `which kpartx` ]; then | ||
37 | kpartx -a ${DRIVE} | ||
38 | fi | ||
39 | |||
40 | # handle various device names. | 35 | # handle various device names. |
41 | # note something like fdisk -l /dev/loop0 | egrep -E '^/dev' | cut -d' ' -f1 | 36 | # note something like fdisk -l /dev/loop0 | egrep -E '^/dev' | cut -d' ' -f1 |
42 | # won't work due to https://bugzilla.redhat.com/show_bug.cgi?id=649572 | 37 | # won't work due to https://bugzilla.redhat.com/show_bug.cgi?id=649572 |
@@ -46,21 +41,10 @@ if [ ! -b ${PARTITION1} ]; then | |||
46 | PARTITION1=${DRIVE}p1 | 41 | PARTITION1=${DRIVE}p1 |
47 | fi | 42 | fi |
48 | 43 | ||
49 | DRIVE_NAME=`basename $DRIVE` | ||
50 | DEV_DIR=`dirname $DRIVE` | ||
51 | |||
52 | if [ ! -b ${PARTITION1} ]; then | ||
53 | PARTITION1=$DEV_DIR/mapper/${DRIVE_NAME}p1 | ||
54 | fi | ||
55 | |||
56 | PARTITION2=${DRIVE}2 | 44 | PARTITION2=${DRIVE}2 |
57 | if [ ! -b ${PARTITION2} ]; then | 45 | if [ ! -b ${PARTITION2} ]; then |
58 | PARTITION2=${DRIVE}p2 | 46 | PARTITION2=${DRIVE}p2 |
59 | fi | 47 | fi |
60 | if [ ! -b ${PARTITION2} ]; then | ||
61 | PARTITION2=$DEV_DIR/mapper/${DRIVE_NAME}p2 | ||
62 | fi | ||
63 | |||
64 | 48 | ||
65 | # now make partitions. | 49 | # now make partitions. |
66 | if [ -b ${PARTITION1} ]; then | 50 | if [ -b ${PARTITION1} ]; then |
diff --git a/recipes/mkcard/mkcard_0.5.bb b/recipes/mkcard/mkcard_0.5.bb index 3671f7a..8d71f81 100644 --- a/recipes/mkcard/mkcard_0.5.bb +++ b/recipes/mkcard/mkcard_0.5.bb | |||
@@ -1,3 +1,25 @@ | |||
1 | ############################################################################# | ||
2 | ## | ||
3 | ## Copyright (C) 2014 Digia Plc and/or its subsidiary(-ies). | ||
4 | ## | ||
5 | ## This file is part of the Qt Enterprise Embedded Scripts of the Qt | ||
6 | ## framework. | ||
7 | ## | ||
8 | ## $QT_BEGIN_LICENSE$ | ||
9 | ## Commercial License Usage Only | ||
10 | ## Licensees holding valid commercial Qt license agreements with Digia | ||
11 | ## with an appropriate addendum covering the Qt Enterprise Embedded Scripts, | ||
12 | ## may use this file in accordance with the terms contained in said license | ||
13 | ## agreement. | ||
14 | ## | ||
15 | ## For further information use the contact form at | ||
16 | ## http://qt.digia.com/contact-us. | ||
17 | ## | ||
18 | ## | ||
19 | ## $QT_END_LICENSE$ | ||
20 | ## | ||
21 | ############################################################################# | ||
22 | |||
1 | DESCRIPTION = "mkcard.sh v0.5" | 23 | DESCRIPTION = "mkcard.sh v0.5" |
2 | LICENSE = "GPLv2+" | 24 | LICENSE = "GPLv2+" |
3 | LIC_FILES_CHKSUM = "file://${COREBASE}/bitbake/COPYING;md5=751419260aa954499f7abaabaa882bbe" | 25 | LIC_FILES_CHKSUM = "file://${COREBASE}/bitbake/COPYING;md5=751419260aa954499f7abaabaa882bbe" |