diff options
Diffstat (limited to 'recipes/mkcard')
-rwxr-xr-x | recipes/mkcard/files/mkcard.sh | 62 | ||||
-rw-r--r-- | recipes/mkcard/mkcard_0.5.bb | 36 |
2 files changed, 0 insertions, 98 deletions
diff --git a/recipes/mkcard/files/mkcard.sh b/recipes/mkcard/files/mkcard.sh deleted file mode 100755 index e75a176..0000000 --- a/recipes/mkcard/files/mkcard.sh +++ /dev/null | |||
@@ -1,62 +0,0 @@ | |||
1 | #! /bin/sh | ||
2 | # mkcard.sh v0.5 | ||
3 | # (c) Copyright 2009 Graeme Gregory <dp@xora.org.uk> | ||
4 | # Licensed under terms of GPLv2 | ||
5 | # | ||
6 | # Parts of the procudure base on the work of Denys Dmytriyenko | ||
7 | # http://wiki.omap.com/index.php/MMC_Boot_Format | ||
8 | |||
9 | export LC_ALL=C | ||
10 | |||
11 | if [ $# -ne 1 ]; then | ||
12 | echo "Usage: $0 <drive>" | ||
13 | exit 1; | ||
14 | fi | ||
15 | |||
16 | DRIVE=$1 | ||
17 | |||
18 | dd if=/dev/zero of=$DRIVE bs=1024 count=1024 | ||
19 | |||
20 | SIZE=`fdisk -l $DRIVE | grep Disk | grep bytes | awk '{print $5}'` | ||
21 | |||
22 | echo DISK SIZE - $SIZE bytes | ||
23 | |||
24 | CYLINDERS=`echo $SIZE/255/63/512 | bc` | ||
25 | |||
26 | echo CYLINDERS - $CYLINDERS | ||
27 | |||
28 | { | ||
29 | echo ,9,0x0C,* | ||
30 | echo ,,,- | ||
31 | } | sfdisk -D -H 255 -S 63 -C $CYLINDERS $DRIVE | ||
32 | |||
33 | sleep 1 | ||
34 | |||
35 | # handle various device names. | ||
36 | # note something like fdisk -l /dev/loop0 | egrep -E '^/dev' | cut -d' ' -f1 | ||
37 | # won't work due to https://bugzilla.redhat.com/show_bug.cgi?id=649572 | ||
38 | |||
39 | PARTITION1=${DRIVE}1 | ||
40 | if [ ! -b ${PARTITION1} ]; then | ||
41 | PARTITION1=${DRIVE}p1 | ||
42 | fi | ||
43 | |||
44 | PARTITION2=${DRIVE}2 | ||
45 | if [ ! -b ${PARTITION2} ]; then | ||
46 | PARTITION2=${DRIVE}p2 | ||
47 | fi | ||
48 | |||
49 | # now make partitions. | ||
50 | if [ -b ${PARTITION1} ]; then | ||
51 | umount ${PARTITION1} | ||
52 | mkfs.vfat -F 32 -n "boot" ${PARTITION1} | ||
53 | else | ||
54 | echo "Cant find boot partition in /dev" | ||
55 | fi | ||
56 | |||
57 | if [ -b ${PARITION2} ]; then | ||
58 | umount ${PARTITION2} | ||
59 | mke2fs -t ext3 -j -L "rootfs" ${PARTITION2} | ||
60 | else | ||
61 | echo "Cant find rootfs partition in /dev" | ||
62 | fi | ||
diff --git a/recipes/mkcard/mkcard_0.5.bb b/recipes/mkcard/mkcard_0.5.bb deleted file mode 100644 index 8d71f81..0000000 --- a/recipes/mkcard/mkcard_0.5.bb +++ /dev/null | |||
@@ -1,36 +0,0 @@ | |||
1 | ############################################################################# | ||
2 | ## | ||
3 | ## Copyright (C) 2014 Digia Plc and/or its subsidiary(-ies). | ||
4 | ## | ||
5 | ## This file is part of the Qt Enterprise Embedded Scripts of the Qt | ||
6 | ## framework. | ||
7 | ## | ||
8 | ## $QT_BEGIN_LICENSE$ | ||
9 | ## Commercial License Usage Only | ||
10 | ## Licensees holding valid commercial Qt license agreements with Digia | ||
11 | ## with an appropriate addendum covering the Qt Enterprise Embedded Scripts, | ||
12 | ## may use this file in accordance with the terms contained in said license | ||
13 | ## agreement. | ||
14 | ## | ||
15 | ## For further information use the contact form at | ||
16 | ## http://qt.digia.com/contact-us. | ||
17 | ## | ||
18 | ## | ||
19 | ## $QT_END_LICENSE$ | ||
20 | ## | ||
21 | ############################################################################# | ||
22 | |||
23 | DESCRIPTION = "mkcard.sh v0.5" | ||
24 | LICENSE = "GPLv2+" | ||
25 | LIC_FILES_CHKSUM = "file://${COREBASE}/bitbake/COPYING;md5=751419260aa954499f7abaabaa882bbe" | ||
26 | SECTION = "devel" | ||
27 | PR = "0" | ||
28 | |||
29 | SRC_URI = "file://mkcard.sh" | ||
30 | |||
31 | do_install () { | ||
32 | install -d ${D}${bindir}/ | ||
33 | install -m 0755 ${WORKDIR}/mkcard.sh ${D}${bindir}/ | ||
34 | } | ||
35 | |||
36 | BBCLASSEXTEND = "nativesdk" | ||