summaryrefslogtreecommitdiffstats
path: root/recipes/packagegroup
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/packagegroup')
-rw-r--r--recipes/packagegroup/nativesdk-packagegroup-b2qt-embedded-toolchain-host.bb1
-rw-r--r--recipes/packagegroup/nativesdk-packagegroup-b2qt-embedded-toolchain-target.bb3
-rw-r--r--recipes/packagegroup/packagegroup-b2qt-embedded-base.bb49
-rw-r--r--recipes/packagegroup/packagegroup-b2qt-embedded-gstreamer.bb42
-rw-r--r--recipes/packagegroup/packagegroup-b2qt-embedded-tools.bb33
5 files changed, 127 insertions, 1 deletions
diff --git a/recipes/packagegroup/nativesdk-packagegroup-b2qt-embedded-toolchain-host.bb b/recipes/packagegroup/nativesdk-packagegroup-b2qt-embedded-toolchain-host.bb
index f32bac4..9c92438 100644
--- a/recipes/packagegroup/nativesdk-packagegroup-b2qt-embedded-toolchain-host.bb
+++ b/recipes/packagegroup/nativesdk-packagegroup-b2qt-embedded-toolchain-host.bb
@@ -28,7 +28,6 @@ LICENSE = "CLOSED"
28require recipes-core/packagegroups/nativesdk-packagegroup-sdk-host.bb 28require recipes-core/packagegroups/nativesdk-packagegroup-sdk-host.bb
29 29
30RDEPENDS_${PN} = "\ 30RDEPENDS_${PN} = "\
31 mkcard-nativesdk \
32 python-nativesdk \ 31 python-nativesdk \
33 python-subprocess-nativesdk \ 32 python-subprocess-nativesdk \
34 " 33 "
diff --git a/recipes/packagegroup/nativesdk-packagegroup-b2qt-embedded-toolchain-target.bb b/recipes/packagegroup/nativesdk-packagegroup-b2qt-embedded-toolchain-target.bb
index 4cdd404..457ea56 100644
--- a/recipes/packagegroup/nativesdk-packagegroup-b2qt-embedded-toolchain-target.bb
+++ b/recipes/packagegroup/nativesdk-packagegroup-b2qt-embedded-toolchain-target.bb
@@ -47,5 +47,8 @@ RDEPENDS_${PN} += "\
47 udev-dev \ 47 udev-dev \
48 tslib-dev \ 48 tslib-dev \
49 hunspell-dev \ 49 hunspell-dev \
50 libcap-dev \
51 wpa-supplicant-dev \
52 ${@base_contains("DISTRO_FEATURES", "bluetooth", "bluez4-dev", "", d)} \
50 ${MACHINE_EXTRA_INSTALL_SDK} \ 53 ${MACHINE_EXTRA_INSTALL_SDK} \
51 " 54 "
diff --git a/recipes/packagegroup/packagegroup-b2qt-embedded-base.bb b/recipes/packagegroup/packagegroup-b2qt-embedded-base.bb
new file mode 100644
index 0000000..0942a7e
--- /dev/null
+++ b/recipes/packagegroup/packagegroup-b2qt-embedded-base.bb
@@ -0,0 +1,49 @@
1#############################################################################
2##
3## Copyright (C) 2014 Digia Plc and/or its subsidiary(-ies).
4##
5## This file is part of the Qt Enterprise Embedded Scripts of the Qt
6## framework.
7##
8## $QT_BEGIN_LICENSE$
9## Commercial License Usage Only
10## Licensees holding valid commercial Qt license agreements with Digia
11## with an appropriate addendum covering the Qt Enterprise Embedded Scripts,
12## may use this file in accordance with the terms contained in said license
13## agreement.
14##
15## For further information use the contact form at
16## http://qt.digia.com/contact-us.
17##
18##
19## $QT_END_LICENSE$
20##
21#############################################################################
22
23DESCRIPTION = "Packagegroup for B2Qt embedded Linux image"
24LICENSE = "CLOSED"
25PR = "r0"
26
27inherit packagegroup
28
29RDEPENDS_${PN} = "\
30 kernel-modules \
31 adbd \
32 psplash \
33 openssh-sftp-server \
34 openssl \
35 libpng \
36 jpeg \
37 tiff \
38 libxslt \
39 icu \
40 freetype \
41 fontconfig \
42 liberation-fonts \
43 tslib \
44 tslib-calibrate \
45 alsa-utils-amixer \
46 hunspell \
47 ca-certificates \
48 ${MACHINE_EXTRA_INSTALL} \
49 "
diff --git a/recipes/packagegroup/packagegroup-b2qt-embedded-gstreamer.bb b/recipes/packagegroup/packagegroup-b2qt-embedded-gstreamer.bb
new file mode 100644
index 0000000..f6a8a54
--- /dev/null
+++ b/recipes/packagegroup/packagegroup-b2qt-embedded-gstreamer.bb
@@ -0,0 +1,42 @@
1#############################################################################
2##
3## Copyright (C) 2014 Digia Plc and/or its subsidiary(-ies).
4##
5## This file is part of the Qt Enterprise Embedded Scripts of the Qt
6## framework.
7##
8## $QT_BEGIN_LICENSE$
9## Commercial License Usage Only
10## Licensees holding valid commercial Qt license agreements with Digia
11## with an appropriate addendum covering the Qt Enterprise Embedded Scripts,
12## may use this file in accordance with the terms contained in said license
13## agreement.
14##
15## For further information use the contact form at
16## http://qt.digia.com/contact-us.
17##
18##
19## $QT_END_LICENSE$
20##
21#############################################################################
22
23DESCRIPTION = "Additional gstreamer packagegroup for B2Qt embedded Linux image"
24LICENSE = "CLOSED"
25PR = "r0"
26
27inherit packagegroup
28
29RDEPENDS_${PN} = "\
30 gst-meta-video \
31 gst-meta-audio \
32 gst-plugins-good \
33 gst-plugins-base-app \
34 gst-plugins-good-videofilter \
35 gst-plugins-good-id3demux \
36 gst-plugins-good-auparse \
37 gst-plugins-good-isomp4 \
38 gst-plugins-ugly-rmdemux \
39 gst-plugins-ugly-asf \
40 gst-plugins-ugly-a52dec \
41 gst-ffmpeg \
42 "
diff --git a/recipes/packagegroup/packagegroup-b2qt-embedded-tools.bb b/recipes/packagegroup/packagegroup-b2qt-embedded-tools.bb
new file mode 100644
index 0000000..61ca211
--- /dev/null
+++ b/recipes/packagegroup/packagegroup-b2qt-embedded-tools.bb
@@ -0,0 +1,33 @@
1#############################################################################
2##
3## Copyright (C) 2014 Digia Plc and/or its subsidiary(-ies).
4##
5## This file is part of the Qt Enterprise Embedded Scripts of the Qt
6## framework.
7##
8## $QT_BEGIN_LICENSE$
9## Commercial License Usage Only
10## Licensees holding valid commercial Qt license agreements with Digia
11## with an appropriate addendum covering the Qt Enterprise Embedded Scripts,
12## may use this file in accordance with the terms contained in said license
13## agreement.
14##
15## For further information use the contact form at
16## http://qt.digia.com/contact-us.
17##
18##
19## $QT_END_LICENSE$
20##
21#############################################################################
22
23DESCRIPTION = "Additional tools packagegroup for B2Qt embedded Linux image"
24LICENSE = "CLOSED"
25PR = "r0"
26
27inherit packagegroup
28
29RDEPENDS_${PN} = "\
30 ldd \
31 binutils \
32 binutils-symlinks \
33 "