diff options
author | Khem Raj <raj.khem@gmail.com> | 2021-02-24 19:15:24 -0800 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2021-03-01 11:12:14 -0800 |
commit | 11127751aad368698f56543415e33e93e6ff709e (patch) | |
tree | 8dc1365e53e52d160a7cbbd1112e20165aa84055 | |
parent | 1c0eefea21688b7e01ea33a0a7bbdeefb9014c27 (diff) | |
download | meta-clang-11127751aad368698f56543415e33e93e6ff709e.tar.gz |
musl: Remove workaround to disable -frounding-math
The hang in clang seems to gone with clang12
remove dependecy on gcc-cross if using clang to compile musl
Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r-- | recipes-core/musl/musl_%.bbappend | 7 |
1 files changed, 1 insertions, 6 deletions
diff --git a/recipes-core/musl/musl_%.bbappend b/recipes-core/musl/musl_%.bbappend index c99c4be..8732a4f 100644 --- a/recipes-core/musl/musl_%.bbappend +++ b/recipes-core/musl/musl_%.bbappend | |||
@@ -1,10 +1,5 @@ | |||
1 | DEPENDS_append_toolchain-clang = " clang-cross-${TARGET_ARCH}" | 1 | DEPENDS_append_toolchain-clang = " clang-cross-${TARGET_ARCH}" |
2 | DEPENDS_remove_toolchain-clang = "virtual/${TARGET_PREFIX}gcc" | ||
2 | TOOLCHAIN_x86-x32 = "gcc" | 3 | TOOLCHAIN_x86-x32 = "gcc" |
3 | TOOLCHAIN_riscv64 = "gcc" | 4 | TOOLCHAIN_riscv64 = "gcc" |
4 | TOOLCHAIN_powerpc64 = "gcc" | 5 | TOOLCHAIN_powerpc64 = "gcc" |
5 | |||
6 | # workaround until https://bugs.llvm.org/show_bug.cgi?id=44384 | ||
7 | # is fixed | ||
8 | do_configure_prepend_toolchain-clang () { | ||
9 | sed -i -e '/frounding-math/d' ${S}/configure | ||
10 | } | ||