summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorErik Schilling <erik@riscstar.com>2025-04-10 09:41:14 +0200
committerKhem Raj <raj.khem@gmail.com>2025-04-10 17:55:07 -0700
commit19aa6e951960ed17af4fe2575a0eb1ee276263a3 (patch)
tree447050018f75d9930ad6750ad4e8fe4623d57231
parent8f1a75ac467863604a47c2493ddb859cabc9eed2 (diff)
downloadmeta-clang-19aa6e951960ed17af4fe2575a0eb1ee276263a3.tar.gz
bpftrace: add systemd PACKAGECONFIG option
This option mostly enables sd_notify support and is useful when running bpftrace as part of a systemd service [1]. Defaulting to the systemd DISTRO_FEATURES seems like a reasonable choice. The official builds also now enable this by default [2]. [1] https://bpftrace.org/docs/latest#_systemd_support [2] https://github.com/bpftrace/bpftrace/pull/3969 Signed-off-by: Erik Schilling <erik@riscstar.com>
-rw-r--r--dynamic-layers/meta-python/recipes-devtools/bpftrace/bpftrace_0.23.0.bb8
1 files changed, 6 insertions, 2 deletions
diff --git a/dynamic-layers/meta-python/recipes-devtools/bpftrace/bpftrace_0.23.0.bb b/dynamic-layers/meta-python/recipes-devtools/bpftrace/bpftrace_0.23.0.bb
index 48176a8..12ebbe8 100644
--- a/dynamic-layers/meta-python/recipes-devtools/bpftrace/bpftrace_0.23.0.bb
+++ b/dynamic-layers/meta-python/recipes-devtools/bpftrace/bpftrace_0.23.0.bb
@@ -26,11 +26,15 @@ SRCREV = "339a2f571505616832379ca216627aceb0e5d0bb"
26 26
27S = "${WORKDIR}/git" 27S = "${WORKDIR}/git"
28 28
29inherit bash-completion cmake ptest 29inherit bash-completion cmake ptest pkgconfig
30 30
31PACKAGECONFIG ?= "${@bb.utils.contains('PTEST_ENABLED', '1', 'tests', '', d)}" 31PACKAGECONFIG ?= " \
32 ${@bb.utils.contains('PTEST_ENABLED', '1', 'tests', '', d)} \
33 ${@bb.utils.contains("DISTRO_FEATURES", "systemd", "systemd", "", d)} \
34 "
32 35
33PACKAGECONFIG[tests] = "-DBUILD_TESTING=ON,-DBUILD_TESTING=OFF,gtest xxd-native" 36PACKAGECONFIG[tests] = "-DBUILD_TESTING=ON,-DBUILD_TESTING=OFF,gtest xxd-native"
37PACKAGECONFIG[systemd] = "-DENABLE_SYSTEMD=ON,-DENABLE_SYSTEMD=OFF,systemd"
34 38
35do_install_ptest() { 39do_install_ptest() {
36 if [ -e ${B}/tests/bpftrace_test ]; then 40 if [ -e ${B}/tests/bpftrace_test ]; then