diff options
author | Hongxu Jia <hongxu.jia@windriver.com> | 2025-02-24 14:13:08 +0800 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2025-02-24 19:41:37 -0800 |
commit | 3669c28e90ad710e38ad2381ef0292d706fa9ffd (patch) | |
tree | 058c3fcefea15e74241bdf6dbf8062ad3ffec6c1 | |
parent | 93dec321980091b8abfa1f7d72c50b844c63167c (diff) | |
download | meta-clang-3669c28e90ad710e38ad2381ef0292d706fa9ffd.tar.gz |
clang: set BPN = "clang" for clang cross,crosssdk,cross-canadian recipes
Similar gcc recipes in oe-core [1], set BPN = "clang" in common.inc for
clang cross,crosssdk,cross-canadian recipes, but the recipe compiler-rt-sanitizers,
compiler-rt, libclc, libcxx, openmp which shares sources with clang are not affected
Due to commit [2], the BPN of llvm-project-source is not affected by this
commit
[1] https://github.com/openembedded/openembedded-core/commit/a2c5509520d5c3e082f55844e6545d0309565f8f
[2] https://github.com/kraj/meta-clang/commit/e7517e1910a7d49abb4782fa0778f0b958f7717d
Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
-rw-r--r-- | recipes-devtools/clang/common.inc | 2 | ||||
-rw-r--r-- | recipes-devtools/clang/compiler-rt-sanitizers_git.bb | 2 | ||||
-rw-r--r-- | recipes-devtools/clang/compiler-rt_git.bb | 2 | ||||
-rw-r--r-- | recipes-devtools/clang/libclc_git.bb | 2 | ||||
-rw-r--r-- | recipes-devtools/clang/libcxx_git.bb | 2 | ||||
-rw-r--r-- | recipes-devtools/clang/openmp_git.bb | 2 |
6 files changed, 12 insertions, 0 deletions
diff --git a/recipes-devtools/clang/common.inc b/recipes-devtools/clang/common.inc index 4d70528..582820d 100644 --- a/recipes-devtools/clang/common.inc +++ b/recipes-devtools/clang/common.inc | |||
@@ -64,3 +64,5 @@ B ?= "${WORKDIR}/llvm-project-source-${PV}/build.${HOST_SYS}.${TARGET_SYS}" | |||
64 | # The real WORKDIR location isn't a dependency for the shared workdir. | 64 | # The real WORKDIR location isn't a dependency for the shared workdir. |
65 | src_patches[vardepsexclude] = "WORKDIR" | 65 | src_patches[vardepsexclude] = "WORKDIR" |
66 | should_apply[vardepsexclude] += "PN" | 66 | should_apply[vardepsexclude] += "PN" |
67 | |||
68 | BPN = "clang" | ||
diff --git a/recipes-devtools/clang/compiler-rt-sanitizers_git.bb b/recipes-devtools/clang/compiler-rt-sanitizers_git.bb index b42c709..1cee81b 100644 --- a/recipes-devtools/clang/compiler-rt-sanitizers_git.bb +++ b/recipes-devtools/clang/compiler-rt-sanitizers_git.bb | |||
@@ -10,6 +10,8 @@ SECTION = "base" | |||
10 | require clang.inc | 10 | require clang.inc |
11 | require common-source.inc | 11 | require common-source.inc |
12 | 12 | ||
13 | BPN = "compiler-rt-sanitizers" | ||
14 | |||
13 | inherit cmake pkgconfig python3native | 15 | inherit cmake pkgconfig python3native |
14 | 16 | ||
15 | 17 | ||
diff --git a/recipes-devtools/clang/compiler-rt_git.bb b/recipes-devtools/clang/compiler-rt_git.bb index 7bc81af..f88e4a2 100644 --- a/recipes-devtools/clang/compiler-rt_git.bb +++ b/recipes-devtools/clang/compiler-rt_git.bb | |||
@@ -12,6 +12,8 @@ SECTION = "base" | |||
12 | require clang.inc | 12 | require clang.inc |
13 | require common-source.inc | 13 | require common-source.inc |
14 | 14 | ||
15 | BPN = "compiler-rt" | ||
16 | |||
15 | inherit cmake cmake-native pkgconfig python3native | 17 | inherit cmake cmake-native pkgconfig python3native |
16 | 18 | ||
17 | 19 | ||
diff --git a/recipes-devtools/clang/libclc_git.bb b/recipes-devtools/clang/libclc_git.bb index 0d43133..1e2f837 100644 --- a/recipes-devtools/clang/libclc_git.bb +++ b/recipes-devtools/clang/libclc_git.bb | |||
@@ -5,6 +5,8 @@ SECTION = "libs" | |||
5 | require clang.inc | 5 | require clang.inc |
6 | require common-source.inc | 6 | require common-source.inc |
7 | 7 | ||
8 | BPN = "libclc" | ||
9 | |||
8 | TOOLCHAIN = "clang" | 10 | TOOLCHAIN = "clang" |
9 | 11 | ||
10 | LIC_FILES_CHKSUM = "file://libclc/LICENSE.TXT;md5=7cc795f6cbb2d801d84336b83c8017db" | 12 | LIC_FILES_CHKSUM = "file://libclc/LICENSE.TXT;md5=7cc795f6cbb2d801d84336b83c8017db" |
diff --git a/recipes-devtools/clang/libcxx_git.bb b/recipes-devtools/clang/libcxx_git.bb index 816d037..85c467c 100644 --- a/recipes-devtools/clang/libcxx_git.bb +++ b/recipes-devtools/clang/libcxx_git.bb | |||
@@ -10,6 +10,8 @@ require common-source.inc | |||
10 | 10 | ||
11 | inherit cmake cmake-native python3native | 11 | inherit cmake cmake-native python3native |
12 | 12 | ||
13 | BPN = "libcxx" | ||
14 | |||
13 | PACKAGECONFIG ??= "compiler-rt exceptions ${@bb.utils.contains("TC_CXX_RUNTIME", "llvm", "unwind unwind-shared", "", d)}" | 15 | PACKAGECONFIG ??= "compiler-rt exceptions ${@bb.utils.contains("TC_CXX_RUNTIME", "llvm", "unwind unwind-shared", "", d)}" |
14 | PACKAGECONFIG:append:armv5 = " no-atomics" | 16 | PACKAGECONFIG:append:armv5 = " no-atomics" |
15 | PACKAGECONFIG:remove:class-native = "compiler-rt" | 17 | PACKAGECONFIG:remove:class-native = "compiler-rt" |
diff --git a/recipes-devtools/clang/openmp_git.bb b/recipes-devtools/clang/openmp_git.bb index 549df0e..398479b 100644 --- a/recipes-devtools/clang/openmp_git.bb +++ b/recipes-devtools/clang/openmp_git.bb | |||
@@ -8,6 +8,8 @@ SECTION = "libs" | |||
8 | require clang.inc | 8 | require clang.inc |
9 | require common-source.inc | 9 | require common-source.inc |
10 | 10 | ||
11 | BPN = "openmp" | ||
12 | |||
11 | TOOLCHAIN = "clang" | 13 | TOOLCHAIN = "clang" |
12 | 14 | ||
13 | LIC_FILES_CHKSUM = "file://openmp/LICENSE.TXT;md5=d75288d1ce0450b28b8d58a284c09c79" | 15 | LIC_FILES_CHKSUM = "file://openmp/LICENSE.TXT;md5=d75288d1ce0450b28b8d58a284c09c79" |