diff options
author | Hongxu Jia <hongxu.jia@windriver.com> | 2024-10-12 14:55:34 +0800 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2024-10-12 08:15:47 -0700 |
commit | 7cf1f0e391e2b9630ae6a0dafbe68c089c457c61 (patch) | |
tree | 0eaad3722cfdccff709a28d4c76a8749824cdedd | |
parent | ebcfaeee43df41d9c99fe58e077e270f529ed686 (diff) | |
download | meta-clang-7cf1f0e391e2b9630ae6a0dafbe68c089c457c61.tar.gz |
llvm-project-source.inc: fix racing on building lib32-llvm-project-source-19.1.0 and llvm-project-source-19.1.0
While enabling multilib, build lib32-llvm-project-source-19.1.0 and
llvm-project-source-19.1.0 at the same time:
$ MACHINE = "qemux86-64"
$ require conf/multilib.conf
$ MULTILIBS = "multilib:lib32"
$ DEFAULTTUNE:virtclass-multilib-lib32 = "x86"
$ bitbake lib32-llvm-project-source-19.1.0 llvm-project-source-19.1.0
...
$ cat tmp/work-shared/llvm-project-source-19.1.0-r0/temp/log.task_order
20241012-070604.819630 do_recipe_qa (2728706): log.do_recipe_qa.2728706
20241012-070604.883194 do_recipe_qa (2728707): log.do_recipe_qa.2728707
20241012-070605.037448 do_fetch (2728779): log.do_fetch.2728779
20241012-070605.165280 do_fetch (2728848): log.do_fetch.2728848
20241012-071030.798104 do_unpack (2733554): log.do_unpack.2733554
20241012-071030.864536 do_unpack (2733559): log.do_unpack.2733559
There are two tasks for do_fetch, do_unpack and others, so there are race issues.
Both of them have the same hardcode 'llvm-project-source-' prefix in ${WORKDIR} and
${S}, explicitly disable lib32-llvm-project-source-19.1.0 for multilib
Set llvm-project-source as BPN of llvm-project-source-19.1.0
Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
-rw-r--r-- | conf/layer.conf | 2 | ||||
-rw-r--r-- | recipes-devtools/clang/llvm-project-source.bb | 2 |
2 files changed, 4 insertions, 0 deletions
diff --git a/conf/layer.conf b/conf/layer.conf index db9d013..2fbf2f7 100644 --- a/conf/layer.conf +++ b/conf/layer.conf | |||
@@ -35,5 +35,7 @@ CLANGSDK ??= "0" | |||
35 | 35 | ||
36 | LLVMVERSION = "19.1.0" | 36 | LLVMVERSION = "19.1.0" |
37 | 37 | ||
38 | NON_MULTILIB_RECIPES:append = " llvm-project-source" | ||
39 | |||
38 | require conf/nonclangable.conf | 40 | require conf/nonclangable.conf |
39 | require conf/nonscanable.conf | 41 | require conf/nonscanable.conf |
diff --git a/recipes-devtools/clang/llvm-project-source.bb b/recipes-devtools/clang/llvm-project-source.bb index 78664c5..c1cd887 100644 --- a/recipes-devtools/clang/llvm-project-source.bb +++ b/recipes-devtools/clang/llvm-project-source.bb | |||
@@ -7,4 +7,6 @@ HOMEPAGE = "https://github.com/llvm/llvm-project" | |||
7 | require llvm-project-source.inc | 7 | require llvm-project-source.inc |
8 | require clang.inc | 8 | require clang.inc |
9 | 9 | ||
10 | BPN = "llvm-project-source" | ||
11 | |||
10 | EXCLUDE_FROM_WORLD = "1" | 12 | EXCLUDE_FROM_WORLD = "1" |