summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2025-04-02 17:02:21 +0200
committerKhem Raj <raj.khem@gmail.com>2025-04-02 12:50:10 -0700
commit7d376c4a0cb45d34f45a26a843b57b3c21cf59fc (patch)
treebba813a9ed60765484cbc15897e2ada952404abc
parent6ec8e778edf8eea06b381b0b30d6ee036f650e7d (diff)
downloadmeta-clang-7d376c4a0cb45d34f45a26a843b57b3c21cf59fc.tar.gz
clang: add whitespace around assignments
With: https://lists.openembedded.org/g/bitbake-devel/message/17508 there are many WARNINGs from this layer Most of them are caused by this LLVM_LIBDIR_SUFFIX=" which is included everywhere. WARNING: meta-clang/recipes-devtools/clang/clang-cross-canadian_git.bb: meta-clang/recipes-devtools/clang/clang.inc:19 has a lack of whitespace around the assignment: 'LLVM_LIBDIR_SUFFIX="${@d.getVar('baselib').replace('lib', '')}"' WARNING: meta-clang/recipes-devtools/clang/clang-crosssdk_git.bb: meta-clang/recipes-devtools/clang/clang.inc:19 has a lack of whitespace around the assignment: 'LLVM_LIBDIR_SUFFIX="${@d.getVar('baselib').replace('lib', '')}"' WARNING: meta-clang/recipes-devtools/clang/clang.inc:19 has a lack of whitespace around the assignment: 'LLVM_LIBDIR_SUFFIX="${@d.getVar('baselib').replace('lib', '')}"' WARNING: meta-clang/recipes-devtools/clang/clang_git.bb: meta-clang/recipes-devtools/clang/clang.inc:19 has a lack of whitespace around the assignment: 'LLVM_LIBDIR_SUFFIX="${@d.getVar('baselib').replace('lib', '')}"' WARNING: meta-clang/recipes-devtools/clang/compiler-rt-sanitizers_git.bb: meta-clang/recipes-devtools/clang/clang.inc:19 has a lack of whitespace around the assignment: 'LLVM_LIBDIR_SUFFIX="${@d.getVar('baselib').replace('lib', '')}"' WARNING: meta-clang/recipes-devtools/clang/compiler-rt-sanitizers_git.bb: meta-clang/recipes-devtools/clang/compiler-rt-sanitizers_git.bb:31 has a lack of whitespace around the assignment: 'PACKAGECONFIG[ctx-profile] ="-DCOMPILER_RT_BUILD_CTX_PROFILE=ON,-DCOMPILER_RT_BUILD_CTX_PROFILE=OFF"' WARNING: meta-clang/recipes-devtools/clang/compiler-rt_git.bb: meta-clang/recipes-devtools/clang/compiler-rt_git.bb:47 has a lack of whitespace around the assignment: 'PACKAGECONFIG[profile] ="-DCOMPILER_RT_BUILD_PROFILE=ON,-DCOMPILER_RT_BUILD_PROFILE=OFF"' WARNING: meta-clang/recipes-devtools/clang/compiler-rt_git.bb: meta-clang/recipes-devtools/clang/compiler-rt_git.bb:49 has a lack of whitespace around the assignment: 'PACKAGECONFIG[ctx-profile] ="-DCOMPILER_RT_BUILD_CTX_PROFILE=ON,-DCOMPILER_RT_BUILD_CTX_PROFILE=OFF"' WARNING: meta-clang/recipes-devtools/clang/compiler-rt_git.bb:47 has a lack of whitespace around the assignment: 'PACKAGECONFIG[profile] ="-DCOMPILER_RT_BUILD_PROFILE=ON,-DCOMPILER_RT_BUILD_PROFILE=OFF"' WARNING: meta-clang/recipes-devtools/clang/compiler-rt_git.bb:49 has a lack of whitespace around the assignment: 'PACKAGECONFIG[ctx-profile] ="-DCOMPILER_RT_BUILD_CTX_PROFILE=ON,-DCOMPILER_RT_BUILD_CTX_PROFILE=OFF"' WARNING: meta-clang/recipes-devtools/clang/libclc_git.bb: meta-clang/recipes-devtools/clang/clang.inc:19 has a lack of whitespace around the assignment: 'LLVM_LIBDIR_SUFFIX="${@d.getVar('baselib').replace('lib', '')}"' WARNING: meta-clang/recipes-devtools/clang/libcxx_git.bb: meta-clang/recipes-devtools/clang/clang.inc:19 has a lack of whitespace around the assignment: 'LLVM_LIBDIR_SUFFIX="${@d.getVar('baselib').replace('lib', '')}"' WARNING: meta-clang/recipes-devtools/clang/llvm-project-source.bb: meta-clang/recipes-devtools/clang/clang.inc:19 has a lack of whitespace around the assignment: 'LLVM_LIBDIR_SUFFIX="${@d.getVar('baselib').replace('lib', '')}"' WARNING: meta-clang/recipes-devtools/clang/openmp_git.bb: meta-clang/recipes-devtools/clang/clang.inc:19 has a lack of whitespace around the assignment: 'LLVM_LIBDIR_SUFFIX="${@d.getVar('baselib').replace('lib', '')}"' Signed-off-by: Martin Jansa <martin.jansa@gmail.com>
-rw-r--r--recipes-devtools/clang/clang.inc2
-rw-r--r--recipes-devtools/clang/compiler-rt-sanitizers_git.bb2
-rw-r--r--recipes-devtools/clang/compiler-rt_git.bb4
3 files changed, 4 insertions, 4 deletions
diff --git a/recipes-devtools/clang/clang.inc b/recipes-devtools/clang/clang.inc
index 784b1b1..59735cd 100644
--- a/recipes-devtools/clang/clang.inc
+++ b/recipes-devtools/clang/clang.inc
@@ -16,7 +16,7 @@ CLANGMD5SUM = "ff42885ed2ab98f1ecb8c1fc41205343"
16LLDMD5SUM = "ae7dc7c027b1fa89b5b013d391d3ee2b" 16LLDMD5SUM = "ae7dc7c027b1fa89b5b013d391d3ee2b"
17LLDBMD5SUM = "2e0d44968471fcde980034dbb826bea9" 17LLDBMD5SUM = "2e0d44968471fcde980034dbb826bea9"
18 18
19LLVM_LIBDIR_SUFFIX="${@d.getVar('baselib').replace('lib', '')}" 19LLVM_LIBDIR_SUFFIX = "${@d.getVar('baselib').replace('lib', '')}"
20 20
21# set the default pigz thread 21# set the default pigz thread
22export PIGZ = "-p ${@oe.utils.cpu_count(at_least=2)}" 22export PIGZ = "-p ${@oe.utils.cpu_count(at_least=2)}"
diff --git a/recipes-devtools/clang/compiler-rt-sanitizers_git.bb b/recipes-devtools/clang/compiler-rt-sanitizers_git.bb
index c892e36..6beb16a 100644
--- a/recipes-devtools/clang/compiler-rt-sanitizers_git.bb
+++ b/recipes-devtools/clang/compiler-rt-sanitizers_git.bb
@@ -28,7 +28,7 @@ PACKAGECONFIG ??= ""
28PACKAGECONFIG[crt] = "-DCOMPILER_RT_BUILD_CRT:BOOL=ON,-DCOMPILER_RT_BUILD_CRT:BOOL=OFF" 28PACKAGECONFIG[crt] = "-DCOMPILER_RT_BUILD_CRT:BOOL=ON,-DCOMPILER_RT_BUILD_CRT:BOOL=OFF"
29PACKAGECONFIG[static-libcxx] = "-DSANITIZER_USE_STATIC_CXX_ABI=ON -DSANITIZER_USE_STATIC_LLVM_UNWINDER=ON -DCOMPILER_RT_ENABLE_STATIC_UNWINDER=ON,," 29PACKAGECONFIG[static-libcxx] = "-DSANITIZER_USE_STATIC_CXX_ABI=ON -DSANITIZER_USE_STATIC_LLVM_UNWINDER=ON -DCOMPILER_RT_ENABLE_STATIC_UNWINDER=ON,,"
30# Context Profiling 30# Context Profiling
31PACKAGECONFIG[ctx-profile] ="-DCOMPILER_RT_BUILD_CTX_PROFILE=ON,-DCOMPILER_RT_BUILD_CTX_PROFILE=OFF" 31PACKAGECONFIG[ctx-profile] = "-DCOMPILER_RT_BUILD_CTX_PROFILE=ON,-DCOMPILER_RT_BUILD_CTX_PROFILE=OFF"
32 32
33HF = "" 33HF = ""
34HF:class-target = "${@ bb.utils.contains('TUNE_CCARGS_MFLOAT', 'hard', 'hf', '', d)}" 34HF:class-target = "${@ bb.utils.contains('TUNE_CCARGS_MFLOAT', 'hard', 'hf', '', d)}"
diff --git a/recipes-devtools/clang/compiler-rt_git.bb b/recipes-devtools/clang/compiler-rt_git.bb
index 266c54a..debc61f 100644
--- a/recipes-devtools/clang/compiler-rt_git.bb
+++ b/recipes-devtools/clang/compiler-rt_git.bb
@@ -44,9 +44,9 @@ LIBCPLUSPLUS:class-target:toolchain-clang = "-stdlib=libstdc++"
44 44
45PACKAGECONFIG ??= "" 45PACKAGECONFIG ??= ""
46PACKAGECONFIG[crt] = "-DCOMPILER_RT_BUILD_CRT:BOOL=ON,-DCOMPILER_RT_BUILD_CRT:BOOL=OFF" 46PACKAGECONFIG[crt] = "-DCOMPILER_RT_BUILD_CRT:BOOL=ON,-DCOMPILER_RT_BUILD_CRT:BOOL=OFF"
47PACKAGECONFIG[profile] ="-DCOMPILER_RT_BUILD_PROFILE=ON,-DCOMPILER_RT_BUILD_PROFILE=OFF" 47PACKAGECONFIG[profile] = "-DCOMPILER_RT_BUILD_PROFILE=ON,-DCOMPILER_RT_BUILD_PROFILE=OFF"
48# Context Profiling, might need to enable 'profile' too 48# Context Profiling, might need to enable 'profile' too
49PACKAGECONFIG[ctx-profile] ="-DCOMPILER_RT_BUILD_CTX_PROFILE=ON,-DCOMPILER_RT_BUILD_CTX_PROFILE=OFF" 49PACKAGECONFIG[ctx-profile] = "-DCOMPILER_RT_BUILD_CTX_PROFILE=ON,-DCOMPILER_RT_BUILD_CTX_PROFILE=OFF"
50 50
51HF = "" 51HF = ""
52HF:class-target = "${@ bb.utils.contains('TUNE_CCARGS_MFLOAT', 'hard', 'hf', '', d)}" 52HF:class-target = "${@ bb.utils.contains('TUNE_CCARGS_MFLOAT', 'hard', 'hf', '', d)}"