summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2025-03-12 00:00:01 -0700
committerKhem Raj <raj.khem@gmail.com>2025-03-21 21:30:56 -0700
commit8e2d5d6e689c392a5cfa23935f89a83ec1591a21 (patch)
treed6e6015f899b848344eac34925ba9db879ef03c4
parent6da0abaa33b458a37b97f42e3755245e3220bf27 (diff)
downloadmeta-clang-8e2d5d6e689c392a5cfa23935f89a83ec1591a21.tar.gz
bcc: Upgrade to 0.33.0+
Fix version string and add missing dependencies for ptests Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--dynamic-layers/meta-python/recipes-devtools/bcc/bcc/0001-tests-cc-Use-c-14-standard.patch29
-rw-r--r--dynamic-layers/meta-python/recipes-devtools/bcc/bcc_0.33.0.bb (renamed from dynamic-layers/meta-python/recipes-devtools/bcc/bcc_0.30.0.bb)6
2 files changed, 3 insertions, 32 deletions
diff --git a/dynamic-layers/meta-python/recipes-devtools/bcc/bcc/0001-tests-cc-Use-c-14-standard.patch b/dynamic-layers/meta-python/recipes-devtools/bcc/bcc/0001-tests-cc-Use-c-14-standard.patch
deleted file mode 100644
index dcd9dc1..0000000
--- a/dynamic-layers/meta-python/recipes-devtools/bcc/bcc/0001-tests-cc-Use-c-14-standard.patch
+++ /dev/null
@@ -1,29 +0,0 @@
1From 9f45e12ad4689ca2c41844b77c6d789d21509a13 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Mon, 6 Mar 2023 13:26:11 -0800
4Subject: [PATCH] tests/cc: Use c++14 standard
5
6default c++ standard was bumped to c++17 when using clang16+ compiler
7via 907b89cc9, however, tests which use check tool is not yet ported
8to work with c++17 standard, therefore use c++14 on tests
9
10Upstream-Status: Submitted [https://github.com/iovisor/bcc/pull/4506]
11Signed-off-by: Khem Raj <raj.khem@gmail.com>
12Cc: Hengqi Chen <chenhengqi@outlook.com>
13---
14 tests/cc/CMakeLists.txt | 4 ++++
15 1 file changed, 4 insertions(+)
16
17--- a/tests/cc/CMakeLists.txt
18+++ b/tests/cc/CMakeLists.txt
19@@ -27,6 +27,10 @@ if(${LLVM_PACKAGE_VERSION} VERSION_EQUAL
20 set(CMAKE_CXX_STANDARD 14)
21 endif()
22
23+if(${LLVM_PACKAGE_VERSION} VERSION_EQUAL 16 OR ${LLVM_PACKAGE_VERSION} VERSION_GREATER 16)
24+set(CMAKE_CXX_STANDARD 14)
25+endif()
26+
27 if(ENABLE_USDT)
28 set(TEST_LIBBCC_SOURCES
29 test_libbcc.cc
diff --git a/dynamic-layers/meta-python/recipes-devtools/bcc/bcc_0.30.0.bb b/dynamic-layers/meta-python/recipes-devtools/bcc/bcc_0.33.0.bb
index 4c461bb..7e5c870 100644
--- a/dynamic-layers/meta-python/recipes-devtools/bcc/bcc_0.30.0.bb
+++ b/dynamic-layers/meta-python/recipes-devtools/bcc/bcc_0.33.0.bb
@@ -16,18 +16,17 @@ DEPENDS += "bison-native \
16 " 16 "
17 17
18RDEPENDS:${PN} += "bash python3 python3-core python3-setuptools xz" 18RDEPENDS:${PN} += "bash python3 python3-core python3-setuptools xz"
19RDEPENDS:${PN}-ptest = "cmake python3 python3-netaddr python3-pyroute2" 19RDEPENDS:${PN}-ptest = "kernel-devsrc packagegroup-core-buildessential cmake python3 python3-netaddr python3-pyroute2"
20 20
21SRC_URI = "gitsm://github.com/iovisor/bcc;branch=master;protocol=https \ 21SRC_URI = "gitsm://github.com/iovisor/bcc;branch=master;protocol=https \
22 file://0001-CMakeLists.txt-override-the-PY_CMD_ESCAPED.patch \ 22 file://0001-CMakeLists.txt-override-the-PY_CMD_ESCAPED.patch \
23 file://0001-Vendor-just-enough-extra-headers-to-allow-libbpf-to-.patch \ 23 file://0001-Vendor-just-enough-extra-headers-to-allow-libbpf-to-.patch \
24 file://0001-tests-cc-Use-c-14-standard.patch \
25 file://0001-CMakeLists.txt-don-t-modify-.gitconfig-on-build-host.patch \ 24 file://0001-CMakeLists.txt-don-t-modify-.gitconfig-on-build-host.patch \
26 file://run-ptest \ 25 file://run-ptest \
27 file://ptest_wrapper.sh \ 26 file://ptest_wrapper.sh \
28 " 27 "
29 28
30SRCREV = "1d8daaa395f066b328a56a36fbd40a0de3a7b3c1" 29SRCREV = "92e32ff8a06616779f3a3191b75da6881d59fd17"
31 30
32PV .= "+git" 31PV .= "+git"
33 32
@@ -40,6 +39,7 @@ PACKAGECONFIG[manpages] = "-DENABLE_MAN=ON,-DENABLE_MAN=OFF,"
40PACKAGECONFIG[examples] = "-DENABLE_EXAMPLES=ON,-DENABLE_EXAMPLES=OFF," 39PACKAGECONFIG[examples] = "-DENABLE_EXAMPLES=ON,-DENABLE_EXAMPLES=OFF,"
41 40
42EXTRA_OECMAKE = " \ 41EXTRA_OECMAKE = " \
42 -DREVISION='${PV}' \
43 -DCMAKE_USE_LIBBPF_PACKAGE=ON \ 43 -DCMAKE_USE_LIBBPF_PACKAGE=ON \
44 -DENABLE_LLVM_SHARED=ON \ 44 -DENABLE_LLVM_SHARED=ON \
45 -DENABLE_CLANG_JIT=ON \ 45 -DENABLE_CLANG_JIT=ON \