diff options
author | Esben Haabendal <esben.haabendal@huawei.com> | 2022-05-25 10:42:15 +0200 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2022-06-02 07:45:34 -0700 |
commit | cd7b2f8c90962bef4e8b272ce6863a57b73f20fc (patch) | |
tree | 20bd6e830ff8abf299fcb2d235ce3f81e8c1d299 | |
parent | 85d956d95401479ca666139e31f662f60c156d5f (diff) | |
download | meta-clang-cd7b2f8c90962bef4e8b272ce6863a57b73f20fc.tar.gz |
compiler-rt: Build clang_rt.profile library when possible
To enable clang_rt.profile library do something like the following in
local.conf or your distro configuration.
PACKAGECONFIG:pn-compiler-rt = "profile"
The clang_rt.profile library is used to collect coverage information. It is a
static library, so does not introduce any additional footprint in
target images.
Signed-off-by: Esben Haabendal <esben.haabendal@huawei.com>
(cherry picked from commit 659d43190d906b6e6081deb48a4bdb038eea0f27)
-rw-r--r-- | recipes-devtools/clang/compiler-rt_git.bb | 2 |
1 files changed, 1 insertions, 1 deletions
diff --git a/recipes-devtools/clang/compiler-rt_git.bb b/recipes-devtools/clang/compiler-rt_git.bb index 77d72dd..9be463a 100644 --- a/recipes-devtools/clang/compiler-rt_git.bb +++ b/recipes-devtools/clang/compiler-rt_git.bb | |||
@@ -47,6 +47,7 @@ BUILD_NM:toolchain-clang = "llvm-nm" | |||
47 | 47 | ||
48 | PACKAGECONFIG ??= "" | 48 | PACKAGECONFIG ??= "" |
49 | PACKAGECONFIG[crt] = "-DCOMPILER_RT_BUILD_CRT:BOOL=ON,-DCOMPILER_RT_BUILD_CRT:BOOL=OFF" | 49 | PACKAGECONFIG[crt] = "-DCOMPILER_RT_BUILD_CRT:BOOL=ON,-DCOMPILER_RT_BUILD_CRT:BOOL=OFF" |
50 | PACKAGECONFIG[profile] ="-DCOMPILER_RT_BUILD_PROFILE=ON,-DCOMPILER_RT_BUILD_PROFILE=OFF" | ||
50 | 51 | ||
51 | HF = "${@ bb.utils.contains('TUNE_CCARGS_MFLOAT', 'hard', 'hf', '', d)}" | 52 | HF = "${@ bb.utils.contains('TUNE_CCARGS_MFLOAT', 'hard', 'hf', '', d)}" |
52 | HF[vardepvalue] = "${HF}" | 53 | HF[vardepvalue] = "${HF}" |
@@ -61,7 +62,6 @@ EXTRA_OECMAKE += "-DCOMPILER_RT_STANDALONE_BUILD=OFF \ | |||
61 | -DCOMPILER_RT_BUILD_SANITIZERS=OFF \ | 62 | -DCOMPILER_RT_BUILD_SANITIZERS=OFF \ |
62 | -DCOMPILER_RT_BUILD_MEMPROF=OFF \ | 63 | -DCOMPILER_RT_BUILD_MEMPROF=OFF \ |
63 | -DCOMPILER_RT_BUILD_LIBFUZZER=OFF \ | 64 | -DCOMPILER_RT_BUILD_LIBFUZZER=OFF \ |
64 | -DCOMPILER_RT_BUILD_PROFILE=OFF \ | ||
65 | -DLLVM_ENABLE_PROJECTS='compiler-rt' \ | 65 | -DLLVM_ENABLE_PROJECTS='compiler-rt' \ |
66 | -DLLVM_LIBDIR_SUFFIX=${LLVM_LIBDIR_SUFFIX} \ | 66 | -DLLVM_LIBDIR_SUFFIX=${LLVM_LIBDIR_SUFFIX} \ |
67 | " | 67 | " |