summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDmitry Baryshkov <dmitry.baryshkov@oss.qualcomm.com>2025-04-03 20:11:47 +0300
committerKhem Raj <raj.khem@gmail.com>2025-04-11 08:18:01 -0700
commite3e592c5dad5384c90c3257b2d659b243f832571 (patch)
tree470d0e83d2c86a92802a2b9feb1d564dd58e9a04
parent18d270b25e6fc86c2125d7acfe356aca1f8ea4c0 (diff)
downloadmeta-clang-e3e592c5dad5384c90c3257b2d659b243f832571.tar.gz
clang: enable targets being used by libclc
Enable NVPTX and SPIRV, targets being used by libclc. Signed-off-by: Dmitry Baryshkov <dmitry.baryshkov@oss.qualcomm.com>
-rw-r--r--recipes-devtools/clang/clang_git.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/recipes-devtools/clang/clang_git.bb b/recipes-devtools/clang/clang_git.bb
index dbc5fc5..e890c8f 100644
--- a/recipes-devtools/clang/clang_git.bb
+++ b/recipes-devtools/clang/clang_git.bb
@@ -126,7 +126,7 @@ LLVM_BUILD_TOOLS;LLVM_USE_HOST_TOOLS;LLVM_CONFIG_PATH;\
126# Gennerally setting LLVM_TARGETS_TO_BUILD = "" in local.conf is ok in most simple situations 126# Gennerally setting LLVM_TARGETS_TO_BUILD = "" in local.conf is ok in most simple situations
127# where only one target architecture is needed along with just one build arch (usually X86) 127# where only one target architecture is needed along with just one build arch (usually X86)
128# 128#
129LLVM_TARGETS_TO_BUILD ?= "AMDGPU;AArch64;ARM;BPF;Mips;PowerPC;RISCV;X86;LoongArch" 129LLVM_TARGETS_TO_BUILD ?= "AMDGPU;AArch64;ARM;BPF;Mips;PowerPC;RISCV;X86;LoongArch;NVPTX;SPIRV"
130 130
131LLVM_EXPERIMENTAL_TARGETS_TO_BUILD ?= "" 131LLVM_EXPERIMENTAL_TARGETS_TO_BUILD ?= ""
132 132