diff options
author | Martin Jansa <martin.jansa@gmail.com> | 2024-09-03 13:43:40 +0200 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2024-09-04 00:18:50 -0700 |
commit | 6523bcaefc3be49d4aae96a84eca20efcc914d3d (patch) | |
tree | 70ad48acd52c4c5f0583b43effb987bd9b74f92a /dynamic-layers/meta-python/recipes-devtools | |
parent | acb53c7858a8a323aad1aa034e3bca028b0e1f4b (diff) | |
download | meta-clang-6523bcaefc3be49d4aae96a84eca20efcc914d3d.tar.gz |
bcc: lower buildpaths from ERROR_QA to WARN_QA when ptest is enabled
WARNING: bcc-0.30.0+git-r0 do_package_qa: QA Issue: File /usr/lib/bcc/ptest/tests/cc/test_libbcc_no_libbpf in package bcc-ptest contains reference to TMPDIR [buildpaths]
This one is difficult to resolve, because the tests use CMAKE_CURRENT_BINARY_DIR directly in .cc e.g.:
https://github.com/iovisor/bcc/commit/7271bfc946a19413761be2e3c60c48bf72c5eea1#diff-233a0bfa490f3d7466c49935b64c86dd93956bbc0461f5af703b344cf6601461
we would probably need to use separate variable for "runtime" path for test assets from the standard CMAKE_CURRENT_BINARY_DIR variable or use relative
path from the test binary
Signed-off-by: Martin Jansa <martin.jansa@gmail.com>
Diffstat (limited to 'dynamic-layers/meta-python/recipes-devtools')
-rw-r--r-- | dynamic-layers/meta-python/recipes-devtools/bcc/bcc_0.30.0.bb | 8 |
1 files changed, 8 insertions, 0 deletions
diff --git a/dynamic-layers/meta-python/recipes-devtools/bcc/bcc_0.30.0.bb b/dynamic-layers/meta-python/recipes-devtools/bcc/bcc_0.30.0.bb index 4509222..4c461bb 100644 --- a/dynamic-layers/meta-python/recipes-devtools/bcc/bcc_0.30.0.bb +++ b/dynamic-layers/meta-python/recipes-devtools/bcc/bcc_0.30.0.bb | |||
@@ -68,3 +68,11 @@ FILES:${PN} += "${PYTHON_SITEPACKAGES_DIR}" | |||
68 | FILES:${PN}-doc += "${datadir}/${PN}/man" | 68 | FILES:${PN}-doc += "${datadir}/${PN}/man" |
69 | 69 | ||
70 | COMPATIBLE_HOST = "(x86_64.*|aarch64.*|powerpc64.*|riscv64.*)-linux" | 70 | COMPATIBLE_HOST = "(x86_64.*|aarch64.*|powerpc64.*|riscv64.*)-linux" |
71 | |||
72 | # WARNING: bcc-0.30.0+git-r0 do_package_qa: QA Issue: File /usr/lib/bcc/ptest/tests/cc/test_libbcc_no_libbpf in package bcc-ptest contains reference to TMPDIR [buildpaths] | ||
73 | # this one is difficult to resolve, because the tests use CMAKE_CURRENT_BINARY_DIR directly in .cc e.g.: | ||
74 | # https://github.com/iovisor/bcc/commit/7271bfc946a19413761be2e3c60c48bf72c5eea1#diff-233a0bfa490f3d7466c49935b64c86dd93956bbc0461f5af703b344cf6601461 | ||
75 | # we would probably need to use separate variable for "runtime" path for test assets from the standard CMAKE_CURRENT_BINARY_DIR variable or use relative | ||
76 | # path from the test binary | ||
77 | WARN_QA:append = "${@bb.utils.contains('PTEST_ENABLED', '1', ' buildpaths', '', d)}" | ||
78 | ERROR_QA:remove = "${@bb.utils.contains('PTEST_ENABLED', '1', 'buildpaths', '', d)}" | ||