diff options
author | Etienne Cordonnier <ecordonnier@snap.com> | 2023-03-03 11:26:18 +0100 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2023-03-07 15:08:02 -0800 |
commit | 33604a56dc35a04c6b4233f2030cebc60e8dcfe9 (patch) | |
tree | e9c96ec6f78d035420069e76a2b41d438a7b135e /dynamic-layers/selinux/android-tools/android-tools/0001-libcrypto.mk-modifications-to-make-it-build-in-yocto.patch | |
parent | 398d4bc3805ca1c5cbb845aacccdb8999aabeab4 (diff) | |
download | meta-clang-33604a56dc35a04c6b4233f2030cebc60e8dcfe9.tar.gz |
android-tools: make it work with devtool
devtool modify android-tools was failing with an error:
- regenerate patches in the git format working with devtool
- add debian patches to yocto instead of applying them manually with do_unpack_and_patch_debian,
to make it work with devtool
Signed-off-by: Etienne Cordonnier <ecordonnier@snap.com>
Diffstat (limited to 'dynamic-layers/selinux/android-tools/android-tools/0001-libcrypto.mk-modifications-to-make-it-build-in-yocto.patch')
-rw-r--r-- | dynamic-layers/selinux/android-tools/android-tools/0001-libcrypto.mk-modifications-to-make-it-build-in-yocto.patch | 41 |
1 files changed, 41 insertions, 0 deletions
diff --git a/dynamic-layers/selinux/android-tools/android-tools/0001-libcrypto.mk-modifications-to-make-it-build-in-yocto.patch b/dynamic-layers/selinux/android-tools/android-tools/0001-libcrypto.mk-modifications-to-make-it-build-in-yocto.patch new file mode 100644 index 0000000..7d6d588 --- /dev/null +++ b/dynamic-layers/selinux/android-tools/android-tools/0001-libcrypto.mk-modifications-to-make-it-build-in-yocto.patch | |||
@@ -0,0 +1,41 @@ | |||
1 | From 30193c177138551a9aa269ae249ed2800811b223 Mon Sep 17 00:00:00 2001 | ||
2 | From: Etienne Cordonnier <ecordonnier@snap.com> | ||
3 | Date: Fri, 3 Mar 2023 13:24:11 +0100 | ||
4 | Subject: [PATCH] libcrypto.mk: modifications to make it build in yocto | ||
5 | environment | ||
6 | |||
7 | Adding an include file that is setting the common flags. | ||
8 | |||
9 | Modified the build rule so that it outputs the binary and include | ||
10 | to the OUT_DIR | ||
11 | |||
12 | Signed-off-by: Nisha Parrakat <Nisha.Parrakat@kpit.com> | ||
13 | --- | ||
14 | debian/libcrypto.mk | 9 ++++++--- | ||
15 | 1 file changed, 6 insertions(+), 3 deletions(-) | ||
16 | |||
17 | diff --git a/debian/libcrypto.mk b/debian/libcrypto.mk | ||
18 | index 4c0268e..8b41056 100644 | ||
19 | --- a/debian/libcrypto.mk | ||
20 | +++ b/debian/libcrypto.mk | ||
21 | @@ -1,3 +1,4 @@ | ||
22 | +include ../../rules_yocto.mk | ||
23 | include sources.mk | ||
24 | |||
25 | NAME = libcrypto | ||
26 | @@ -26,6 +27,8 @@ CPPFLAGS += -Isrc/include -Isrc/crypto | ||
27 | LDFLAGS += -shared -Wl,-soname,$(NAME).so.0 -lpthread | ||
28 | |||
29 | build: $(SOURCES) | ||
30 | - mkdir --parents debian/out | ||
31 | - $(CC) $^ -o debian/out/$(NAME).so.0 $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) | ||
32 | - ln -s $(NAME).so.0 debian/out/$(NAME).so | ||
33 | \ No newline at end of file | ||
34 | + mkdir --parents $(OUT_DIR)/usr/lib/$(DEB_HOST_MULTIARCH)/android/ | ||
35 | + mkdir --parents $(OUT_DIR)/usr/include | ||
36 | + $(CC) $^ -o $(OUT_DIR)/usr/lib/$(DEB_HOST_MULTIARCH)/android/$(NAME).so.0 $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) -DOPENSSL_NO_ASM | ||
37 | + ln -sf $(NAME).so.0 $(OUT_DIR)/usr/lib/$(DEB_HOST_MULTIARCH)/android/$(NAME).so | ||
38 | + cp -r include/openssl $(OUT_DIR)/usr/include | ||
39 | -- | ||
40 | 2.36.1.vfs.0.0 | ||
41 | |||