summaryrefslogtreecommitdiffstats
path: root/dynamic-layers
diff options
context:
space:
mode:
authorSoumya Sambu <soumya.sambu@windriver.com>2025-03-18 10:31:38 +0000
committerKhem Raj <raj.khem@gmail.com>2025-03-26 11:28:46 -0700
commit2b21544ca797b91f1739c965cf620c245766e309 (patch)
tree352feebce676908a3ab6c1f471c499f81f1faf1d /dynamic-layers
parent092eaa77f61f8ab6ceeb0429030d750a2618b1ab (diff)
downloadmeta-clang-kirkstone-clang18.tar.gz
bpftrace: Fix llvm-objcopy issue and backport libbpf patches for kirkstone-clang18kirkstone-clang18
Fix bpftrace do_configure failure for kirkstone-clang18: | CMake Error at tests/data/CMakeLists.txt:6 (find_program): | Could not find LLVM_OBJCOPY using the following names: llvm-objcopy, | llvm-objcopy-18, llvm18-objcopy This error occurs because bpftrace searches for llvm-objcopy-${LLVM_VERSION_MAJOR}, expecting llvm version 18.x, while llvm-native from oe-core provides v13.0.1. Since clang-native provides v18.1.6, switching to it resolves the issue. While fixing this, additional libbpf compatibility issues were identified during bpftrace compilation, requiring backporting of multiple patches to resolve: • Undefined BTF_KIND_ENUM64, replaced with BTF_KIND_ENUM. • Missing kprobe_multi in bpf_link_create_opts. • Undefined BPF_TRACE_KPROBE_MULTI. • Undefined reference to btf_is_enum64 in libbpf.so and other related libbpf errors Signed-off-by: Soumya Sambu <soumya.sambu@windriver.com>
Diffstat (limited to 'dynamic-layers')
-rw-r--r--dynamic-layers/openembedded-layer/recipes-devtools/bpftrace/bpftrace_0.20.1.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-devtools/bpftrace/bpftrace_0.20.1.bb b/dynamic-layers/openembedded-layer/recipes-devtools/bpftrace/bpftrace_0.20.1.bb
index 355f427..1bd9150 100644
--- a/dynamic-layers/openembedded-layer/recipes-devtools/bpftrace/bpftrace_0.20.1.bb
+++ b/dynamic-layers/openembedded-layer/recipes-devtools/bpftrace/bpftrace_0.20.1.bb
@@ -12,7 +12,7 @@ DEPENDS += "bison-native \
12 libcereal \ 12 libcereal \
13 libbpf \ 13 libbpf \
14 " 14 "
15DEPENDS += "${@bb.utils.contains('PTEST_ENABLED', '1', 'pahole-native llvm-native', '', d)}" 15DEPENDS += "${@bb.utils.contains('PTEST_ENABLED', '1', 'pahole-native clang-native', '', d)}"
16 16
17RDEPENDS:${PN} += "bash python3 xz" 17RDEPENDS:${PN} += "bash python3 xz"
18 18