summaryrefslogtreecommitdiffstats
path: root/recipes-devtools/clang/libcxx_git.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2023-10-23 17:20:24 -0700
committerKhem Raj <raj.khem@gmail.com>2023-10-25 10:20:08 -0700
commit41b7f5296d1176160712d79730d3b5ce0c58d1da (patch)
tree1c21380d428f5a7dd175431136159d54435c16e2 /recipes-devtools/clang/libcxx_git.bb
parent4c6512205b11140ed381d9fd1b7e0dcfb587c023 (diff)
downloadmeta-clang-41b7f5296d1176160712d79730d3b5ce0c58d1da.tar.gz
meta-clang: Replace RUNTIME with TC_CXX_RUNTIME
TC_CXX_RUNTIME is now defined in OE-core Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes-devtools/clang/libcxx_git.bb')
-rw-r--r--recipes-devtools/clang/libcxx_git.bb6
1 files changed, 3 insertions, 3 deletions
diff --git a/recipes-devtools/clang/libcxx_git.bb b/recipes-devtools/clang/libcxx_git.bb
index 13136fc..3d5ce54 100644
--- a/recipes-devtools/clang/libcxx_git.bb
+++ b/recipes-devtools/clang/libcxx_git.bb
@@ -10,7 +10,7 @@ require common-source.inc
10 10
11inherit cmake cmake-native python3native 11inherit cmake cmake-native python3native
12 12
13PACKAGECONFIG ??= "compiler-rt exceptions ${@bb.utils.contains("RUNTIME", "llvm", "unwind unwind-shared", "", d)}" 13PACKAGECONFIG ??= "compiler-rt exceptions ${@bb.utils.contains("TC_CXX_RUNTIME", "llvm", "unwind unwind-shared", "", d)}"
14PACKAGECONFIG:append:armv5 = " no-atomics" 14PACKAGECONFIG:append:armv5 = " no-atomics"
15PACKAGECONFIG:remove:class-native = "compiler-rt" 15PACKAGECONFIG:remove:class-native = "compiler-rt"
16PACKAGECONFIG[unwind] = "-DLIBCXXABI_USE_LLVM_UNWINDER=ON -DLIBCXXABI_ENABLE_STATIC_UNWINDER=ON,-DLIBCXXABI_USE_LLVM_UNWINDER=OFF,," 16PACKAGECONFIG[unwind] = "-DLIBCXXABI_USE_LLVM_UNWINDER=ON -DLIBCXXABI_ENABLE_STATIC_UNWINDER=ON,-DLIBCXXABI_USE_LLVM_UNWINDER=OFF,,"
@@ -50,7 +50,7 @@ LIC_FILES_CHKSUM = "file://libcxx/LICENSE.TXT;md5=55d89dd7eec8d3b4204b680e27da39
50" 50"
51 51
52OECMAKE_TARGET_COMPILE = "cxxabi cxx" 52OECMAKE_TARGET_COMPILE = "cxxabi cxx"
53OECMAKE_TARGET_INSTALL = "install-cxx install-cxxabi ${@bb.utils.contains("RUNTIME", "llvm", "install-unwind", "", d)}" 53OECMAKE_TARGET_INSTALL = "install-cxx install-cxxabi ${@bb.utils.contains("TC_CXX_RUNTIME", "llvm", "install-unwind", "", d)}"
54 54
55OECMAKE_SOURCEPATH = "${S}/llvm" 55OECMAKE_SOURCEPATH = "${S}/llvm"
56EXTRA_OECMAKE += "\ 56EXTRA_OECMAKE += "\
@@ -97,7 +97,7 @@ ALLOW_EMPTY:${PN} = "1"
97PROVIDES:append:runtime-llvm = " libunwind" 97PROVIDES:append:runtime-llvm = " libunwind"
98 98
99do_install:append() { 99do_install:append() {
100 if ${@bb.utils.contains("RUNTIME", "llvm", "true", "false", d)} 100 if ${@bb.utils.contains("TC_CXX_RUNTIME", "llvm", "true", "false", d)}
101 then 101 then
102 for f in libunwind.h __libunwind_config.h unwind.h unwind_itanium.h unwind_arm_ehabi.h 102 for f in libunwind.h __libunwind_config.h unwind.h unwind_itanium.h unwind_arm_ehabi.h
103 do 103 do