diff options
author | Khem Raj <raj.khem@gmail.com> | 2023-08-25 11:02:21 -0700 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2023-08-26 17:50:51 -0700 |
commit | 7c3eefb457051f3b5f518b88d2d060ee34bb5b29 (patch) | |
tree | 8812ee78768aaf410611b7e730af02f4816a9bd7 /recipes-devtools/python | |
parent | 1b32c9268a71ae5853f677bf459b3c8e259dfb4f (diff) | |
download | meta-clang-7c3eefb457051f3b5f518b88d2d060ee34bb5b29.tar.gz |
python3: Add clang to rdeps for python3-ptests
cppext test needs full toolchain as it tries to build an extention with
C, using clang ensures that a function
compiler bits are pulled into ptest image when using TOOLCHAIN = "clang"
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes-devtools/python')
-rw-r--r-- | recipes-devtools/python/python3_%.bbappend | 4 |
1 files changed, 4 insertions, 0 deletions
diff --git a/recipes-devtools/python/python3_%.bbappend b/recipes-devtools/python/python3_%.bbappend index a4d8b49..08c783b 100644 --- a/recipes-devtools/python/python3_%.bbappend +++ b/recipes-devtools/python/python3_%.bbappend | |||
@@ -1,5 +1,9 @@ | |||
1 | FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:" | 1 | FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:" |
2 | 2 | ||
3 | # tests need compiler on target and they need the compiler which was | ||
4 | # used to build python | ||
5 | RDEPENDS:${PN}-ptest:append:toolchain-clang = " clang" | ||
6 | |||
3 | do_configure:prepend:class-target:toolchain-clang() { | 7 | do_configure:prepend:class-target:toolchain-clang() { |
4 | # We do not need --print-multiarch with clang since it prints wrong value | 8 | # We do not need --print-multiarch with clang since it prints wrong value |
5 | sed -i -e 's#\[MULTIARCH=$($CC --print-multiarch 2>/dev/null)\]#\[MULTIARCH=""\]#g' ${S}/configure.ac | 9 | sed -i -e 's#\[MULTIARCH=$($CC --print-multiarch 2>/dev/null)\]#\[MULTIARCH=""\]#g' ${S}/configure.ac |