diff options
author | Richard Purdie <richard.purdie@linuxfoundation.org> | 2025-01-21 22:08:49 +0000 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2025-01-21 20:14:14 -0800 |
commit | 0ea2df0462edc0c01e787b6ee6c0e20cd6a42fc7 (patch) | |
tree | 6edbb2b01270bdd7a0a15cee2dc9f11292108d28 /recipes-devtools | |
parent | 92e322d797e7945425103d76289a5fc3a2b43ace (diff) | |
download | meta-clang-0ea2df0462edc0c01e787b6ee6c0e20cd6a42fc7.tar.gz |
recipes: Update to match OE-Core virtual/cross-* changes
Update meta-clang to match OE-Core changes to use recipe specific virtual
providers (without yet switching to the new switching mechanism).
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'recipes-devtools')
-rw-r--r-- | recipes-devtools/clang/clang-cross-canadian_git.bb | 2 | ||||
-rw-r--r-- | recipes-devtools/clang/clang-cross_git.bb | 2 | ||||
-rw-r--r-- | recipes-devtools/clang/clang-crosssdk_git.bb | 2 | ||||
-rw-r--r-- | recipes-devtools/clang/clang_git.bb | 2 | ||||
-rw-r--r-- | recipes-devtools/clang/compiler-rt-sanitizers_git.bb | 2 | ||||
-rw-r--r-- | recipes-devtools/clang/compiler-rt_git.bb | 2 | ||||
-rw-r--r-- | recipes-devtools/clang/libcxx_git.bb | 2 |
7 files changed, 7 insertions, 7 deletions
diff --git a/recipes-devtools/clang/clang-cross-canadian_git.bb b/recipes-devtools/clang/clang-cross-canadian_git.bb index f327a12..81935b2 100644 --- a/recipes-devtools/clang/clang-cross-canadian_git.bb +++ b/recipes-devtools/clang/clang-cross-canadian_git.bb | |||
@@ -12,7 +12,7 @@ require clang.inc | |||
12 | require common-source.inc | 12 | require common-source.inc |
13 | inherit cross-canadian | 13 | inherit cross-canadian |
14 | 14 | ||
15 | DEPENDS += "nativesdk-clang binutils-cross-canadian-${TRANSLATED_TARGET_ARCH} virtual/${HOST_PREFIX}binutils virtual/nativesdk-libc" | 15 | DEPENDS += "nativesdk-clang binutils-cross-canadian-${TRANSLATED_TARGET_ARCH} virtual/nativesdk-cross-binutils virtual/nativesdk-libc" |
16 | # We have to point gcc at a sysroot but we don't need to rebuild if this changes | 16 | # We have to point gcc at a sysroot but we don't need to rebuild if this changes |
17 | # e.g. we switch between different machines with different tunes. | 17 | # e.g. we switch between different machines with different tunes. |
18 | EXTRA_OECONF_PATHS[vardepsexclude] = "TUNE_PKGARCH" | 18 | EXTRA_OECONF_PATHS[vardepsexclude] = "TUNE_PKGARCH" |
diff --git a/recipes-devtools/clang/clang-cross_git.bb b/recipes-devtools/clang/clang-cross_git.bb index a0c215e..59ebb65 100644 --- a/recipes-devtools/clang/clang-cross_git.bb +++ b/recipes-devtools/clang/clang-cross_git.bb | |||
@@ -11,7 +11,7 @@ PN = "clang-cross-${TARGET_ARCH}" | |||
11 | require clang.inc | 11 | require clang.inc |
12 | require common-source.inc | 12 | require common-source.inc |
13 | inherit cross | 13 | inherit cross |
14 | DEPENDS += "clang-native virtual/${TARGET_PREFIX}binutils" | 14 | DEPENDS += "clang-native virtual/cross-binutils" |
15 | 15 | ||
16 | do_install() { | 16 | do_install() { |
17 | install -d ${D}${bindir} | 17 | install -d ${D}${bindir} |
diff --git a/recipes-devtools/clang/clang-crosssdk_git.bb b/recipes-devtools/clang/clang-crosssdk_git.bb index 913c49a..c5e2867 100644 --- a/recipes-devtools/clang/clang-crosssdk_git.bb +++ b/recipes-devtools/clang/clang-crosssdk_git.bb | |||
@@ -11,7 +11,7 @@ PN = "clang-crosssdk-${SDK_SYS}" | |||
11 | require clang.inc | 11 | require clang.inc |
12 | require common-source.inc | 12 | require common-source.inc |
13 | inherit crosssdk | 13 | inherit crosssdk |
14 | DEPENDS += "clang-native nativesdk-clang-glue virtual/${TARGET_PREFIX}binutils virtual/nativesdk-libc" | 14 | DEPENDS += "clang-native nativesdk-clang-glue virtual/nativesdk-cross-binutils virtual/nativesdk-libc" |
15 | 15 | ||
16 | do_install() { | 16 | do_install() { |
17 | install -d ${D}${bindir} | 17 | install -d ${D}${bindir} |
diff --git a/recipes-devtools/clang/clang_git.bb b/recipes-devtools/clang/clang_git.bb index 1ad40f2..5017895 100644 --- a/recipes-devtools/clang/clang_git.bb +++ b/recipes-devtools/clang/clang_git.bb | |||
@@ -206,7 +206,7 @@ EXTRA_OECMAKE:append:class-target = "\ | |||
206 | " | 206 | " |
207 | 207 | ||
208 | DEPENDS = "binutils zlib zstd libffi libxml2 libxml2-native ninja-native swig-native" | 208 | DEPENDS = "binutils zlib zstd libffi libxml2 libxml2-native ninja-native swig-native" |
209 | DEPENDS:append:class-nativesdk = " clang-crosssdk-${SDK_SYS} virtual/${TARGET_PREFIX}binutils nativesdk-python3" | 209 | DEPENDS:append:class-nativesdk = " clang-crosssdk-${SDK_SYS} virtual/nativesdk-cross-binutils nativesdk-python3" |
210 | DEPENDS:append:class-target = " clang-cross-${TARGET_ARCH} python3 compiler-rt libcxx" | 210 | DEPENDS:append:class-target = " clang-cross-${TARGET_ARCH} python3 compiler-rt libcxx" |
211 | 211 | ||
212 | RRECOMMENDS:${PN} = "binutils" | 212 | RRECOMMENDS:${PN} = "binutils" |
diff --git a/recipes-devtools/clang/compiler-rt-sanitizers_git.bb b/recipes-devtools/clang/compiler-rt-sanitizers_git.bb index acd5516..b42c709 100644 --- a/recipes-devtools/clang/compiler-rt-sanitizers_git.bb +++ b/recipes-devtools/clang/compiler-rt-sanitizers_git.bb | |||
@@ -100,7 +100,7 @@ INSANE_SKIP:${PN} = "dev-so libdir" | |||
100 | INSANE_SKIP:${PN}-dbg = "libdir" | 100 | INSANE_SKIP:${PN}-dbg = "libdir" |
101 | 101 | ||
102 | #PROVIDES:append:class-target = "\ | 102 | #PROVIDES:append:class-target = "\ |
103 | # virtual/${TARGET_PREFIX}compilerlibs \ | 103 | # virtual/${MLPREFIX}compilerlibs \ |
104 | # libgcc \ | 104 | # libgcc \ |
105 | # libgcc-initial \ | 105 | # libgcc-initial \ |
106 | # libgcc-dev \ | 106 | # libgcc-dev \ |
diff --git a/recipes-devtools/clang/compiler-rt_git.bb b/recipes-devtools/clang/compiler-rt_git.bb index 080e53b..7bc81af 100644 --- a/recipes-devtools/clang/compiler-rt_git.bb +++ b/recipes-devtools/clang/compiler-rt_git.bb | |||
@@ -108,7 +108,7 @@ INSANE_SKIP:${PN} = "dev-so libdir" | |||
108 | INSANE_SKIP:${PN}-dbg = "libdir" | 108 | INSANE_SKIP:${PN}-dbg = "libdir" |
109 | 109 | ||
110 | #PROVIDES:append:class-target = "\ | 110 | #PROVIDES:append:class-target = "\ |
111 | # virtual/${TARGET_PREFIX}compilerlibs \ | 111 | # virtual/${MLPREFIX}compilerlibs \ |
112 | # libgcc \ | 112 | # libgcc \ |
113 | # libgcc-initial \ | 113 | # libgcc-initial \ |
114 | # libgcc-dev \ | 114 | # libgcc-dev \ |
diff --git a/recipes-devtools/clang/libcxx_git.bb b/recipes-devtools/clang/libcxx_git.bb index c7f3a77..816d037 100644 --- a/recipes-devtools/clang/libcxx_git.bb +++ b/recipes-devtools/clang/libcxx_git.bb | |||
@@ -20,7 +20,7 @@ PACKAGECONFIG[compiler-rt] = "-DLIBCXX_USE_COMPILER_RT=ON -DLIBCXXABI_USE_COMPIL | |||
20 | PACKAGECONFIG[unwind-shared] = "-DLIBUNWIND_ENABLE_SHARED=ON,-DLIBUNWIND_ENABLE_SHARED=OFF,," | 20 | PACKAGECONFIG[unwind-shared] = "-DLIBUNWIND_ENABLE_SHARED=ON,-DLIBUNWIND_ENABLE_SHARED=OFF,," |
21 | 21 | ||
22 | DEPENDS += "ninja-native" | 22 | DEPENDS += "ninja-native" |
23 | DEPENDS:append:class-target = " clang-cross-${TARGET_ARCH} virtual/${MLPREFIX}libc virtual/${TARGET_PREFIX}compilerlibs" | 23 | DEPENDS:append:class-target = " clang-cross-${TARGET_ARCH} virtual/${MLPREFIX}libc virtual/${MLPREFIX}compilerlibs" |
24 | DEPENDS:append:class-nativesdk = " clang-crosssdk-${SDK_SYS} nativesdk-compiler-rt" | 24 | DEPENDS:append:class-nativesdk = " clang-crosssdk-${SDK_SYS} nativesdk-compiler-rt" |
25 | DEPENDS:append:class-native = " clang-native compiler-rt-native" | 25 | DEPENDS:append:class-native = " clang-native compiler-rt-native" |
26 | 26 | ||