diff options
author | MastaG <mastag@gmail.com> | 2019-03-14 11:12:37 +0100 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2019-03-15 08:57:55 -0700 |
commit | 80bde5b1af11ae40b4931f5960effff6f6ab44ba (patch) | |
tree | a1ce0f0a77401df6b90a4817ea42c02170816f52 /recipes-graphics/wayland/files/fix_duplicate_main.patch | |
parent | 2705ac1c920a2cc45701035c1a30c152cd26817f (diff) | |
download | meta-clang-80bde5b1af11ae40b4931f5960effff6f6ab44ba.tar.gz |
Fix duplicates symbols when building with lld
Samba: https://svnweb.freebsd.org/ports/branches/2018Q4/net/samba47/files/patch-source3__wscript_build?view=markup&pathrev=481551
Wayland: https://gitlab.freedesktop.org/wayland/wayland/commit/c70fd8a812d74b5ef6fcba1287b409f4f8821e91
Diffstat (limited to 'recipes-graphics/wayland/files/fix_duplicate_main.patch')
-rw-r--r-- | recipes-graphics/wayland/files/fix_duplicate_main.patch | 54 |
1 files changed, 54 insertions, 0 deletions
diff --git a/recipes-graphics/wayland/files/fix_duplicate_main.patch b/recipes-graphics/wayland/files/fix_duplicate_main.patch new file mode 100644 index 0000000..9b9ec99 --- /dev/null +++ b/recipes-graphics/wayland/files/fix_duplicate_main.patch | |||
@@ -0,0 +1,54 @@ | |||
1 | --- wayland-1.16.0/Makefile.am 2019-03-14 10:29:31.103099516 +0100 | ||
2 | +++ wayland-1.16.0/Makefile.am 2019-03-14 10:33:07.987977505 +0100 | ||
3 | @@ -210,12 +210,15 @@ | ||
4 | exec-fd-leak-checker \ | ||
5 | fixed-benchmark | ||
6 | |||
7 | -noinst_LTLIBRARIES += libtest-runner.la | ||
8 | +noinst_LTLIBRARIES += \ | ||
9 | + libtest-runner.la \ | ||
10 | + libtest-helpers.la | ||
11 | + | ||
12 | +libtest_helpers_la_SOURCES = tests/test-helpers.c | ||
13 | |||
14 | libtest_runner_la_SOURCES = \ | ||
15 | tests/test-runner.c \ | ||
16 | tests/test-runner.h \ | ||
17 | - tests/test-helpers.c \ | ||
18 | tests/test-compositor.h \ | ||
19 | tests/test-compositor.c | ||
20 | libtest_runner_la_LIBADD = \ | ||
21 | @@ -223,9 +226,9 @@ | ||
22 | libwayland-util.la \ | ||
23 | libwayland-client.la \ | ||
24 | libwayland-server.la \ | ||
25 | + libtest-helpers.la \ | ||
26 | -lrt -ldl $(FFI_LIBS) | ||
27 | |||
28 | - | ||
29 | array_test_SOURCES = tests/array-test.c | ||
30 | array_test_LDADD = libtest-runner.la | ||
31 | client_test_SOURCES = tests/client-test.c | ||
32 | @@ -270,7 +273,6 @@ | ||
33 | headers_test_SOURCES = tests/headers-test.c \ | ||
34 | tests/headers-protocol-test.c \ | ||
35 | tests/headers-protocol-core-test.c | ||
36 | -headers_test_LDADD = libtest-runner.la | ||
37 | nodist_headers_test_SOURCES = \ | ||
38 | protocol/wayland-server-protocol-core.h \ | ||
39 | protocol/wayland-client-protocol-core.h | ||
40 | @@ -280,13 +282,12 @@ | ||
41 | endif | ||
42 | |||
43 | fixed_benchmark_SOURCES = tests/fixed-benchmark.c | ||
44 | -fixed_benchmark_LDADD = libtest-runner.la | ||
45 | |||
46 | os_wrappers_test_SOURCES = tests/os-wrappers-test.c | ||
47 | os_wrappers_test_LDADD = libtest-runner.la | ||
48 | |||
49 | exec_fd_leak_checker_SOURCES = tests/exec-fd-leak-checker.c | ||
50 | -exec_fd_leak_checker_LDADD = libtest-runner.la | ||
51 | +exec_fd_leak_checker_LDADD = libtest-helpers.la | ||
52 | |||
53 | EXTRA_DIST += tests/scanner-test.sh \ | ||
54 | protocol/tests.xml \ | ||