diff options
2 files changed, 55 insertions, 0 deletions
diff --git a/dynamic-layers/meta-python/recipes-devtools/bpftrace/bpftrace/0001-Fix-build-failures-due-to-missing-location.hh.patch b/dynamic-layers/meta-python/recipes-devtools/bpftrace/bpftrace/0001-Fix-build-failures-due-to-missing-location.hh.patch new file mode 100644 index 0000000..1c2ae33 --- /dev/null +++ b/dynamic-layers/meta-python/recipes-devtools/bpftrace/bpftrace/0001-Fix-build-failures-due-to-missing-location.hh.patch | |||
@@ -0,0 +1,54 @@ | |||
1 | From 24421ba92c69f1abaadaff01270621917616a2b8 Mon Sep 17 00:00:00 2001 | ||
2 | From: Changqing Li <changqing.li@windriver.com> | ||
3 | Date: Thu, 17 Apr 2025 10:38:50 +0800 | ||
4 | Subject: [PATCH] Fix build failures due to missing location.hh | ||
5 | |||
6 | ast/location.h does `#include "location.hh"` and location.hh is | ||
7 | generated by the parser so any CMake target whose source includes | ||
8 | ast/location.h needs to have a dependency on the `parser` target, | ||
9 | otherwise the compilation may fail due to incorrect ordering of build | ||
10 | targets. This also applies to targets which include ast/location.h | ||
11 | transitively via other headers. | ||
12 | |||
13 | To avoid such errors, do 2 things: | ||
14 | - drop includes of ast/location.h where unused | ||
15 | - for CMake targets including ast/location.h, add an explicit dependency | ||
16 | on the `parser` target | ||
17 | |||
18 | Signed-off-by: Viktor Malik <viktor.malik@gmail.com> | ||
19 | |||
20 | Upstream-Status: Backport [https://github.com/bpftrace/bpftrace/commit/743cb9c88c25fb9737d714f4d4ac853f05bb6481] | ||
21 | |||
22 | Signed-off-by: Changqing Li <changqing.li@windriver.com> | ||
23 | --- | ||
24 | src/CMakeLists.txt | 1 + | ||
25 | src/ast/CMakeLists.txt | 1 + | ||
26 | 2 files changed, 2 insertions(+) | ||
27 | |||
28 | diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt | ||
29 | index e04ee429..13a51040 100644 | ||
30 | --- a/src/CMakeLists.txt | ||
31 | +++ b/src/CMakeLists.txt | ||
32 | @@ -21,6 +21,7 @@ add_library(compiler_core STATIC | ||
33 | struct.cpp | ||
34 | types.cpp | ||
35 | ) | ||
36 | +add_dependencies(compiler_core parser) | ||
37 | |||
38 | add_library(runtime STATIC | ||
39 | attached_probe.cpp | ||
40 | diff --git a/src/ast/CMakeLists.txt b/src/ast/CMakeLists.txt | ||
41 | index 92231f85..7230cf71 100644 | ||
42 | --- a/src/ast/CMakeLists.txt | ||
43 | +++ b/src/ast/CMakeLists.txt | ||
44 | @@ -22,6 +22,7 @@ add_library(ast STATIC | ||
45 | passes/return_path_analyser.cpp | ||
46 | ) | ||
47 | |||
48 | +add_dependencies(ast parser) | ||
49 | target_compile_definitions(ast PRIVATE ${BPFTRACE_FLAGS}) | ||
50 | target_link_libraries(ast PUBLIC ast_defs arch compiler_core parser) | ||
51 | |||
52 | -- | ||
53 | 2.34.1 | ||
54 | |||
diff --git a/dynamic-layers/meta-python/recipes-devtools/bpftrace/bpftrace_0.23.0.bb b/dynamic-layers/meta-python/recipes-devtools/bpftrace/bpftrace_0.23.0.bb index e52e5c9..5fde87e 100644 --- a/dynamic-layers/meta-python/recipes-devtools/bpftrace/bpftrace_0.23.0.bb +++ b/dynamic-layers/meta-python/recipes-devtools/bpftrace/bpftrace_0.23.0.bb | |||
@@ -21,6 +21,7 @@ PV .= "+git" | |||
21 | SRC_URI = "git://github.com/iovisor/bpftrace;branch=release/0.23.x;protocol=https \ | 21 | SRC_URI = "git://github.com/iovisor/bpftrace;branch=release/0.23.x;protocol=https \ |
22 | file://run-ptest \ | 22 | file://run-ptest \ |
23 | file://0002-CMakeLists.txt-allow-to-set-BISON_FLAGS-like-l.patch \ | 23 | file://0002-CMakeLists.txt-allow-to-set-BISON_FLAGS-like-l.patch \ |
24 | file://0001-Fix-build-failures-due-to-missing-location.hh.patch \ | ||
24 | " | 25 | " |
25 | SRCREV = "01e806d24c61f996f1809e1e991646311499db4f" | 26 | SRCREV = "01e806d24c61f996f1809e1e991646311499db4f" |
26 | 27 | ||