summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--dynamic-layers/meta-python/recipes-devtools/bcc/bcc_0.33.0.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/dynamic-layers/meta-python/recipes-devtools/bcc/bcc_0.33.0.bb b/dynamic-layers/meta-python/recipes-devtools/bcc/bcc_0.33.0.bb
index 3285020..69fa9f2 100644
--- a/dynamic-layers/meta-python/recipes-devtools/bcc/bcc_0.33.0.bb
+++ b/dynamic-layers/meta-python/recipes-devtools/bcc/bcc_0.33.0.bb
@@ -67,6 +67,7 @@ do_install_ptest() {
67 # Hence, these files are copied to the image to fix these tests. 67 # Hence, these files are copied to the image to fix these tests.
68 install -d ${D}${B}/tests/cc 68 install -d ${D}${B}/tests/cc
69 install ${B}/tests/cc/archive.zip ${B}/tests/cc/libdebuginfo_test_lib.so ${B}/tests/cc/with_gnu_debuglink.so ${B}/tests/cc/with_gnu_debugdata.so ${B}/tests/cc/debuginfo.so ${D}${B}/tests/cc 69 install ${B}/tests/cc/archive.zip ${B}/tests/cc/libdebuginfo_test_lib.so ${B}/tests/cc/with_gnu_debuglink.so ${B}/tests/cc/with_gnu_debugdata.so ${B}/tests/cc/debuginfo.so ${D}${B}/tests/cc
70 install -d ${D}/opt
70 install ${B}/tests/cc/test_libbcc_no_libbpf ${B}/tests/cc/libusdt_test_lib.so ${D}${PTEST_PATH}/tests/cc 71 install ${B}/tests/cc/test_libbcc_no_libbpf ${B}/tests/cc/libusdt_test_lib.so ${D}${PTEST_PATH}/tests/cc
71 cp -rf ${S}/tests/python ${D}${PTEST_PATH}/tests/python 72 cp -rf ${S}/tests/python ${D}${PTEST_PATH}/tests/python
72 install ${UNPACKDIR}/ptest_wrapper.sh ${D}${PTEST_PATH}/tests 73 install ${UNPACKDIR}/ptest_wrapper.sh ${D}${PTEST_PATH}/tests
@@ -75,6 +76,7 @@ do_install_ptest() {
75 76
76FILES:${PN} += "${PYTHON_SITEPACKAGES_DIR}" 77FILES:${PN} += "${PYTHON_SITEPACKAGES_DIR}"
77FILES:${PN} += "${B}/tests/cc" 78FILES:${PN} += "${B}/tests/cc"
79FILES:${PN}-ptest += "/opt/"
78FILES:${PN}-doc += "${datadir}/${PN}/man" 80FILES:${PN}-doc += "${datadir}/${PN}/man"
79 81
80COMPATIBLE_HOST = "(x86_64.*|aarch64.*|powerpc64.*|riscv64.*)-linux" 82COMPATIBLE_HOST = "(x86_64.*|aarch64.*|powerpc64.*|riscv64.*)-linux"