diff options
author | Harish Sadineni <HarishSadineni@windriver.com> | 2025-04-24 15:23:22 +0530 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2025-05-06 06:14:52 -0700 |
commit | 1121044151f3ff1c18696e3466a171af684c2369 (patch) | |
tree | 147c0acf8a3e62f395f8225350af41b6d293b5e0 | |
parent | 47a03c576465a89d927c50ebd24b9ad455006325 (diff) | |
download | meta-clang-1121044151f3ff1c18696e3466a171af684c2369.tar.gz |
bcc: install opt dir to image to fix py_test_trace3_c
This patch Fixes the following error:
ERROR: test_blk1 (__main__.TestBlkRequest.test_blk1)
----------------------------------------------------------------------
Traceback (most recent call last):
File "/usr/lib/bcc/ptest/tests/python/./test_trace3.py", line 38, in test_blk1
os.unlink("/opt/trace3.txt")
~~~~~~~~~^^^^^^^^^^^^^^^^^^^
FileNotFoundError: [Errno 2] No such file or directory: '/opt/trace3.txt'
Signed-off-by: Harish Sadineni <HarishSadineni@windriver.com>
-rw-r--r-- | dynamic-layers/meta-python/recipes-devtools/bcc/bcc_0.33.0.bb | 2 |
1 files changed, 2 insertions, 0 deletions
diff --git a/dynamic-layers/meta-python/recipes-devtools/bcc/bcc_0.33.0.bb b/dynamic-layers/meta-python/recipes-devtools/bcc/bcc_0.33.0.bb index 3285020..69fa9f2 100644 --- a/dynamic-layers/meta-python/recipes-devtools/bcc/bcc_0.33.0.bb +++ b/dynamic-layers/meta-python/recipes-devtools/bcc/bcc_0.33.0.bb | |||
@@ -67,6 +67,7 @@ do_install_ptest() { | |||
67 | # Hence, these files are copied to the image to fix these tests. | 67 | # Hence, these files are copied to the image to fix these tests. |
68 | install -d ${D}${B}/tests/cc | 68 | install -d ${D}${B}/tests/cc |
69 | install ${B}/tests/cc/archive.zip ${B}/tests/cc/libdebuginfo_test_lib.so ${B}/tests/cc/with_gnu_debuglink.so ${B}/tests/cc/with_gnu_debugdata.so ${B}/tests/cc/debuginfo.so ${D}${B}/tests/cc | 69 | install ${B}/tests/cc/archive.zip ${B}/tests/cc/libdebuginfo_test_lib.so ${B}/tests/cc/with_gnu_debuglink.so ${B}/tests/cc/with_gnu_debugdata.so ${B}/tests/cc/debuginfo.so ${D}${B}/tests/cc |
70 | install -d ${D}/opt | ||
70 | install ${B}/tests/cc/test_libbcc_no_libbpf ${B}/tests/cc/libusdt_test_lib.so ${D}${PTEST_PATH}/tests/cc | 71 | install ${B}/tests/cc/test_libbcc_no_libbpf ${B}/tests/cc/libusdt_test_lib.so ${D}${PTEST_PATH}/tests/cc |
71 | cp -rf ${S}/tests/python ${D}${PTEST_PATH}/tests/python | 72 | cp -rf ${S}/tests/python ${D}${PTEST_PATH}/tests/python |
72 | install ${UNPACKDIR}/ptest_wrapper.sh ${D}${PTEST_PATH}/tests | 73 | install ${UNPACKDIR}/ptest_wrapper.sh ${D}${PTEST_PATH}/tests |
@@ -75,6 +76,7 @@ do_install_ptest() { | |||
75 | 76 | ||
76 | FILES:${PN} += "${PYTHON_SITEPACKAGES_DIR}" | 77 | FILES:${PN} += "${PYTHON_SITEPACKAGES_DIR}" |
77 | FILES:${PN} += "${B}/tests/cc" | 78 | FILES:${PN} += "${B}/tests/cc" |
79 | FILES:${PN}-ptest += "/opt/" | ||
78 | FILES:${PN}-doc += "${datadir}/${PN}/man" | 80 | FILES:${PN}-doc += "${datadir}/${PN}/man" |
79 | 81 | ||
80 | COMPATIBLE_HOST = "(x86_64.*|aarch64.*|powerpc64.*|riscv64.*)-linux" | 82 | COMPATIBLE_HOST = "(x86_64.*|aarch64.*|powerpc64.*|riscv64.*)-linux" |