diff options
author | Harish Sadineni <HarishSadineni@windriver.com> | 2025-04-24 15:21:51 +0530 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2025-05-06 06:14:52 -0700 |
commit | 47a03c576465a89d927c50ebd24b9ad455006325 (patch) | |
tree | fe0247a0601d4a4cc37153991d13aedf237cec66 | |
parent | 8608f14a5727ffa67dcc57677a8cbfc9a60be3a8 (diff) | |
download | meta-clang-47a03c576465a89d927c50ebd24b9ad455006325.tar.gz |
bcc: Fix for test bpf stack_id table
The test for bpf_stack_id was failing due to the system being unable to locate libc.so.6.
Upon investigation using strace, the following error was observed:
newfstatat(AT_FDCWD, "/lib/x86_64-linux-gnu/libc.so.6", 0x7ffdcd475420, 0) = -1 ENOENT (No such file or directory)
newfstatat(AT_FDCWD, "/lib64/libc.so.6", 0x7ffdcd475420, 0) = -1 ENOENT (No such file or directory)
This issue occurs because libc.so.6 was not found in the expected locations.
To resolve this, the location of libc.so.6 in image has been added . It is now accessible at: /lib/libc.so.6
Upstream-Status: Submitted [https://github.com/iovisor/bcc/pull/5292]
Signed-off-by: Harish Sadineni <HarishSadineni@windriver.com>
-rw-r--r-- | dynamic-layers/meta-python/recipes-devtools/bcc/bcc/bpf_stack_id.patch | 13 | ||||
-rw-r--r-- | dynamic-layers/meta-python/recipes-devtools/bcc/bcc_0.33.0.bb | 1 |
2 files changed, 14 insertions, 0 deletions
diff --git a/dynamic-layers/meta-python/recipes-devtools/bcc/bcc/bpf_stack_id.patch b/dynamic-layers/meta-python/recipes-devtools/bcc/bcc/bpf_stack_id.patch new file mode 100644 index 0000000..18221be --- /dev/null +++ b/dynamic-layers/meta-python/recipes-devtools/bcc/bcc/bpf_stack_id.patch | |||
@@ -0,0 +1,13 @@ | |||
1 | Upstream-Status: Submitted [https://github.com/iovisor/bcc/pull/5292] | ||
2 | Signed-off-by: Harish Sadineni <Harish.Sadineni@windriver.com> | ||
3 | |||
4 | --- a/tests/cc/test_bpf_table.cc | ||
5 | +++ b/tests/cc/test_bpf_table.cc | ||
6 | @@ -260,6 +260,7 @@ | ||
7 | /* libc locations on different distributions are added below*/ | ||
8 | bpf.add_module("/lib/x86_64-linux-gnu/libc.so.6"); //Location of libc in ubuntu | ||
9 | bpf.add_module("/lib64/libc.so.6"); //Location of libc fedora machine | ||
10 | + bpf.add_module("/lib/libc.so.6");//location of libc in image | ||
11 | |||
12 | int stack_id = id[0]; | ||
13 | REQUIRE(stack_id >= 0); | ||
diff --git a/dynamic-layers/meta-python/recipes-devtools/bcc/bcc_0.33.0.bb b/dynamic-layers/meta-python/recipes-devtools/bcc/bcc_0.33.0.bb index 2839d69..3285020 100644 --- a/dynamic-layers/meta-python/recipes-devtools/bcc/bcc_0.33.0.bb +++ b/dynamic-layers/meta-python/recipes-devtools/bcc/bcc_0.33.0.bb | |||
@@ -24,6 +24,7 @@ SRC_URI = "gitsm://github.com/iovisor/bcc;branch=master;protocol=https \ | |||
24 | file://0001-CMakeLists.txt-don-t-modify-.gitconfig-on-build-host.patch \ | 24 | file://0001-CMakeLists.txt-don-t-modify-.gitconfig-on-build-host.patch \ |
25 | file://run-ptest \ | 25 | file://run-ptest \ |
26 | file://ptest_wrapper.sh \ | 26 | file://ptest_wrapper.sh \ |
27 | file://bpf_stack_id.patch \ | ||
27 | " | 28 | " |
28 | 29 | ||
29 | SRCREV = "92e32ff8a06616779f3a3191b75da6881d59fd17" | 30 | SRCREV = "92e32ff8a06616779f3a3191b75da6881d59fd17" |