diff options
author | Harish Sadineni <HarishSadineni@windriver.com> | 2025-04-24 15:17:41 +0530 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2025-05-06 06:14:52 -0700 |
commit | 8608f14a5727ffa67dcc57677a8cbfc9a60be3a8 (patch) | |
tree | 3e28b50c9685c6bf4d86c854617fdc48b0533d05 | |
parent | 000581d0ecd3aa3c956640a0e28d845999430f07 (diff) | |
download | meta-clang-8608f14a5727ffa67dcc57677a8cbfc9a60be3a8.tar.gz |
bcc: copy shared libs & archive files to image
Avoid stripping debuginfo.so to fix some tests.
ptest searches for shared libs and archive files in the build folder.
Hence, these files are copied to the image to fix some tests.
Signed-off-by: Harish Sadineni <HarishSadineni@windriver.com>
-rw-r--r-- | dynamic-layers/meta-python/recipes-devtools/bcc/bcc_0.33.0.bb | 9 |
1 files changed, 9 insertions, 0 deletions
diff --git a/dynamic-layers/meta-python/recipes-devtools/bcc/bcc_0.33.0.bb b/dynamic-layers/meta-python/recipes-devtools/bcc/bcc_0.33.0.bb index 7e5c870..2839d69 100644 --- a/dynamic-layers/meta-python/recipes-devtools/bcc/bcc_0.33.0.bb +++ b/dynamic-layers/meta-python/recipes-devtools/bcc/bcc_0.33.0.bb | |||
@@ -48,6 +48,10 @@ EXTRA_OECMAKE = " \ | |||
48 | -DPYTHON_FLAGS=--install-lib=${PYTHON_SITEPACKAGES_DIR} \ | 48 | -DPYTHON_FLAGS=--install-lib=${PYTHON_SITEPACKAGES_DIR} \ |
49 | " | 49 | " |
50 | 50 | ||
51 | # Avoid stripping debuginfo.so to fix some tests. | ||
52 | INHIBIT_PACKAGE_STRIP = "1" | ||
53 | INHIBIT_PACKAGE_DEBUG_SPLIT = "1" | ||
54 | |||
51 | do_install:append() { | 55 | do_install:append() { |
52 | sed -e 's@#!/usr/bin/env python@#!/usr/bin/env python3@g' \ | 56 | sed -e 's@#!/usr/bin/env python@#!/usr/bin/env python3@g' \ |
53 | -i $(find ${D}${datadir}/${PN} -type f) | 57 | -i $(find ${D}${datadir}/${PN} -type f) |
@@ -58,6 +62,10 @@ do_install:append() { | |||
58 | 62 | ||
59 | do_install_ptest() { | 63 | do_install_ptest() { |
60 | install -d ${D}${PTEST_PATH}/tests/cc | 64 | install -d ${D}${PTEST_PATH}/tests/cc |
65 | # ptest searches for shared libs and archive files in the build folder. | ||
66 | # Hence, these files are copied to the image to fix these tests. | ||
67 | install -d ${D}${B}/tests/cc | ||
68 | install ${B}/tests/cc/archive.zip ${B}/tests/cc/libdebuginfo_test_lib.so ${B}/tests/cc/with_gnu_debuglink.so ${B}/tests/cc/with_gnu_debugdata.so ${B}/tests/cc/debuginfo.so ${D}${B}/tests/cc | ||
61 | install ${B}/tests/cc/test_libbcc_no_libbpf ${B}/tests/cc/libusdt_test_lib.so ${D}${PTEST_PATH}/tests/cc | 69 | install ${B}/tests/cc/test_libbcc_no_libbpf ${B}/tests/cc/libusdt_test_lib.so ${D}${PTEST_PATH}/tests/cc |
62 | cp -rf ${S}/tests/python ${D}${PTEST_PATH}/tests/python | 70 | cp -rf ${S}/tests/python ${D}${PTEST_PATH}/tests/python |
63 | install ${UNPACKDIR}/ptest_wrapper.sh ${D}${PTEST_PATH}/tests | 71 | install ${UNPACKDIR}/ptest_wrapper.sh ${D}${PTEST_PATH}/tests |
@@ -65,6 +73,7 @@ do_install_ptest() { | |||
65 | } | 73 | } |
66 | 74 | ||
67 | FILES:${PN} += "${PYTHON_SITEPACKAGES_DIR}" | 75 | FILES:${PN} += "${PYTHON_SITEPACKAGES_DIR}" |
76 | FILES:${PN} += "${B}/tests/cc" | ||
68 | FILES:${PN}-doc += "${datadir}/${PN}/man" | 77 | FILES:${PN}-doc += "${datadir}/${PN}/man" |
69 | 78 | ||
70 | COMPATIBLE_HOST = "(x86_64.*|aarch64.*|powerpc64.*|riscv64.*)-linux" | 79 | COMPATIBLE_HOST = "(x86_64.*|aarch64.*|powerpc64.*|riscv64.*)-linux" |