diff options
-rw-r--r-- | classes/clang.bbclass | 3 | ||||
-rw-r--r-- | recipes-devtools/clang/libcxx_git.bb | 2 |
2 files changed, 3 insertions, 2 deletions
diff --git a/classes/clang.bbclass b/classes/clang.bbclass index cfd92d9..7c36da9 100644 --- a/classes/clang.bbclass +++ b/classes/clang.bbclass | |||
@@ -13,6 +13,7 @@ COMPILER_RT ??= "--rtlib=compiler-rt ${UNWINDLIB}" | |||
13 | UNWINDLIB ??= "--unwindlib=libunwind" | 13 | UNWINDLIB ??= "--unwindlib=libunwind" |
14 | UNWINDLIB_riscv64 = "--unwindlib=libgcc" | 14 | UNWINDLIB_riscv64 = "--unwindlib=libgcc" |
15 | UNWINDLIB_riscv32 = "--unwindlib=libgcc" | 15 | UNWINDLIB_riscv32 = "--unwindlib=libgcc" |
16 | UNWINDLIB_powerpc = "--unwindlib=libgcc" | ||
16 | 17 | ||
17 | LIBCPLUSPLUS ??= "--stdlib=libc++" | 18 | LIBCPLUSPLUS ??= "--stdlib=libc++" |
18 | 19 | ||
@@ -69,6 +70,6 @@ BASEDEPENDS_append_toolchain-clang_class-target = "${@clang_dep_prepend(d)}" | |||
69 | 70 | ||
70 | PREFERRED_PROVIDER_libunwind_toolchain-clang = "libcxx" | 71 | PREFERRED_PROVIDER_libunwind_toolchain-clang = "libcxx" |
71 | PREFERRED_PROVIDER_libunwind ?= "libunwind" | 72 | PREFERRED_PROVIDER_libunwind ?= "libunwind" |
72 | PREFERRED_PROVIDER_libunwind_mipsarch = "libunwind" | 73 | PREFERRED_PROVIDER_libunwind_powerpc = "libunwind" |
73 | PREFERRED_PROVIDER_libunwind_riscv32 = "libunwind" | 74 | PREFERRED_PROVIDER_libunwind_riscv32 = "libunwind" |
74 | PREFERRED_PROVIDER_libunwind_riscv64 = "libunwind" | 75 | PREFERRED_PROVIDER_libunwind_riscv64 = "libunwind" |
diff --git a/recipes-devtools/clang/libcxx_git.bb b/recipes-devtools/clang/libcxx_git.bb index 4882513..5e8deb9 100644 --- a/recipes-devtools/clang/libcxx_git.bb +++ b/recipes-devtools/clang/libcxx_git.bb | |||
@@ -17,6 +17,7 @@ TARGET_CXXFLAGS_remove_toolchain-clang = "--stdlib=libc++" | |||
17 | TUNE_CCARGS_remove_toolchain-clang = "--rtlib=compiler-rt --unwindlib=libunwind --stdlib=libc++" | 17 | TUNE_CCARGS_remove_toolchain-clang = "--rtlib=compiler-rt --unwindlib=libunwind --stdlib=libc++" |
18 | 18 | ||
19 | PACKAGECONFIG ??= "unwind" | 19 | PACKAGECONFIG ??= "unwind" |
20 | PACKAGECONFIG_toolchain-gcc = "" | ||
20 | PACKAGECONFIG_powerpc = "" | 21 | PACKAGECONFIG_powerpc = "" |
21 | PACKAGECONFIG_riscv64 = "" | 22 | PACKAGECONFIG_riscv64 = "" |
22 | PACKAGECONFIG_riscv32 = "" | 23 | PACKAGECONFIG_riscv32 = "" |
@@ -89,4 +90,3 @@ RPROVIDES_${PN}-locale += "${@bb.utils.contains('PACKAGECONFIG', 'unwind', 'libu | |||
89 | RPROVIDES_${PN}-src += "${@bb.utils.contains('PACKAGECONFIG', 'unwind', 'libunwind-src', '', d)}" | 90 | RPROVIDES_${PN}-src += "${@bb.utils.contains('PACKAGECONFIG', 'unwind', 'libunwind-src', '', d)}" |
90 | 91 | ||
91 | BBCLASSEXTEND = "native nativesdk" | 92 | BBCLASSEXTEND = "native nativesdk" |
92 | TOOLCHAIN_forcevariable = "clang" | ||