diff options
-rw-r--r-- | recipes-core/busybox/busybox/0001-Turn-ptr_to_globals-and-bb_errno-to-be-non-const.patch | 14 | ||||
-rw-r--r-- | recipes-core/busybox/busybox_1.33%.bbappend (renamed from recipes-core/busybox/busybox_1.32.%.bbappend) | 0 |
2 files changed, 7 insertions, 7 deletions
diff --git a/recipes-core/busybox/busybox/0001-Turn-ptr_to_globals-and-bb_errno-to-be-non-const.patch b/recipes-core/busybox/busybox/0001-Turn-ptr_to_globals-and-bb_errno-to-be-non-const.patch index 4f4bbbd..468a32d 100644 --- a/recipes-core/busybox/busybox/0001-Turn-ptr_to_globals-and-bb_errno-to-be-non-const.patch +++ b/recipes-core/busybox/busybox/0001-Turn-ptr_to_globals-and-bb_errno-to-be-non-const.patch | |||
@@ -115,7 +115,7 @@ Signed-off-by: Khem Raj <raj.khem@gmail.com> | |||
115 | 115 | ||
116 | --- a/coreutils/test.c | 116 | --- a/coreutils/test.c |
117 | +++ b/coreutils/test.c | 117 | +++ b/coreutils/test.c |
118 | @@ -401,7 +401,7 @@ struct test_statics { | 118 | @@ -435,7 +435,7 @@ struct test_statics { |
119 | }; | 119 | }; |
120 | 120 | ||
121 | /* See test_ptr_hack.c */ | 121 | /* See test_ptr_hack.c */ |
@@ -127,15 +127,15 @@ Signed-off-by: Khem Raj <raj.khem@gmail.com> | |||
127 | --- a/include/libbb.h | 127 | --- a/include/libbb.h |
128 | +++ b/include/libbb.h | 128 | +++ b/include/libbb.h |
129 | @@ -342,7 +342,7 @@ struct BUG_off_t_size_is_misdetected { | 129 | @@ -342,7 +342,7 @@ struct BUG_off_t_size_is_misdetected { |
130 | #if defined(__GLIBC__) | 130 | #if defined(errno) |
131 | /* glibc uses __errno_location() to get a ptr to errno */ | 131 | /* If errno is a define, assume it's "define errno (*__errno_location())" |
132 | /* We can just memorize it once - no multithreading in busybox :) */ | 132 | * and we will cache it's result in this variable */ |
133 | -extern int *const bb_errno; | 133 | -extern int *const bb_errno; |
134 | +extern int *bb_errno; | 134 | +extern int *bb_errno; |
135 | #undef errno | 135 | #undef errno |
136 | #define errno (*bb_errno) | 136 | #define errno (*bb_errno) |
137 | #endif | 137 | #define bb_cached_errno_ptr 1 |
138 | @@ -2168,7 +2168,7 @@ struct globals; | 138 | @@ -2228,7 +2228,7 @@ struct globals; |
139 | /* '*const' ptr makes gcc optimize code much better. | 139 | /* '*const' ptr makes gcc optimize code much better. |
140 | * Magic prevents ptr_to_globals from going into rodata. | 140 | * Magic prevents ptr_to_globals from going into rodata. |
141 | * If you want to assign a value, use SET_PTR_TO_GLOBALS(x) */ | 141 | * If you want to assign a value, use SET_PTR_TO_GLOBALS(x) */ |
@@ -146,7 +146,7 @@ Signed-off-by: Khem Raj <raj.khem@gmail.com> | |||
146 | /* Clang/llvm drops assignment to "constant" storage. Silently. | 146 | /* Clang/llvm drops assignment to "constant" storage. Silently. |
147 | --- a/libbb/lineedit.c | 147 | --- a/libbb/lineedit.c |
148 | +++ b/libbb/lineedit.c | 148 | +++ b/libbb/lineedit.c |
149 | @@ -181,7 +181,7 @@ struct lineedit_statics { | 149 | @@ -192,7 +192,7 @@ struct lineedit_statics { |
150 | }; | 150 | }; |
151 | 151 | ||
152 | /* See lineedit_ptr_hack.c */ | 152 | /* See lineedit_ptr_hack.c */ |
diff --git a/recipes-core/busybox/busybox_1.32.%.bbappend b/recipes-core/busybox/busybox_1.33%.bbappend index f26df7e..f26df7e 100644 --- a/recipes-core/busybox/busybox_1.32.%.bbappend +++ b/recipes-core/busybox/busybox_1.33%.bbappend | |||