diff options
-rw-r--r-- | conf/nonclangable.conf | 1 | ||||
-rw-r--r-- | recipes-core/systemd/systemd_%.bbappend | 7 |
2 files changed, 1 insertions, 7 deletions
diff --git a/conf/nonclangable.conf b/conf/nonclangable.conf index bab6a69..6442ead 100644 --- a/conf/nonclangable.conf +++ b/conf/nonclangable.conf | |||
@@ -270,6 +270,7 @@ LDFLAGS:append:pn-qemu:toolchain-clang:x86 = " -latomic" | |||
270 | # warning: <elfFile> has a LOAD segment with RWX permissions | 270 | # warning: <elfFile> has a LOAD segment with RWX permissions |
271 | LDFLAGS:append:pn-ruby:toolchain-clang:powerpc = " -Wl,--no-warn-rwx-segment" | 271 | LDFLAGS:append:pn-ruby:toolchain-clang:powerpc = " -Wl,--no-warn-rwx-segment" |
272 | LDFLAGS:append:pn-cairo:toolchain-clang:powerpc = " -Wl,--no-warn-rwx-segment" | 272 | LDFLAGS:append:pn-cairo:toolchain-clang:powerpc = " -Wl,--no-warn-rwx-segment" |
273 | LDFLAGS:append:pn-systemd:toolchain-clang:powerpc = " -Wl,--no-warn-rwx-segment" | ||
273 | 274 | ||
274 | # glibc is built with gcc and hence encodes some libgcc specific builtins which are not found | 275 | # glibc is built with gcc and hence encodes some libgcc specific builtins which are not found |
275 | # when doing static linking with clang using compiler-rt, so use libgcc | 276 | # when doing static linking with clang using compiler-rt, so use libgcc |
diff --git a/recipes-core/systemd/systemd_%.bbappend b/recipes-core/systemd/systemd_%.bbappend deleted file mode 100644 index a54d6ee..0000000 --- a/recipes-core/systemd/systemd_%.bbappend +++ /dev/null | |||
@@ -1,7 +0,0 @@ | |||
1 | FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:" | ||
2 | |||
3 | # systemd 251.4 started to cause boot issues see | ||
4 | # https://bugzilla.yoctoproject.org/show_bug.cgi?id=14906 | ||
5 | # As a workaround disable O2 and use Os for now with clang | ||
6 | SELECTED_OPTIMIZATION:append:toolchain-clang = "-Os" | ||
7 | SELECTED_OPTIMIZATION:remove:toolchain-clang = "-O2" | ||