summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--dynamic-layers/openembedded-layer/recipes-devtools/bpftrace/bpftrace_0.14.1.bb19
1 files changed, 13 insertions, 6 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-devtools/bpftrace/bpftrace_0.14.1.bb b/dynamic-layers/openembedded-layer/recipes-devtools/bpftrace/bpftrace_0.14.1.bb
index 4e947fc..4a03ab0 100644
--- a/dynamic-layers/openembedded-layer/recipes-devtools/bpftrace/bpftrace_0.14.1.bb
+++ b/dynamic-layers/openembedded-layer/recipes-devtools/bpftrace/bpftrace_0.14.1.bb
@@ -12,7 +12,6 @@ DEPENDS += "bison-native \
12 libcereal \ 12 libcereal \
13 libbpf \ 13 libbpf \
14 " 14 "
15DEPENDS += "${@bb.utils.contains('PTEST_ENABLED', '1', 'gtest xxd-native', '', d)}"
16 15
17PV .= "+git${SRCREV}" 16PV .= "+git${SRCREV}"
18RDEPENDS:${PN} += "bash python3 xz" 17RDEPENDS:${PN} += "bash python3 xz"
@@ -29,11 +28,20 @@ S = "${WORKDIR}/git"
29 28
30inherit cmake ptest 29inherit cmake ptest
31 30
31PACKAGECONFIG ?= "${@bb.utils.contains('PTEST_ENABLED', '1', 'tests', '', d)}"
32
33# Clang-15.x crashes compiling some usdt tests
34# see https://github.com/llvm/llvm-project/issues/58477
35PACKAGECONFIG:remove:riscv64 = "tests"
36
37PACKAGECONFIG[tests] = "-DBUILD_TESTING=ON,-DBUILD_TESTING=OFF,gtest xxd-native"
38
32do_install_ptest() { 39do_install_ptest() {
33 install -d ${D}${PTEST_PATH}/tests 40 if [ -e ${B}/tests/bpftrace_test ]; then
34 install -m 755 ${B}/tests/bpftrace_test ${D}${PTEST_PATH}/tests 41 install -Dm 755 ${B}/tests/bpftrace_test ${D}${PTEST_PATH}/tests/bpftrace_test
35 cp -rf ${B}/tests/runtime* ${D}${PTEST_PATH}/tests 42 cp -rf ${B}/tests/runtime* ${D}${PTEST_PATH}/tests
36 cp -rf ${B}/tests/test* ${D}${PTEST_PATH}/tests 43 cp -rf ${B}/tests/test* ${D}${PTEST_PATH}/tests
44 fi
37} 45}
38 46
39def llvm_major_version(d): 47def llvm_major_version(d):
@@ -48,7 +56,6 @@ EXTRA_OECMAKE = " \
48 -DLLVM_REQUESTED_VERSION=${LLVM_MAJOR_VERSION} \ 56 -DLLVM_REQUESTED_VERSION=${LLVM_MAJOR_VERSION} \
49 -DENABLE_MAN=OFF \ 57 -DENABLE_MAN=OFF \
50" 58"
51EXTRA_OECMAKE += "${@bb.utils.contains('PTEST_ENABLED', '1', '-DBUILD_TESTING=ON', '-DBUILD_TESTING=OFF', d)}"
52 59
53COMPATIBLE_HOST = "(x86_64.*|aarch64.*|powerpc64.*|riscv64.*)-linux" 60COMPATIBLE_HOST = "(x86_64.*|aarch64.*|powerpc64.*|riscv64.*)-linux"
54COMPATIBLE_HOST:libc-musl = "null" 61COMPATIBLE_HOST:libc-musl = "null"