summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-devtools/castxml/castxml_0.6.11.bb2
-rw-r--r--recipes-devtools/clang/common.inc72
2 files changed, 73 insertions, 1 deletions
diff --git a/recipes-devtools/castxml/castxml_0.6.11.bb b/recipes-devtools/castxml/castxml_0.6.11.bb
index cd6e004..7eccc77 100644
--- a/recipes-devtools/castxml/castxml_0.6.11.bb
+++ b/recipes-devtools/castxml/castxml_0.6.11.bb
@@ -9,6 +9,6 @@ SRCREV = "f38c024b395187814f14f77974d8f5240bb2e71f"
9S = "${WORKDIR}/git" 9S = "${WORKDIR}/git"
10 10
11DEPENDS = "clang" 11DEPENDS = "clang"
12inherit cmake cmake-native pkgconfig python3native 12inherit cmake pkgconfig python3native
13 13
14BBCLASSEXTEND = "native nativesdk" 14BBCLASSEXTEND = "native nativesdk"
diff --git a/recipes-devtools/clang/common.inc b/recipes-devtools/clang/common.inc
new file mode 100644
index 0000000..e49bd68
--- /dev/null
+++ b/recipes-devtools/clang/common.inc
@@ -0,0 +1,72 @@
1FILESEXTRAPATHS =. "${FILE_DIRNAME}/clang:"
2
3LIC_FILES_CHKSUM = "file://llvm/LICENSE.TXT;md5=${LLVMMD5SUM} \
4 file://clang/LICENSE.TXT;md5=${CLANGMD5SUM} \
5"
6LICENSE = "Apache-2.0-with-LLVM-exception"
7
8# Snapshot
9#RELEASE ?= "a69568efe6c4972e71af295c6577b3412dd57c22"
10#BASEURI ?= "https://api.github.com/repos/llvm/llvm-project/tarball/${RELEASE};downloadfilename=llvm-${PV}-${RELEASE}.tar.gz"
11#SOURCEDIR ?= "llvm-llvm-project-${@'${RELEASE}'[0:7]}"
12#SRC_URI[sha256sum] = "aed4f66cd72867b36cc55a0588436933c3d58d3e61ca782b6bf57605d3fdcb09"
13
14# GA Release
15RELEASE ?= "${PV}"
16BASEURI ?= "${LLVM_HTTP}/llvm-project/releases/download/llvmorg-${PV}/llvm-project-${PV}.src.tar.xz"
17SOURCEDIR ?= "llvm-project-${PV}.src"
18SRC_URI[sha256sum] = "f0a4a240aabc9b056142d14d5478bb6d962aeac549cbd75b809f5499240a8b38"
19
20SRC_URI = "\
21 ${BASEURI} \
22 file://0001-libcxxabi-Find-libunwind-headers-when-LIBCXXABI_LIBU.patch \
23 file://0002-compiler-rt-support-a-new-embedded-linux-target.patch \
24 file://0003-compiler-rt-Simplify-cross-compilation.-Don-t-use-na.patch \
25 file://0004-llvm-TargetLibraryInfo-Undefine-libc-functions-if-th.patch \
26 file://0005-llvm-allow-env-override-of-exe-and-libdir-path.patch \
27 file://0006-clang-driver-Check-sysroot-for-ldso-path.patch \
28 file://0007-clang-Driver-tools.cpp-Add-lssp_nonshared-on-musl.patch \
29 file://0008-clang-Prepend-trailing-to-sysroot.patch \
30 file://0009-clang-Look-inside-the-target-sysroot-for-compiler-ru.patch \
31 file://0010-clang-Define-releative-gcc-installation-dir.patch \
32 file://0011-clang-Add-lpthread-and-ldl-along-with-lunwind-for-st.patch \
33 file://0012-Pass-PYTHON_EXECUTABLE-when-cross-compiling-for-nati.patch \
34 file://0013-Check-for-atomic-double-intrinsics.patch \
35 file://0014-cmake-Fix-configure-for-packages-using-find_package.patch \
36 file://0015-clang-Fix-resource-dir-location-for-cross-toolchains.patch \
37 file://0016-clang-driver-Add-dyld-prefix-when-checking-sysroot-f.patch \
38 file://0017-clang-Use-python3-in-python-scripts.patch \
39 file://0018-For-x86_64-set-Yocto-based-GCC-install-search-path.patch \
40 file://0019-llvm-Insert-anchor-for-adding-OE-distro-vendor-names.patch \
41 file://0020-compiler-rt-Do-not-use-backtrace-APIs-on-non-glibc-l.patch \
42 file://0021-clang-Fix-x86-triple-for-non-debian-multiarch-linux-.patch \
43 file://0022-libunwind-Added-unw_backtrace-method.patch \
44 file://0023-clang-Do-not-use-install-relative-libc-headers.patch \
45 file://0024-Fix-lib-paths-for-OpenEmbedded-Host.patch \
46 file://0025-Correct-library-search-path-for-OpenEmbedded-Host.patch \
47 file://0026-lldb-Link-with-libatomic-on-x86.patch \
48 file://0027-compiler-rt-Enable-__int128-for-ppc32.patch \
49 file://0028-llvm-Do-not-use-cmake-infra-to-detect-libzstd.patch \
50 file://0029-compiler-rt-Fix-stat-struct-s-size-for-O32-ABI.patch \
51 file://0030-compiler-rt-Undef-_TIME_BITS-along-with-_FILE_OFFSET.patch \
52 file://0031-ToolChains-Gnu.cpp-ARMLibDirs-search-also-in-lib32.patch \
53 file://0032-clang-llvm-Add-OE-specific-ABI-triple-for-N32-ABI.patch \
54 file://0033-llvm-Add-libunwind.pc.in-and-llvm-config-scripts.patch \
55 file://0034-scan-build-py-respect-LLVM_LIBDIR_SUFFIX-like-other-.patch \
56 file://0035-compiler-rt-Do-not-pass-target-to-clang-compiler.patch \
57 file://0036-Fix-build-on-ppc64-musl.patch \
58 file://0037-clangd-Add-a-build-option-to-disable-building-dexp.patch \
59 file://0001-llvm-config-remove-LLVM_LDFLAGS-from-ldflags-output.patch \
60"
61# Fallback to no-PIE if not set
62GCCPIE ??= ""
63
64S = "${TMPDIR}/work-shared/llvm-project-source-${PV}-${PR}/${SOURCEDIR}"
65B ?= "${WORKDIR}/llvm-project-source-${PV}/build.${HOST_SYS}.${TARGET_SYS}"
66
67# We need to ensure that for the shared work directory, the do_patch signatures match
68# The real WORKDIR location isn't a dependency for the shared workdir.
69src_patches[vardepsexclude] = "WORKDIR"
70should_apply[vardepsexclude] += "PN"
71
72BPN = "clang"