summaryrefslogtreecommitdiffstats
path: root/recipes-devtools/include-what-you-use/include-what-you-use_0.23.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-devtools/include-what-you-use/include-what-you-use_0.23.bb')
-rw-r--r--recipes-devtools/include-what-you-use/include-what-you-use_0.23.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/recipes-devtools/include-what-you-use/include-what-you-use_0.23.bb b/recipes-devtools/include-what-you-use/include-what-you-use_0.23.bb
new file mode 100644
index 0000000..9ba16b6
--- /dev/null
+++ b/recipes-devtools/include-what-you-use/include-what-you-use_0.23.bb
@@ -0,0 +1,26 @@
1SUMMARY = "Include What You Use (IWYU) - Clang based checker for C/C++ header includes"
2DESCRIPTION = "For every symbol (type, function, variable, or macro) that you \
3 use in foo.cc (or foo.cpp), either foo.cc or foo.h should \
4 include a .h file that exports the declaration of that symbol."
5HOMEPAGE = "https://include-what-you-use.org"
6BUGTRACKER = "https://github.com/include-what-you-use/include-what-you-use/issues"
7LICENSE = "NCSA"
8LIC_FILES_CHKSUM = "file://LICENSE.TXT;md5=3bb66a14534286912cd6f26649b5c60a \
9 file://iwyu-check-license-header.py;md5=7bdb749831163fbe9232b3cb7186116f"
10
11DEPENDS = "clang"
12
13SRC_URI = "git://github.com/include-what-you-use/include-what-you-use.git;protocol=https;branch=master"
14SRCREV = "fa1094c0b3848f82244778bc6153cc84f8a890f6"
15
16PV .= "+git"
17
18S = "${WORKDIR}/git"
19
20inherit cmake python3native
21
22EXTRA_OECMAKE = "-DIWYU_RESOURCE_RELATIVE_TO=iwyu"
23
24FILES:${PN} += "${datadir}/${BPN}"
25
26BBCLASSEXTEND = "nativesdk"