diff options
author | Bruce Ashfield <bruce.ashfield@gmail.com> | 2024-10-12 01:15:34 +0000 |
---|---|---|
committer | Bruce Ashfield <bruce.ashfield@gmail.com> | 2024-10-12 01:16:20 +0000 |
commit | 10f244fc36babc24eca62277f1bc95b966c15373 (patch) | |
tree | b5978907d1e113a15620a764960a74e0f2131f20 | |
parent | 31ed0c88aa5dc841a96c7a16abd9cdc8ffb425fc (diff) | |
download | meta-cloud-services-10f244fc36babc24eca62277f1bc95b966c15373.tar.gz |
puppet-labs-stdlib: update to v9.6.0
We also update our gemspec file.
Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
3 files changed, 34 insertions, 37 deletions
diff --git a/recipes-support/puppetlabs-stdlib/files/Add-gemspec.patch b/recipes-support/puppetlabs-stdlib/files/Add-gemspec.patch deleted file mode 100644 index fd65da6..0000000 --- a/recipes-support/puppetlabs-stdlib/files/Add-gemspec.patch +++ /dev/null | |||
@@ -1,37 +0,0 @@ | |||
1 | From e23971fcc1425e06a11484e552fbc631c43f44d4 Mon Sep 17 00:00:00 2001 | ||
2 | From: Mark Asselstine <mark.asselstine@windriver.com> | ||
3 | Date: Tue, 22 Dec 2015 11:05:22 -0500 | ||
4 | Subject: [PATCH] Add gemspec | ||
5 | |||
6 | Started with an example from here | ||
7 | http://guides.rubygems.org/make-your-own-gem/ | ||
8 | |||
9 | Upstream-Status: Inappropriate [embedded specific] | ||
10 | |||
11 | Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> | ||
12 | --- | ||
13 | puppetlabs-stdlib.gemspec | 12 ++++++++++++ | ||
14 | 1 file changed, 12 insertions(+) | ||
15 | create mode 100644 puppetlabs-stdlib.gemspec | ||
16 | |||
17 | diff --git a/puppetlabs-stdlib.gemspec b/puppetlabs-stdlib.gemspec | ||
18 | new file mode 100644 | ||
19 | index 0000000..6b7eee3 | ||
20 | --- /dev/null | ||
21 | +++ b/puppetlabs-stdlib.gemspec | ||
22 | @@ -0,0 +1,12 @@ | ||
23 | +Gem::Specification.new do |s| | ||
24 | + s.name = 'puppetlabs-stdlib' | ||
25 | + s.version = '4.10.0' | ||
26 | + s.date = '2015-12-15' | ||
27 | + s.summary = "Puppet Labs Standard Library module" | ||
28 | + s.description = s.summary | ||
29 | + s.authors = ["Puppet Labs"] | ||
30 | + s.email = '' | ||
31 | + s.files = %w(LICENSE README.markdown Rakefile) + Dir.glob('{lib,spec}/**/*') | ||
32 | + s.homepage = 'https://github.com/puppetlabs/puppetlabs-stdlib' | ||
33 | + s.license = 'Apache 2.0' | ||
34 | +end | ||
35 | -- | ||
36 | 2.1.4 | ||
37 | |||
diff --git a/recipes-support/puppetlabs-stdlib/files/puppetlabs-stdlib.gemspec b/recipes-support/puppetlabs-stdlib/files/puppetlabs-stdlib.gemspec new file mode 100644 index 0000000..46b2c9e --- /dev/null +++ b/recipes-support/puppetlabs-stdlib/files/puppetlabs-stdlib.gemspec | |||
@@ -0,0 +1,30 @@ | |||
1 | # | ||
2 | # -*- encoding: utf-8 -*- | ||
3 | |||
4 | Gem::Specification.new do |s| | ||
5 | s.name = "puppetmodule-stdlib" | ||
6 | |||
7 | s.version = "4.0.0" | ||
8 | |||
9 | s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version= | ||
10 | s.authors = ["Puppet Labs"] | ||
11 | s.date = "2013-04-10" | ||
12 | s.description = "Puppet Labs Standard Library module" | ||
13 | s.email = "bruce.ashfield@gmail.com" | ||
14 | s.executables = [] | ||
15 | s.files += Dir['lib/**/*.rb'] + Dir['manifests/**/*.pp'] + Dir['tests/**/*.pp'] + Dir['spec/**/*.rb'] | ||
16 | s.homepage = "https://github.com/puppetlabs/puppetlabs-stdlib" | ||
17 | s.rdoc_options = ["--title", "Puppet Standard Library Module", "--main", "README.markdown", "--line-numbers"] | ||
18 | s.require_paths = ["lib"] | ||
19 | s.rubyforge_project = "puppetmodule-stdlib" | ||
20 | s.summary = "This module provides a standard library of resources for developing Puppet Modules." | ||
21 | |||
22 | if s.respond_to? :specification_version then | ||
23 | s.specification_version = 3 | ||
24 | |||
25 | if Gem::Version.new(Gem::VERSION) >= Gem::Version.new('1.2.0') then | ||
26 | else | ||
27 | end | ||
28 | else | ||
29 | end | ||
30 | end | ||
diff --git a/recipes-support/puppetlabs-stdlib/puppetlabs-stdlib_git.bb b/recipes-support/puppetlabs-stdlib/puppetlabs-stdlib_git.bb index 41f8c6e..cb343e4 100644 --- a/recipes-support/puppetlabs-stdlib/puppetlabs-stdlib_git.bb +++ b/recipes-support/puppetlabs-stdlib/puppetlabs-stdlib_git.bb | |||
@@ -8,10 +8,14 @@ SRCREV = "99aebdd57d665ac7e2ba38ab95f3fbdbc2fb56e0" | |||
8 | 8 | ||
9 | SRC_URI = " \ | 9 | SRC_URI = " \ |
10 | git://github.com/puppetlabs/puppetlabs-stdlib.git;branch=main;protocol=https \ | 10 | git://github.com/puppetlabs/puppetlabs-stdlib.git;branch=main;protocol=https \ |
11 | file://puppetlabs-stdlib.gemspec \ | ||
11 | " | 12 | " |
12 | 13 | ||
13 | inherit rubyv2 | 14 | inherit rubyv2 |
14 | 15 | ||
16 | GEM_NAME = "puppetlabs-std" | ||
17 | GEM_SPEC_FILE = "puppetlabs-stdlib.gemspec" | ||
18 | |||
15 | S="${WORKDIR}/git" | 19 | S="${WORKDIR}/git" |
16 | 20 | ||
17 | DEPENDS += " \ | 21 | DEPENDS += " \ |