summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@gmail.com>2024-10-09 23:42:21 +0000
committerBruce Ashfield <bruce.ashfield@gmail.com>2024-10-09 23:42:21 +0000
commit4f7788bbebe80f1c6b13bd3bc2db875e900bfa29 (patch)
treedce7e352a1b69cf28d947c56a2d4f22ab25c7e7e
parentd3acbcf51a36518ca6daa1376da5e54623285e7a (diff)
downloadmeta-cloud-services-4f7788bbebe80f1c6b13bd3bc2db875e900bfa29.tar.gz
heira: update to 3.12.0
Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
-rw-r--r--recipes-support/hiera/hiera/add_hiera_gemspec.patch23
-rw-r--r--recipes-support/hiera/hiera/hiera.gemspec28
-rw-r--r--recipes-support/hiera/hiera_1.3.4.bb20
-rw-r--r--recipes-support/hiera/hiera_3.12.0.bb24
4 files changed, 52 insertions, 43 deletions
diff --git a/recipes-support/hiera/hiera/add_hiera_gemspec.patch b/recipes-support/hiera/hiera/add_hiera_gemspec.patch
deleted file mode 100644
index 7e302cf..0000000
--- a/recipes-support/hiera/hiera/add_hiera_gemspec.patch
+++ /dev/null
@@ -1,23 +0,0 @@
1diff -urN hiera-1.3.4_ori/hiera.gemspec hiera-1.3.4/hiera.gemspec
2--- hiera-1.3.4_ori/hiera.gemspec 1970-01-01 08:00:00.000000000 +0800
3+++ hiera-1.3.4/hiera.gemspec 2014-11-12 14:30:07.000000000 +0800
4@@ -0,0 +1,19 @@
5+$:.unshift(File.dirname(__FILE__) + '/lib')
6+require 'hiera/version'
7+
8+Gem::Specification.new do |s|
9+ s.name = 'hiera'
10+ s.version = Hiera::VERSION
11+ s.platform = Gem::Platform::RUBY
12+ s.summary = 'A simple pluggable Hierarchical Database.'
13+ s.description = s.summary
14+ s.author = 'Yang Haibo'
15+ s.email = 'b40869@freescale.com'
16+ s.homepage = 'https://projects.puppetlabs.com/projects/hiera'
17+ s.license = 'Apache 2.0'
18+
19+ s.bindir = 'bin'
20+ s.executables = ['hiera']
21+ s.require_path = 'lib'
22+ s.files = %w(LICENSE README.md Rakefile) + Dir.glob('{lib,spec}/**/*')
23+end
diff --git a/recipes-support/hiera/hiera/hiera.gemspec b/recipes-support/hiera/hiera/hiera.gemspec
new file mode 100644
index 0000000..5d3ae06
--- /dev/null
+++ b/recipes-support/hiera/hiera/hiera.gemspec
@@ -0,0 +1,28 @@
1lib = File.expand_path('../lib/', __FILE__)
2$:.unshift lib unless $:.include?(lib)
3
4require 'bundler/version'
5
6Gem::Specification.new do |s|
7 s.name = "hiera-file"
8 s.version = '1.1.1'
9 s.platform = Gem::Platform::RUBY
10
11 s.authors = ["Hunter Haugen", "Adrien Thebo", "Reid Vandewiele"]
12 s.authors = "adrien@puppetlabs.com"
13 s.homepage = "http://github.com/adrienthebo/hiera-file"
14 s.summary = "File backend for Hiera"
15 s.description = "A data backend for Hiera that can return the content of whole files"
16
17 # hiera is omitted as an explicit dependency so that hiera-file can be
18 # installed as a gem when hiera is installed via system package.
19 #s.add_dependency 'hiera', '>= 1.0.0'
20
21 s.add_development_dependency 'rspec', '~> 2.10.0'
22 s.add_development_dependency 'mocha', '~> 0.10.5'
23
24 s.files = Dir.glob("lib/**/*")
25 s.require_path = 'lib'
26
27 s.test_files = Dir.glob("spec/**/*_spec.rb")
28end
diff --git a/recipes-support/hiera/hiera_1.3.4.bb b/recipes-support/hiera/hiera_1.3.4.bb
deleted file mode 100644
index eb633ff..0000000
--- a/recipes-support/hiera/hiera_1.3.4.bb
+++ /dev/null
@@ -1,20 +0,0 @@
1SUMMARY = "A simple pluggable Hierarchical Database"
2HOMEPAGE = "https://projects.puppetlabs.com/projects/hiera"
3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=8ac92c91fbec097f798223679c1a7491"
5
6SRC_URI = " \
7 https://downloads.puppetlabs.com/hiera/hiera-${PV}.tar.gz \
8 file://add_hiera_gemspec.patch \
9"
10SRC_URI[md5sum] = "6abccc518edb55291a63129ef30888cd"
11SRC_URI[sha256sum] = "d3ecbfedc7d8493fd00c7dd624efbb225705d289442fe7706cb81a3a7230e70e"
12
13
14inherit ruby
15
16DEPENDS += " \
17 ruby \
18"
19
20RUBY_INSTALL_GEMS = "hiera-${PV}.gem"
diff --git a/recipes-support/hiera/hiera_3.12.0.bb b/recipes-support/hiera/hiera_3.12.0.bb
new file mode 100644
index 0000000..7a465a8
--- /dev/null
+++ b/recipes-support/hiera/hiera_3.12.0.bb
@@ -0,0 +1,24 @@
1SUMMARY = "A simple pluggable Hierarchical Database"
2HOMEPAGE = "https://projects.puppetlabs.com/projects/hiera"
3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=cb05cd62f0184c1950374f251caef471"
5
6SRC_URI = " \
7 https://downloads.puppetlabs.com/hiera/hiera-${PV}.tar.gz \
8 file://hiera.gemspec \
9"
10
11SRC_URI[md5sum] = "899ca6294677757ec8c5b6422c0090e2"
12SRC_URI[sha256sum] = "1c258f6b290f0884f6b6e892985b58d0dd24f389b42f5911c83f392030c403e1"
13
14inherit ruby
15
16DEPENDS += " \
17 ruby \
18"
19
20RUBY_INSTALL_GEMS = "hiera-file-1.1.1.gem"
21
22do_compile:prepend() {
23 cp ${UNPACKDIR}/hiera.gemspec ${S}
24}