diff options
author | Mark Asselstine <mark.asselstine@windriver.com> | 2016-01-09 14:27:21 -0500 |
---|---|---|
committer | Bruce Ashfield <bruce.ashfield@windriver.com> | 2016-01-11 09:33:32 -0500 |
commit | d901bade0b2b6b65bd218056658bf028dbde6fbf (patch) | |
tree | 984d4dba7cab05d53b5fbee6a75dac25addc900c | |
parent | 18f6951ff709cc78c5519c0a593e39cf8c09f331 (diff) | |
download | meta-cloud-services-d901bade0b2b6b65bd218056658bf028dbde6fbf.tar.gz |
python-monotonic: add new recipe to fulfil dependencies
This package is required by uprevs of trove, nova, several oslo
packages, to name a few. Adding this package so that it is available
for these uprevs as we move to openstack liberty.
This python module provides access to the value, in fractions of a
second, of a clock.
Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com>
Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
-rw-r--r-- | meta-openstack/recipes-devtools/python/python-monotonic_git.bb | 31 |
1 files changed, 31 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-monotonic_git.bb b/meta-openstack/recipes-devtools/python/python-monotonic_git.bb new file mode 100644 index 0000000..2552409 --- /dev/null +++ b/meta-openstack/recipes-devtools/python/python-monotonic_git.bb | |||
@@ -0,0 +1,31 @@ | |||
1 | DESCRIPTION = "An implementation of time.monotonic()" | ||
2 | HOMEPAGE = "https://github.com/atdt/monotonic" | ||
3 | SECTION = "devel/python" | ||
4 | LICENSE = "Apache-2.0" | ||
5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=d2794c0df5b907fdace235a619d80314" | ||
6 | |||
7 | PV = "0.4" | ||
8 | SRCREV = "93b3d3ba63597e57b20333db4e33ca0f48debf2a" | ||
9 | |||
10 | SRCNAME = "monotonic" | ||
11 | SRC_URI = "git://github.com/atdt/${SRCNAME}.git" | ||
12 | |||
13 | S = "${WORKDIR}/git" | ||
14 | |||
15 | inherit distutils | ||
16 | |||
17 | DEPENDS += " \ | ||
18 | python-pbr \ | ||
19 | " | ||
20 | |||
21 | RDEPENDS_${PN} += " \ | ||
22 | python-pbr \ | ||
23 | " | ||
24 | |||
25 | do_install_append() { | ||
26 | # Using these "longest" paths will ensure needed shorter paths will be created | ||
27 | install -d ${D}/${libdir}/python2.7/site-packages/${SRCNAME}.egg-info | ||
28 | |||
29 | install -m 644 ${S}/${SRCNAME}.py ${D}/${libdir}/python2.7/site-packages/ | ||
30 | install -m 644 ${S}/${SRCNAME}.egg-info/* ${D}/${libdir}/python2.7/site-packages/${SRCNAME}.egg-info/ | ||
31 | } | ||