summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorVijay Anusuri <vanusuri@mvista.com>2024-12-03 13:06:12 +0530
committerBruce Ashfield <bruce.ashfield@gmail.com>2024-12-10 03:45:20 +0000
commite606fa3e70bc407f695e2bbfadd2c6519eda4107 (patch)
tree9744d715bd25c91f6c181807750b91b2c3a9b43f
parent82d6a52a38056518423afe1d2ce4bc0d4ff78d5c (diff)
downloadmeta-cloud-services-e606fa3e70bc407f695e2bbfadd2c6519eda4107.tar.gz
mod-wsgi: upgrade 4.9.0 -> 5.0.2
mod-wsgi version 4.9.0 doesn't build against python 3.13 update it to 5.0.2 which does build. Refreshed configure.ac-allow-PYTHON-values-to-be-passed-via-en.patch for 5.0.2 version. Signed-off-by: Anand Je Sypureddy <anandje@mvista.com> Signed-off-by: Vijay Anusuri <vanusuri@mvista.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
-rw-r--r--meta-openstack/recipes-support/mod-wsgi/files/configure.ac-allow-PYTHON-values-to-be-passed-via-en.patch22
-rw-r--r--meta-openstack/recipes-support/mod-wsgi/mod-wsgi_git.bb4
2 files changed, 14 insertions, 12 deletions
diff --git a/meta-openstack/recipes-support/mod-wsgi/files/configure.ac-allow-PYTHON-values-to-be-passed-via-en.patch b/meta-openstack/recipes-support/mod-wsgi/files/configure.ac-allow-PYTHON-values-to-be-passed-via-en.patch
index 79aedff..6718a4a 100644
--- a/meta-openstack/recipes-support/mod-wsgi/files/configure.ac-allow-PYTHON-values-to-be-passed-via-en.patch
+++ b/meta-openstack/recipes-support/mod-wsgi/files/configure.ac-allow-PYTHON-values-to-be-passed-via-en.patch
@@ -9,14 +9,14 @@ issues.
9 9
10Updated for 4.9.0: Jeremy Puhlman 10Updated for 4.9.0: Jeremy Puhlman
11 11
12Upstream-Status: Pending
12Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> 13Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com>
13---- 14---
14 configure.ac | 41 +++++++++++++++++++++++++++++++++++++++++ 15 configure.ac | 40 ++++++++++++++++++++++++++++++++++++++++
15 1 file changed, 41 insertions(+) 16 1 file changed, 40 insertions(+)
16
17 17
18diff --git a/configure.ac b/configure.ac 18diff --git a/configure.ac b/configure.ac
19index 37a0f86..9b77c7f 100644 19index f994dd7..8774010 100644
20--- a/configure.ac 20--- a/configure.ac
21+++ b/configure.ac 21+++ b/configure.ac
22@@ -106,26 +106,38 @@ fi 22@@ -106,26 +106,38 @@ fi
@@ -58,7 +58,7 @@ index 37a0f86..9b77c7f 100644
58 58
59 if test "${ENABLE_EMBEDDED}" != "yes"; then 59 if test "${ENABLE_EMBEDDED}" != "yes"; then
60 CPPFLAGS3="-DMOD_WSGI_DISABLE_EMBEDDED" 60 CPPFLAGS3="-DMOD_WSGI_DISABLE_EMBEDDED"
61@@ -137,22 +149,42 @@ CPPFLAGS="${CPPFLAGS} ${CPPFLAGS1} ${CPPFLAGS2} ${CPPFLAGS3}" 61@@ -137,21 +149,41 @@ CPPFLAGS="${CPPFLAGS} ${CPPFLAGS1} ${CPPFLAGS2} ${CPPFLAGS3}"
62 62
63 AC_SUBST(CPPFLAGS) 63 AC_SUBST(CPPFLAGS)
64 64
@@ -71,9 +71,8 @@ index 37a0f86..9b77c7f 100644
71+fi 71+fi
72+if test -z "${PYTHON_CFGDIR}"; then 72+if test -z "${PYTHON_CFGDIR}"; then
73 PYTHONCFGDIR=`${PYTHON} -c 'from sys import stdout; \ 73 PYTHONCFGDIR=`${PYTHON} -c 'from sys import stdout; \
74 import distutils.sysconfig; \ 74 import sysconfig; \
75 stdout.write(distutils.sysconfig.get_python_lib(plat_specific=1, \ 75 stdout.write(sysconfig.get_path("platstdlib") +"/config")'`
76 standard_lib=1) +"/config")'`
77+else 76+else
78+PYTHONCFGDIR="${PYTHON_CFGDIR}" 77+PYTHONCFGDIR="${PYTHON_CFGDIR}"
79+fi 78+fi
@@ -101,7 +100,7 @@ index 37a0f86..9b77c7f 100644
101 100
102 if test "${PYTHON_LDVERSION}" != "${PYTHON_VERSION}"; then 101 if test "${PYTHON_LDVERSION}" != "${PYTHON_VERSION}"; then
103 PYTHONCFGDIR="${PYTHONCFGDIR}-${PYTHON_LDVERSION}" 102 PYTHONCFGDIR="${PYTHONCFGDIR}-${PYTHON_LDVERSION}"
104@@ -180,12 +212,20 @@ if test "${PYTHONFRAMEWORKDIR}" = "no-framework" -o \ 103@@ -179,12 +211,20 @@ if test "${PYTHONFRAMEWORKDIR}" = "no-framework" -o \
105 LDLIBS1="-lpython${PYTHON_VERSION}" 104 LDLIBS1="-lpython${PYTHON_VERSION}"
106 fi 105 fi
107 106
@@ -122,3 +121,6 @@ index 37a0f86..9b77c7f 100644
122 else 121 else
123 LDFLAGS1="-Wl,-F${PYTHONFRAMEWORKPREFIX} -framework ${PYTHONFRAMEWORK}" 122 LDFLAGS1="-Wl,-F${PYTHONFRAMEWORKPREFIX} -framework ${PYTHONFRAMEWORK}"
124 123
124--
1252.25.1
126
diff --git a/meta-openstack/recipes-support/mod-wsgi/mod-wsgi_git.bb b/meta-openstack/recipes-support/mod-wsgi/mod-wsgi_git.bb
index b0daf54..f22a242 100644
--- a/meta-openstack/recipes-support/mod-wsgi/mod-wsgi_git.bb
+++ b/meta-openstack/recipes-support/mod-wsgi/mod-wsgi_git.bb
@@ -9,8 +9,8 @@ HOMEPAGE = "https://github.com/GrahamDumpleton/mod_wsgi"
9LICENSE = "Apache-2.0" 9LICENSE = "Apache-2.0"
10LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57" 10LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
11 11
12SRCREV = "df9faf954a1ab6208f45ba6fde90f0b41f605483" 12SRCREV = "1b645ebd7d87f7a27d23690c19e97dbf8dafe6b4"
13PV = "4.9.0+git${SRCPV}" 13PV = "5.0.2+git${SRCPV}"
14 14
15S = "${WORKDIR}/git" 15S = "${WORKDIR}/git"
16 16