diff options
author | Hongzhi.Song <hongzhi.song@windriver.com> | 2019-03-14 06:15:53 -0400 |
---|---|---|
committer | Bruce Ashfield <bruce.ashfield@gmail.com> | 2019-03-17 00:19:23 +0000 |
commit | 8d19a924405ee3acd4c560aa9d381facfcaa7ac4 (patch) | |
tree | 83b36886dd8feb1eeda2f4fb63f8a705ac963db7 /recipes-extended/glusterfs/files/python-work-around-host-and-target-python.patch | |
parent | 61b2b5b3e38ff63bf39007cb9b7d4773f42a5f85 (diff) | |
download | meta-cloud-services-8d19a924405ee3acd4c560aa9d381facfcaa7ac4.tar.gz |
glusterfs: uprev from v3.11.1 to v5.4
The latest stable release covers some CVEs and new features.
Signed-off-by: Hongzhi.Song <hongzhi.song@windriver.com>
Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'recipes-extended/glusterfs/files/python-work-around-host-and-target-python.patch')
-rw-r--r-- | recipes-extended/glusterfs/files/python-work-around-host-and-target-python.patch | 56 |
1 files changed, 30 insertions, 26 deletions
diff --git a/recipes-extended/glusterfs/files/python-work-around-host-and-target-python.patch b/recipes-extended/glusterfs/files/python-work-around-host-and-target-python.patch index d70a103..700b0ba 100644 --- a/recipes-extended/glusterfs/files/python-work-around-host-and-target-python.patch +++ b/recipes-extended/glusterfs/files/python-work-around-host-and-target-python.patch | |||
@@ -1,6 +1,6 @@ | |||
1 | From fbe4fdfddb096e4e6650908929c366dcc9556ade Mon Sep 17 00:00:00 2001 | 1 | From 80c38519224635e9fe2a21542b7dbb14e4c16dcc Mon Sep 17 00:00:00 2001 |
2 | From: Mark Asselstine <mark.asselstine@windriver.com> | 2 | From: "Hongzhi.Song" <hongzhi.song@windriver.com> |
3 | Date: Thu, 27 Feb 2014 21:50:40 -0500 | 3 | Date: Tue, 12 Mar 2019 19:46:27 -0700 |
4 | Subject: [PATCH] python: work around host and target python | 4 | Subject: [PATCH] python: work around host and target python |
5 | 5 | ||
6 | In order to allow for the build system to make use of python but not | 6 | In order to allow for the build system to make use of python but not |
@@ -18,7 +18,8 @@ Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> | |||
18 | Signed-off-by: Xulin Sun <xulin.sun@windriver.com> | 18 | Signed-off-by: Xulin Sun <xulin.sun@windriver.com> |
19 | [Yi: minor adjust the code to apply the patch on 3.11.1] | 19 | [Yi: minor adjust the code to apply the patch on 3.11.1] |
20 | Signed-off-by: Yi Zhao <yi.zhao@windriver.com> | 20 | Signed-off-by: Yi Zhao <yi.zhao@windriver.com> |
21 | 21 | [Hongzhi: minor adjust the code to apply on v5.4] | |
22 | Signed-off-by: Hongzhi.Song <hongzhi.song@windriver.com> | ||
22 | --- | 23 | --- |
23 | configure.ac | 2 ++ | 24 | configure.ac | 2 ++ |
24 | geo-replication/src/Makefile.am | 3 ++- | 25 | geo-replication/src/Makefile.am | 3 ++- |
@@ -26,10 +27,10 @@ Signed-off-by: Yi Zhao <yi.zhao@windriver.com> | |||
26 | 3 files changed, 7 insertions(+), 4 deletions(-) | 27 | 3 files changed, 7 insertions(+), 4 deletions(-) |
27 | 28 | ||
28 | diff --git a/configure.ac b/configure.ac | 29 | diff --git a/configure.ac b/configure.ac |
29 | index 8ce28f6..8e0652a 100644 | 30 | index bc4cf93..d55a7b2 100644 |
30 | --- a/configure.ac | 31 | --- a/configure.ac |
31 | +++ b/configure.ac | 32 | +++ b/configure.ac |
32 | @@ -270,6 +270,8 @@ AC_CANONICAL_HOST | 33 | @@ -279,6 +279,8 @@ AC_CANONICAL_HOST |
33 | AC_PROG_CC | 34 | AC_PROG_CC |
34 | AC_DISABLE_STATIC | 35 | AC_DISABLE_STATIC |
35 | AC_PROG_LIBTOOL | 36 | AC_PROG_LIBTOOL |
@@ -53,27 +54,30 @@ index 9937a0b..07456fb 100644 | |||
53 | AM_CFLAGS = -Wall $(GF_CFLAGS) | 54 | AM_CFLAGS = -Wall $(GF_CFLAGS) |
54 | 55 | ||
55 | diff --git a/geo-replication/src/gsyncd.c b/geo-replication/src/gsyncd.c | 56 | diff --git a/geo-replication/src/gsyncd.c b/geo-replication/src/gsyncd.c |
56 | index 2c48ca5..b1d1126 100644 | 57 | index 77af662..8cd0551 100644 |
57 | --- a/geo-replication/src/gsyncd.c | 58 | --- a/geo-replication/src/gsyncd.c |
58 | +++ b/geo-replication/src/gsyncd.c | 59 | +++ b/geo-replication/src/gsyncd.c |
59 | @@ -153,9 +153,9 @@ invoke_gsyncd (int argc, char **argv) | 60 | @@ -118,9 +118,9 @@ invoke_gsyncd(int argc, char **argv) |
60 | goto error; | 61 | goto error; |
61 | 62 | ||
62 | j = 0; | 63 | j = 0; |
63 | - python = getenv("PYTHON"); | 64 | - python = getenv("PYTHON"); |
64 | + python = getenv("TARGET_PYTHON"); | 65 | + python = getenv("TARGET_PYTHON"); |
65 | if(!python) | 66 | if (!python) |
66 | - python = PYTHON; | 67 | - python = PYTHON; |
67 | + python = TARGET_PYTHON; | 68 | + python = TARGET_PYTHON; |
68 | nargv[j++] = python; | 69 | nargv[j++] = python; |
69 | nargv[j++] = GSYNCD_PREFIX"/python/syncdaemon/"GSYNCD_PY; | 70 | nargv[j++] = GSYNCD_PREFIX "/python/syncdaemon/" GSYNCD_PY; |
70 | for (i = 1; i < argc; i++) | 71 | for (i = 1; i < argc; i++) |
71 | @@ -205,7 +205,7 @@ find_gsyncd (pid_t pid, pid_t ppid, char *name, void *data) | 72 | @@ -170,7 +170,7 @@ find_gsyncd(pid_t pid, pid_t ppid, char *name, void *data) |
72 | ret = 0; | 73 | ret = 0; |
73 | switch (zeros) { | 74 | switch (zeros) { |
74 | case 2: | 75 | case 2: |
75 | - if ((strcmp (basename (buf), basename (PYTHON)) || | 76 | - if ((strcmp(basename(buf), basename(PYTHON)) || |
76 | + if ((strcmp (basename (buf), basename (TARGET_PYTHON)) || | 77 | + if ((strcmp (basename (buf), basename (TARGET_PYTHON)) || |
77 | strcmp (basename (buf + strlen (buf) + 1), GSYNCD_PY)) == 0) { | 78 | strcmp(basename(buf + strlen(buf) + 1), GSYNCD_PY)) == 0) { |
78 | ret = 1; | 79 | ret = 1; |
79 | break; | 80 | break; |
81 | -- | ||
82 | 2.17.1 | ||
83 | |||