summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-openstack/recipes-devtools/python/python-monotonic_git.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-monotonic_git.bb b/meta-openstack/recipes-devtools/python/python-monotonic_git.bb
new file mode 100644
index 0000000..2552409
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-monotonic_git.bb
@@ -0,0 +1,31 @@
1DESCRIPTION = "An implementation of time.monotonic()"
2HOMEPAGE = "https://github.com/atdt/monotonic"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=d2794c0df5b907fdace235a619d80314"
6
7PV = "0.4"
8SRCREV = "93b3d3ba63597e57b20333db4e33ca0f48debf2a"
9
10SRCNAME = "monotonic"
11SRC_URI = "git://github.com/atdt/${SRCNAME}.git"
12
13S = "${WORKDIR}/git"
14
15inherit distutils
16
17DEPENDS += " \
18 python-pbr \
19 "
20
21RDEPENDS_${PN} += " \
22 python-pbr \
23 "
24
25do_install_append() {
26 # Using these "longest" paths will ensure needed shorter paths will be created
27 install -d ${D}/${libdir}/python2.7/site-packages/${SRCNAME}.egg-info
28
29 install -m 644 ${S}/${SRCNAME}.py ${D}/${libdir}/python2.7/site-packages/
30 install -m 644 ${S}/${SRCNAME}.egg-info/* ${D}/${libdir}/python2.7/site-packages/${SRCNAME}.egg-info/
31}