diff options
Diffstat (limited to 'recipes-support/spice/files/build-allow-separated-src-and-build-dirs.patch')
-rw-r--r-- | recipes-support/spice/files/build-allow-separated-src-and-build-dirs.patch | 62 |
1 files changed, 0 insertions, 62 deletions
diff --git a/recipes-support/spice/files/build-allow-separated-src-and-build-dirs.patch b/recipes-support/spice/files/build-allow-separated-src-and-build-dirs.patch deleted file mode 100644 index 9cbbff9..0000000 --- a/recipes-support/spice/files/build-allow-separated-src-and-build-dirs.patch +++ /dev/null | |||
@@ -1,62 +0,0 @@ | |||
1 | From 7d0d0ff080b159e647ebb26c337cb75314d64b52 Mon Sep 17 00:00:00 2001 | ||
2 | From: Mark Asselstine <mark.asselstine@windriver.com> | ||
3 | Date: Thu, 1 May 2014 12:09:16 -0400 | ||
4 | Subject: [PATCH] build: allow separated src and build dirs | ||
5 | |||
6 | We need to expland the list of include dirs to include the build dir since | ||
7 | generated files will be created there instead of in the src dir. | ||
8 | |||
9 | We also don't want to force using $srcdir for generated files as this will | ||
10 | allow them to be created in the build dir. We account for the slight | ||
11 | deviation in the generated files with expanded include paths. | ||
12 | |||
13 | Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> | ||
14 | --- | ||
15 | configure.ac | 2 +- | ||
16 | spice-common/common/Makefile.am | 14 +++++++------- | ||
17 | 2 file changed, 8 insertions(+), 8 deletions(-) | ||
18 | |||
19 | diff --git a/configure.ac b/configure.ac | ||
20 | index edda8e9..9151fcb 100644 | ||
21 | --- a/configure.ac | ||
22 | +++ b/configure.ac | ||
23 | @@ -165,7 +165,7 @@ dnl ========================================================================= | ||
24 | dnl Check deps | ||
25 | |||
26 | AC_CONFIG_SUBDIRS([spice-common]) | ||
27 | -COMMON_CFLAGS='-I ${top_srcdir}/spice-common/ -I ${top_srcdir}/spice-common/spice-protocol/' | ||
28 | +COMMON_CFLAGS='-I ${top_srcdir}/spice-common/ -I ${top_srcdir}/spice-common/common/ -I ${top_srcdir}/spice-common/spice-protocol/ -I ${top_builddir}/spice-common/' | ||
29 | AC_SUBST(COMMON_CFLAGS) | ||
30 | |||
31 | AC_CHECK_LIBM | ||
32 | diff --git a/spice-common/common/Makefile.am b/spice-common/common/Makefile.am | ||
33 | index 45568c6..4c65ac4 100644 | ||
34 | --- a/spice-common/common/Makefile.am | ||
35 | +++ b/spice-common/common/Makefile.am | ||
36 | @@ -2,16 +2,16 @@ NULL = | ||
37 | |||
38 | # Avoid need for python(pyparsing) by end users | ||
39 | CLIENT_MARSHALLERS = \ | ||
40 | - $(srcdir)/generated_client_demarshallers.c \ | ||
41 | - $(srcdir)/generated_client_demarshallers1.c \ | ||
42 | - $(srcdir)/generated_client_marshallers.c \ | ||
43 | - $(srcdir)/generated_client_marshallers1.c \ | ||
44 | + generated_client_demarshallers.c \ | ||
45 | + generated_client_demarshallers1.c \ | ||
46 | + generated_client_marshallers.c \ | ||
47 | + generated_client_marshallers1.c \ | ||
48 | $(NULL) | ||
49 | |||
50 | SERVER_MARSHALLERS = \ | ||
51 | - $(srcdir)/generated_server_demarshallers.c \ | ||
52 | - $(srcdir)/generated_server_marshallers.c \ | ||
53 | - $(srcdir)/generated_server_marshallers.h \ | ||
54 | + generated_server_demarshallers.c \ | ||
55 | + generated_server_marshallers.c \ | ||
56 | + generated_server_marshallers.h \ | ||
57 | $(NULL) | ||
58 | |||
59 | BUILT_SOURCES = $(CLIENT_MARSHALLERS) $(SERVER_MARSHALLERS) $(top_srcdir)/spice-protocol/spice/enums.h | ||
60 | -- | ||
61 | 1.8.3.2 | ||
62 | |||