diff options
author | Naveen Saini <naveen.kumar.saini@intel.com> | 2022-10-21 09:40:50 +0800 |
---|---|---|
committer | Anuj Mittal <anuj.mittal@intel.com> | 2022-10-31 10:01:01 +0800 |
commit | 12900bd7b17d18eb05ed9e7ad337cb6d861eef00 (patch) | |
tree | 13c44629df023bd0b7307fee4616001b18bde482 /dynamic-layers/clang-layer/recipes-support/xdp-tools/xdp-tools/0002-Makefile-It-does-not-detect-libbpf-header-from-sysro.patch | |
parent | f6895c0dd2e6add213eb16bcf041af50ad2ec153 (diff) | |
download | meta-dpdk-12900bd7b17d18eb05ed9e7ad337cb6d861eef00.tar.gz |
xdp-tools: add recipe
xdp-tools - Library and utilities for use with XDP.
It also provides libxdp library.
https://github.com/xdp-project/xdp-tools
Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com>
Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
Diffstat (limited to 'dynamic-layers/clang-layer/recipes-support/xdp-tools/xdp-tools/0002-Makefile-It-does-not-detect-libbpf-header-from-sysro.patch')
-rw-r--r-- | dynamic-layers/clang-layer/recipes-support/xdp-tools/xdp-tools/0002-Makefile-It-does-not-detect-libbpf-header-from-sysro.patch | 44 |
1 files changed, 44 insertions, 0 deletions
diff --git a/dynamic-layers/clang-layer/recipes-support/xdp-tools/xdp-tools/0002-Makefile-It-does-not-detect-libbpf-header-from-sysro.patch b/dynamic-layers/clang-layer/recipes-support/xdp-tools/xdp-tools/0002-Makefile-It-does-not-detect-libbpf-header-from-sysro.patch new file mode 100644 index 0000000..2e66783 --- /dev/null +++ b/dynamic-layers/clang-layer/recipes-support/xdp-tools/xdp-tools/0002-Makefile-It-does-not-detect-libbpf-header-from-sysro.patch | |||
@@ -0,0 +1,44 @@ | |||
1 | From 2840cf0b89497f545fae2eed7ece3f3c5fc558e3 Mon Sep 17 00:00:00 2001 | ||
2 | From: Naveen Saini <naveen.kumar.saini@intel.com> | ||
3 | Date: Mon, 17 Oct 2022 15:50:34 +0800 | ||
4 | Subject: [PATCH 2/4] Makefile: It does not detect libbpf header from sysroot | ||
5 | |||
6 | So adding sysroot headers path. | ||
7 | |||
8 | Upstream-Status: OE-Specific | ||
9 | |||
10 | Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com> | ||
11 | --- | ||
12 | lib/common.mk | 2 +- | ||
13 | lib/libxdp/Makefile | 2 +- | ||
14 | 2 files changed, 2 insertions(+), 2 deletions(-) | ||
15 | |||
16 | diff --git a/lib/common.mk b/lib/common.mk | ||
17 | index 56c0406..ab0bad8 100644 | ||
18 | --- a/lib/common.mk | ||
19 | +++ b/lib/common.mk | ||
20 | @@ -55,7 +55,7 @@ LIBXDP_SOURCES := $(wildcard $(LIBXDP_DIR)/*.[ch] $(LIBXDP_DIR)/*.in) | ||
21 | KERN_USER_H ?= $(wildcard common_kern_user.h) | ||
22 | |||
23 | CFLAGS += -I$(HEADER_DIR) -I$(LIB_DIR)/util $(ARCH_INCLUDES) | ||
24 | -BPF_CFLAGS += -I$(HEADER_DIR) $(ARCH_INCLUDES) | ||
25 | +BPF_CFLAGS += -I$(HEADER_DIR) $(ARCH_INCLUDES) -I${STAGING_INCDIR}/ | ||
26 | |||
27 | BPF_HEADERS := $(wildcard $(HEADER_DIR)/bpf/*.h) $(wildcard $(HEADER_DIR)/xdp/*.h) | ||
28 | |||
29 | diff --git a/lib/libxdp/Makefile b/lib/libxdp/Makefile | ||
30 | index 358b751..8f459d8 100644 | ||
31 | --- a/lib/libxdp/Makefile | ||
32 | +++ b/lib/libxdp/Makefile | ||
33 | @@ -30,7 +30,7 @@ PC_FILE := $(OBJDIR)/libxdp.pc | ||
34 | TEMPLATED_SOURCES := xdp-dispatcher.c | ||
35 | |||
36 | CFLAGS += -I$(HEADER_DIR) | ||
37 | -BPF_CFLAGS += -I$(HEADER_DIR) | ||
38 | +BPF_CFLAGS += -I$(HEADER_DIR) -I${STAGING_INCDIR}/ | ||
39 | |||
40 | |||
41 | ifndef BUILD_STATIC_ONLY | ||
42 | -- | ||
43 | 2.25.1 | ||
44 | |||