diff options
Diffstat (limited to 'recipes-extended/dpdk/dpdk_23.11.1.bb')
-rw-r--r-- | recipes-extended/dpdk/dpdk_23.11.1.bb | 71 |
1 files changed, 71 insertions, 0 deletions
diff --git a/recipes-extended/dpdk/dpdk_23.11.1.bb b/recipes-extended/dpdk/dpdk_23.11.1.bb new file mode 100644 index 0000000..e7a0a23 --- /dev/null +++ b/recipes-extended/dpdk/dpdk_23.11.1.bb | |||
@@ -0,0 +1,71 @@ | |||
1 | include dpdk.inc | ||
2 | |||
3 | SRC_URI += " file://0001-config-meson-get-cpu_instruction_set-from-meson-opti.patch " | ||
4 | |||
5 | STABLE = "-stable" | ||
6 | BRANCH = "23.11" | ||
7 | SRCREV = "a6ec5765cf83d3d58cbd6d4ed5b92b4a06f8a808" | ||
8 | S = "${WORKDIR}/git" | ||
9 | |||
10 | def get_cpu_instruction_set(bb, d): | ||
11 | import re | ||
12 | march = re.search(r'-march=([^\s]*)', d.getVar('CC')) | ||
13 | if march: | ||
14 | return march.group(1) | ||
15 | else: | ||
16 | return "core2" | ||
17 | |||
18 | EXTRA_OEMESON = " -Dexamples=all -Dcpu_instruction_set=${@get_cpu_instruction_set(bb, d)} " | ||
19 | |||
20 | COMPATIBLE_MACHINE = "null" | ||
21 | COMPATIBLE_HOST:libc-musl:class-target = "null" | ||
22 | COMPATIBLE_HOST:linux-gnux32 = "null" | ||
23 | |||
24 | PACKAGECONFIG ??= " " | ||
25 | PACKAGECONFIG[afxdp] = ",,libbpf xdp-tools" | ||
26 | PACKAGECONFIG[libvirt] = ",,libvirt" | ||
27 | |||
28 | RDEPENDS:${PN} += "pciutils python3-core" | ||
29 | RDEPENDS:${PN}-examples += "bash" | ||
30 | DEPENDS = "numactl python3-pyelftools-native" | ||
31 | |||
32 | inherit meson pkgconfig | ||
33 | |||
34 | INSTALL_PATH = "${prefix}/share/dpdk" | ||
35 | |||
36 | do_install:append(){ | ||
37 | # remove source files | ||
38 | rm -rf ${D}/${INSTALL_PATH}/examples/* | ||
39 | |||
40 | # Install examples | ||
41 | install -m 0755 -d ${D}/${INSTALL_PATH}/examples/ | ||
42 | for dirname in ${B}/examples/dpdk-* | ||
43 | do | ||
44 | if [ ! -d ${dirname} ] && [ -x ${dirname} ]; then | ||
45 | install -m 0755 ${dirname} ${D}/${INSTALL_PATH}/examples/ | ||
46 | fi | ||
47 | done | ||
48 | |||
49 | } | ||
50 | |||
51 | PACKAGES =+ "${PN}-examples ${PN}-tools" | ||
52 | |||
53 | FILES:${PN} += " ${bindir}/dpdk-testpmd \ | ||
54 | ${bindir}/dpdk-proc-info \ | ||
55 | ${libdir}/*.so* \ | ||
56 | ${libdir}/dpdk/pmds-24.0/*.so* \ | ||
57 | " | ||
58 | FILES:${PN}-examples = " \ | ||
59 | ${prefix}/share/dpdk/examples/* \ | ||
60 | " | ||
61 | |||
62 | FILES:${PN}-tools = " \ | ||
63 | ${bindir}/dpdk-pdump \ | ||
64 | ${bindir}/dpdk-test \ | ||
65 | ${bindir}/dpdk-test-* \ | ||
66 | ${bindir}/dpdk-*.py \ | ||
67 | " | ||
68 | |||
69 | CVE_PRODUCT = "data_plane_development_kit" | ||
70 | |||
71 | INSANE_SKIP:${PN} = "dev-so" | ||