summaryrefslogtreecommitdiffstats
path: root/recipes-extended/dpdk/dpdk_23.11.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-extended/dpdk/dpdk_23.11.1.bb')
-rw-r--r--recipes-extended/dpdk/dpdk_23.11.1.bb71
1 files changed, 71 insertions, 0 deletions
diff --git a/recipes-extended/dpdk/dpdk_23.11.1.bb b/recipes-extended/dpdk/dpdk_23.11.1.bb
new file mode 100644
index 0000000..e7a0a23
--- /dev/null
+++ b/recipes-extended/dpdk/dpdk_23.11.1.bb
@@ -0,0 +1,71 @@
1include dpdk.inc
2
3SRC_URI += " file://0001-config-meson-get-cpu_instruction_set-from-meson-opti.patch "
4
5STABLE = "-stable"
6BRANCH = "23.11"
7SRCREV = "a6ec5765cf83d3d58cbd6d4ed5b92b4a06f8a808"
8S = "${WORKDIR}/git"
9
10def get_cpu_instruction_set(bb, d):
11 import re
12 march = re.search(r'-march=([^\s]*)', d.getVar('CC'))
13 if march:
14 return march.group(1)
15 else:
16 return "core2"
17
18EXTRA_OEMESON = " -Dexamples=all -Dcpu_instruction_set=${@get_cpu_instruction_set(bb, d)} "
19
20COMPATIBLE_MACHINE = "null"
21COMPATIBLE_HOST:libc-musl:class-target = "null"
22COMPATIBLE_HOST:linux-gnux32 = "null"
23
24PACKAGECONFIG ??= " "
25PACKAGECONFIG[afxdp] = ",,libbpf xdp-tools"
26PACKAGECONFIG[libvirt] = ",,libvirt"
27
28RDEPENDS:${PN} += "pciutils python3-core"
29RDEPENDS:${PN}-examples += "bash"
30DEPENDS = "numactl python3-pyelftools-native"
31
32inherit meson pkgconfig
33
34INSTALL_PATH = "${prefix}/share/dpdk"
35
36do_install:append(){
37 # remove source files
38 rm -rf ${D}/${INSTALL_PATH}/examples/*
39
40 # Install examples
41 install -m 0755 -d ${D}/${INSTALL_PATH}/examples/
42 for dirname in ${B}/examples/dpdk-*
43 do
44 if [ ! -d ${dirname} ] && [ -x ${dirname} ]; then
45 install -m 0755 ${dirname} ${D}/${INSTALL_PATH}/examples/
46 fi
47 done
48
49}
50
51PACKAGES =+ "${PN}-examples ${PN}-tools"
52
53FILES:${PN} += " ${bindir}/dpdk-testpmd \
54 ${bindir}/dpdk-proc-info \
55 ${libdir}/*.so* \
56 ${libdir}/dpdk/pmds-24.0/*.so* \
57 "
58FILES:${PN}-examples = " \
59 ${prefix}/share/dpdk/examples/* \
60 "
61
62FILES:${PN}-tools = " \
63 ${bindir}/dpdk-pdump \
64 ${bindir}/dpdk-test \
65 ${bindir}/dpdk-test-* \
66 ${bindir}/dpdk-*.py \
67 "
68
69CVE_PRODUCT = "data_plane_development_kit"
70
71INSANE_SKIP:${PN} = "dev-so"